I don't know how to make my microphone working manjaro i3

Hello,

I am running manjaro i3 on my computer in dual boot with windows 10.

The mic on windows 10 is working very well but I have tried fixing it on my manjaro for hours without success.

I have alsamixer (don't know how to use it xd) and I have downloaded pulseaudio (I can't lunch it) and pavucontrol.

I have no idea how to fix microphone, before my mic was doing some sound like if I had a bad mic (no difference if I talk or not). Now I have tried to change some options and it does nothing at all.

I hope you can help me with that, feel free to ask if you need any additional info.

I don't know if it can help but on my motherboard has only 2 entry for mic and for headphone.
A green and blue one.

On my headset I have two colors, green and pink, the green goes to green and I put the pink one inside of the blue one.

I don't know what the colors mean but actually it works on windows not on manjaro :frowning:

Please post screenshots of the two last tabs in pavucontrol and the alsamixer (press F4 in alsamixer to show capture devices).

green is correct socket for headphone/speakers

pink is standard colour for microphone, blue is for line-in
so this is the correct socket for plugging in microphone, but ALSA may need to be configured for mono microphone instead of stereo line-in

get full ALSA information with alsa-info.sh --upload
and post the link to data uploaded to alsa-project here
data will include text information equivalent to settings visible in alsamixer

microphone may just need to be turned on or level turned up
i can explain how to do that in alsamixer if i know more about the audio devices on this system

Hey,

Thank you for your answers.

Here are the screens Photon asked:

DeepinScreenshot_20200718134531

DeepinScreenshot_20200718134537

DeepinScreenshot_20200718134611

Link for sudo alsa-info.sh --upload:
http://alsa-project.org/db/?f=c9c65795316eae93955f30422a937f335f71510a

I also have tried without sudo but it says that an operation was not permited

Pulseaudio Profile for Built-in Audio is set to Analog Stereo Output

for microphone input device in Pulseaudio change Profile to Analog Stereo Duplex

Hey,

How to do that? :confused:

I have tried to change in pavucontrol, now I have this
DeepinScreenshot_20200718154704

But the mic is still not working :frowning:

If you don't use HDMI audio, disable it by selecting the "Disabled" profile in pavucontrol. Sometimes HDMI interferes with other audio channels.

I put these options

DeepinScreenshot_pavucontrol_20200718161403

Still not working :frowning:

I have many people who's mic is not working btw, they need two accounts on discord, one for share screen and the other one to talk with their phone :frowning: all with manjaro.

Can you please show how the "Input devices" tab looks now?

Here it is

DeepinScreenshot_pavucontrol_20200718220158

Now the sound looks like if someone was continuously blowing to a mic (nothing change if I speak or not)

Looks good now. Any improvement if you try different ports (above the volume slider)?

You mean in place of "Line In"? I have only "microphone (unplugged)" and not working too

It looks to me like you should plug in your microphone into the microphone "hole", then choose the "microphone" entry. But as you stated, there is no pink one, only a blue one, which is line in.

Which motherboard do you use?

edit: I looked into your ALSA report, found it. The mic input is on the front, did you try that one?

No, I did not try the mic in front.

But I have some weird noises in my headphone when I plug it in front :frowning: that why this option is impossible :frowning:

But it works well on windows in this input, don't know why it does not work in linux.

For the motherboard:

sudo dmidecode -t baseboard :

# dmidecode 3.2
Getting SMBIOS data from sysfs.
SMBIOS 2.7 present.

Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
	Manufacturer: Hewlett-Packard
	Product Name: 3396
	Version: Not Specified
	Serial Number: CZC33447F8
	Asset Tag: CZC33447F8
	Features:
		Board is a hosting board
		Board is removable
		Board is replaceable
	Location In Chassis: Not Specified
	Chassis Handle: 0x0003
	Type: Motherboard
	Contained Object Handles: 0

Handle 0x000B, DMI type 41, 11 bytes
Onboard Device
	Reference Designation:  Onboard VGA
	Type: Video
	Status: Disabled
	Type Instance: 1
	Bus Address: 0000:00:02.0

Handle 0x000C, DMI type 41, 11 bytes
Onboard Device
	Reference Designation:  Onboard LAN
	Type: Ethernet
	Status: Enabled
	Type Instance: 1
	Bus Address: 0000:00:19.0

In your alsamixer screenshot, the two switches on the right have "Mic" as "Input Source". Maybe this needs to be changed to "Line In". You can do so by navigating with left/right arrow buttons and going through the possible values with the up/down arrow buttons.

alsamixer screenshot in post#4 is showing 2 Capture channels followed by controls for Input Source

Capture is turned on and Input Source is set to Mic

Capture 1 is turned off but Input Source 1 is also set to Mic

both capture channels connected to the microphone for audio capture might be causing some problems with microphone audio

suggest go to

alsamixer --card=1 --view=Capture

select Input Source 1 and change it to Line (or anything else that is not Mic)

Esc to exit and then save new ALSA settings

sudo alsactl store

I have changed the settings to "line":

DeepinScreenshot_urxvt_20200719124251

Still not working :confused: maybe I need to change the sound somewhere to enable it?

When I run

alsamixer --card=1 --view=Capture

I get this result:

DeepinScreenshot_urxvt_20200719122624

You're seeing your HDMI device, switch to your integrated sound with F6.

1 Like

alsamixer --card=1 --view=Capture was suggested because the onboard audio is shown as 2nd audio card in pavucontrol
if there are only 2 devices, and pulseaudio card order does not follow same order as ALSA

use F6 as suggested to change cards

or

alsamixer --card=0 --view=Capture
1 Like

I have done with the other card and set it to line:

DeepinScreenshot_urxvt_20200722181011

Still not working :cry:

Forum kindly sponsored by