I installed manjaro, and I can access it through "EFI bootloader" but when I restart without the USB I get a GRUB prompt

Disk /dev/sdd: 931.53 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: ST1000LX015-1U71
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: AC3C54AC-78CA-42DE-85B8-2969494659FF

Device       Start        End    Sectors  Size Type
/dev/sdd1     2048    1050623    1048576  512M EFI System
/dev/sdd2  1050624 1953523711 1952473088  931G Linux filesystem


Disk /dev/sde: 476.96 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: SanDisk SDSSDH35
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 246252F3-75F8-E543-9D43-D749D3EF629D

Device      Start        End   Sectors   Size Type
/dev/sde1    4096     618495    614400   300M EFI System
/dev/sde2  618496 1000206899 999588404 476.7G Linux filesystem

These look to be two GNU/Linux installations. Can you say which is which?

Please post
efibootmgr -v
and
sudo blkid

I updated my BIOS
also here's the output of efibootmgr -v

BootCurrent: 0008
Timeout: 1 seconds
BootOrder: 0008,0004,0005,0007,0001,0002,0006
Boot0001  Hard Drive    BBS(HD,,0x0)/VenHw(5ce8128b-2cec-40f0-8372-80640e3dc858,0200)..GO..NO..........W.D.C. .W.D.2.5.0.2.A.B.Y.S.-.0.2.B.7.A.0...................\.,.@.r.d.=.X..........A.................................>..Gd-.;.A..MQ..L. . . . .W. .-.D.C.W.T.A.H.1.5.8.2.8.2.9........BO..NO..........S.T.2.0.0.0.V.N.0.0.4.-.2.E.4.1.6.4...................\.,.@.r.d.=.X..........A.................................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .5.Z.5.2.C.H.C.Z........BO..NO..........S.T.1.0.0.0.L.X.0.1.5.-.1.U.7.1.7.2...................\.,.@.r.d.=.X..........A.................................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .D.Z.H.E.3.X.D.0........BO..NO..........S.a.n.D.i.s.k. .S.D.S.S.D.H.3.5.1.2.G...................\.,.@.r.d.=.X..........A.................................>..Gd-.;.A..MQ..L.9.1.7.1.7.5.0.8.2.4.0.5. . . . . . . . ........BO
Boot0002  CD/DVD Drive  BBS(CDROM,,0x0)/VenHw(5ce8128b-2cec-40f0-8372-80640e3dc858,0300)..GO..NO..........T.S.S.T.c.o.r.p. .C.D.D.V.D.W. .S.H.-.2.2.4.D.B...................\.,.@.r.d.=.X..........A.................................>..Gd-.;.A..MQ..L.9.R.E.3.8.6.F.E.0.A.A.0.B.E. . . . . . ........BO
Boot0004* ubuntu        HD(1,GPT,5521496f-8c93-41c9-95a4-bf95cc7cd596,0x800,0x100000)/File(\EFI\UBUNTU\SHIMX64.EFI)..BO
Boot0005* UEFI OS       HD(1,GPT,056e013a-dcba-9247-9a08-8d1c5f996f61,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)..BO
Boot0006  USB KEY       BBS(HD,,0x0)/VenHw(5ce8128b-2cec-40f0-8372-80640e3dc858,0b00)..GO..NO..........S.a.n.D.i.s.k...................\.,.@.r.d.=.X..........A.............................>..Gd-.;.A..MQ..L.4.C.5.3.1.0.0.1.5.9.0.4.0.3.1.1.4.5.4.2........BO
Boot0007* UEFI: SanDisk PciRoot(0x0)/Pci(0x7,0x1)/Pci(0x0,0x3)/USB(0,0)/CDROM(1,0x5ab7e8,0x8000)..BO
Boot0008* UEFI: SanDisk, Partition 2    PciRoot(0x0)/Pci(0x7,0x1)/Pci(0x0,0x3)/USB(0,0)/HD(2,MBR,0x0,0x5ab7e8,0x2000)..BO```

And here is sudo blkid

/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/sda: PTUUID="9a466f20-90cd-944b-b422-d2c78e433d3a" PTTYPE="gpt"
/dev/sdb: LABEL="Library_of_alex" UUID="cb91606d-fa0e-44d8-946a-d89839751938" BLOCK_SIZE="4096" TYPE="ext4"
/dev/sdc1: BLOCK_SIZE="2048" UUID="2020-03-11-13-57-55-00" LABEL="MANJARO_KDE_1902" TYPE="iso9660"
/dev/sdc2: SEC_TYPE="msdos" LABEL_FATBOOT="MISO_EFI" LABEL="MISO_EFI" UUID="CE99-60AE" BLOCK_SIZE="512" TYPE="vfat"
/dev/sdd1: UUID="6472-8E2B" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="5521496f-8c93-41c9-95a4-bf95cc7cd596"
/dev/sdd2: LABEL="TurtleSSD" UUID="be39440a-1299-416e-9b7b-9300ea906c9c" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="ee90624a-253a-4d15-a612-3ab9fa76e75a"
/dev/sde1: UUID="4A80-0697" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="056e013a-dcba-9247-9a08-8d1c5f996f61"
/dev/sde2: UUID="893e1fde-1bab-4edb-9b4c-6be9788ccc38" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="db7c0c07-1601-134d-aa36-1d062b2396a2"
/dev/sr0: BLOCK_SIZE="2048" UUID="2015-06-30-10-42-39-00" LABEL="CD373A1" TYPE="iso9660"```
I hope this helps

Try the following first and see if you get to boot up Manjaro correctly. In your Manjaro live usb, open a terminal and run:

sudo efibootmgr -o 0008,0005,0004,0007,0001,0002,0006

Shutdown. Remove the usb and powerup your machine.

ok so I did it (adjusted because I had been doing things in between replies) but when I restart it goes back to it's original configuration.

Not knowning the "current state of the affairs", I can only suggest to reistall Manjaro's bootloader following the guide below:

Or:

https://wiki.manjaro.org/index.php?title=GRUB/Restore_the_GRUB_Bootloader

I have done both of those. I don't know how I can help, but I can give you the list of boot options and it's current order:

BootCurrent: 0011
Timeout: 1 seconds
BootOrder: 0011,0004,0000,000F,000D,0005,0012,0001,0002,0010
Boot0000* Manjaro
Boot0001  Hard Drive
Boot0002  CD/DVD Drive
Boot0004* ubuntu
Boot0005* UEFI OS
Boot000A  USB KEY
Boot000D* UEFI OS
Boot000F* UEFI OS
Boot0010  USB KEY
Boot0011* UEFI: SanDisk
Boot0012* UEFI: SanDisk, Partition 2

I do not have ubuntu installed on any drive and haven't for over a month so I do not know why it is considered an option. I think that's the problem though.

Try going into the bios/firmware settings and find your way to boot options/devices (or some such) and move Manjaro to top of the list. Sve the settings and reboot and see if it will work.

1 Like

ok I will try that and report back

ok so I did it, and I still got the grub prompt, but since I was there and reinstalled grub I decided to try your previous links again.
grub> echo $grub_platform
produced: efi
and grub> search.file /etc/manjaro-release root worked (at least it didn't have an error)
but when I did grub> configfile /boot/grub/grub.cfg
it gave an error https://imgur.com/gallery/wQeqPFL but the interesting thing about it is that when I pressed a key as it said it just booted to manjaro like I always wanted. I did this again and it still fails but it also still does the same thing and boots into manjaro after the error.

Try (re) creating grubenv

sudo grub-editenv /boot/grub/grubenv create

1 Like

ok trying that now I'll report back

1 Like

ok so when I went through the steps again, the initial error when I execute grub> configfile /boot/grub/grub.cfg I get this error which quickly redirects to the error I showed you in the last post. I can't find much on it on google.

I feel I have run out of ideas here.

Please read the previous link carefully once more and perhaps you would need to do "If grub is really messed up" part from chroot environment since you can no longer boot into your system. Adapt the commands to correspond to your disk setup.

If nothing helps, perhaps wiping the whole drive, creating a new partition table (GPT) and re-installing could be the last option unless @stephane or other forum members can come up with some remedy.

1 Like

thank you, you did your best. My last question is is there a way to automate the input of those two commands so that it goes through that whole process automatically? if not thats fine. Thanks for all the help, I feel so much closer to figuring it out than I was at the beginning.

1 Like

Not sure which ones.

These two
grub> search.file /etc/manjaro-release root
grub> configfile /boot/grub/grub.cfg
?

yes those commands

Not really. I am not aware of any way to that.

1 Like

ok that's fine. thanks again for all the help!

You are welcome! Hope you get it resolved soon!

:crossed_fingers:

Forum kindly sponsored by