I installed manjaro, and I can access it through "EFI bootloader" but when I restart without the USB I get a GRUB prompt

ok so I did it, and I still got the grub prompt, but since I was there and reinstalled grub I decided to try your previous links again.
grub> echo $grub_platform
produced: efi
and grub> search.file /etc/manjaro-release root worked (at least it didn't have an error)
but when I did grub> configfile /boot/grub/grub.cfg
it gave an error https://imgur.com/gallery/wQeqPFL but the interesting thing about it is that when I pressed a key as it said it just booted to manjaro like I always wanted. I did this again and it still fails but it also still does the same thing and boots into manjaro after the error.

Try (re) creating grubenv

sudo grub-editenv /boot/grub/grubenv create

1 Like

ok trying that now I'll report back

1 Like

ok so when I went through the steps again, the initial error when I execute grub> configfile /boot/grub/grub.cfg I get this error which quickly redirects to the error I showed you in the last post. I can't find much on it on google.

I feel I have run out of ideas here.

Please read the previous link carefully once more and perhaps you would need to do "If grub is really messed up" part from chroot environment since you can no longer boot into your system. Adapt the commands to correspond to your disk setup.

If nothing helps, perhaps wiping the whole drive, creating a new partition table (GPT) and re-installing could be the last option unless @stephane or other forum members can come up with some remedy.

1 Like

thank you, you did your best. My last question is is there a way to automate the input of those two commands so that it goes through that whole process automatically? if not thats fine. Thanks for all the help, I feel so much closer to figuring it out than I was at the beginning.

1 Like

Not sure which ones.

These two
grub> search.file /etc/manjaro-release root
grub> configfile /boot/grub/grub.cfg
?

yes those commands

Not really. I am not aware of any way to that.

1 Like

ok that's fine. thanks again for all the help!

You are welcome! Hope you get it resolved soon!

:crossed_fingers:

we can check moutpoint for EFI manjaro if is installed
boot on iso USB manjaro ( not your disk )
open a terminal and a browser on this topic

manjaro-chroot -a 
cat /etc/fstab ( see UUID /boot/efi )
lsblk -fs  ( you should see here same UUID ) 
efibootmgr -v ( check EFI is ok )

ok so after doing more tweaking I finally got it to not give missing file errors in grub. After that I was looking around in the BIOS and found a second boot order hidden in the menus, and I found ubuntu first and manjaro second. I flipped them and now it works. THANK YOU SO MUCH FOR ALL OF YOUR HELP I LOVE YOU ALL!

1 Like

dont forget on any update ubuntu ,
use USB manjaro ,
chroot and update-grub in this case

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by