i installed openbox but screen wont open on top of majaro xfce

screen wont change resolution and pamac wont install programs i know policykit is installed

I am sorry, but you will probably need to be a little more explanatory than that ..
(where did you start? what did you do? what happens? what do you expect?)
[ bonus - system info = inxi -Fxxxza --no-host ]

Manjaro community members cannot be required to guess what you mean.

Please provide adequate information about your issue.

This is a known issue with all Arch based distributions. The default display emulation is VMSVGA - Manjaro recommendation is to use VBoxSVGA.

Change your virtual machine to use VBoxSVGA instead of VMSVGA.


In Xfce or Openbox? What is the message?

Please update your system when you install packages

sudo pacman -Syu pkgname

ok i updated the system but in pamac it says athentication failed

maybe i neeed to edit a config in polkit to allow openbox to see it?

o ined to create this file and in desktop entry write openbox?

cat .config/autostart/polkit.desktop

[Desktop Entry]
Name=polkit agent
Comment=polkit agent
Exec=/usr/lib/polkit-1-dde/dde-polkit-agent
Terminal=false
Type=Application
NoDisplay=true

This topic is clearly a case of an xy problem because Openbox - both the minimal and the full edition works OOB.

dde-polkit - this sounds a lot like a Deepin application - and has nothing to do with either Openbox or Xfce.

Gnome polkit agent is started in ~/.config/openbox/autorun so there is no need to create extra launchers.

If you have been messing around in the system - with no clear history of what you have done and what not - this is an impossible task - I won't help you with that.

Still I would like to know which version of Openbox you have installed and if you have installed it in VirtualBox.

i intalled it on manjaro xfce i loged in and my screen was not set i did some research fixed my tint2 fixed my display and now i am reading on how to fix the authentication failed error but i dont really need it but i am learning on the fly currently i am installing polybar

I see - you didn't install an Openbox edition - you installed the package openbox from the repo and now you are in the process of configuring it.

That is an important piece of information - you should have specified that.

yes sir i fixed everything and now i think i have to add either polkit or PolicyKit Authentication Agent to autostart now my question is do i put exactly gnome-polkit and PolicyKit Authentication Agent in .config/aurostart?

i am sorry about not specifying

and how would i install manjaro openbox through terminal i tried a couple of things but it wont work

i solved it by adding /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 & eval $(gnome-keyring-daemon -s --components=pkcs11,secrets,ssh,gpg) & to autostart now pamac is working with no authentication error

hello i have a question my resolution fixed its self at 1920x1080 by its self then the a couple of hours later it reverted to not being fully opened for some reason so i made a new screen resolution with xrandr created .xprofile and saved it. there is one little issue when the 1920x1080 was working normally when i play a video there was no little black screen on the top and he bottom i crated a 1680x1050 and it has a little like margin on the top and the bottom like your watching a widescreen movie my question is there a resolution under 1920x1091 that iives almost the same output

If I understand this - your game settings change the screen resolution. I don't now anything about games.

1920x1080 is the FHD screeen resolution.

no im not playing a game its just when i watch movies there is a little bit of a black screen on top and on the bottom like im watching it in widescreen

The video may not be encoded to fit into FHD.

the command does not work on github it says run

sudo pacman -Syu - < openbox.txt --needed

Did you create the file and paste the package list from the snippet?

no im sorry i says create file what kind of file ........like a folder then open terminal?

Forum kindly sponsored by