I really like Manjaro, but...

Greetings,

I really like Manjaro, but it's deadslow on my system. My kubuntu is flying in comparison. It's like the graphic can't follow the applications I open. I tried with updating BIOS, added different grub commands, changing kernel etc. but somehow there's a bottleneck in the system. The funny thing is that the usb live session is speeding fast, but when installed it it gets laggy. It may be the infamous ryzen bug in the kernels that makes my Manjaro installation slow, but somehow it's not represented in kubuntu which uses kernel 5.4.0.

This is not a direct rant, but hopefully getting my Manjaro flying like a speedboat. I'm not sure where to start to debunk the error(s).

Oh, I really like the Manjaro community, one of the better if not the best. Kudos to that.

best regards
Storm

P.S. Now I will install Manjaro again, and hopefully I can crack the laggy bug.

Since its a rant I guess you dont want support so I guess I will just say ..
Thats surprising .. its almost assuredly up to your (mis-)configuration :wink:

2 Likes

You're a welcome to advise me. No I'm begging you. I must do something wrong, but I really don't where?

image

And yes, not the place for a support thread, open one in the correct place and post all the pertinent info, you have been here long enough to know how we work :wink:

PS check the baloo file indexer - notorious for lags on new systems

3 Likes

Thanks, I take a look :slight_smile:

And the same issue with a newly created user?

It's like it gets slower and slower with more applications/games I install. When I added a 60 GB game to Manjaro, KDE went south.

Going to eat my words. Manjaro is speedy fast when I went disabling Baloo. :open_mouth:

4 Likes

Does Kubuntu disable by default? Dunno :smiley:

60 gb game = a lot of files to index..............

...Or..
You can also configure baloo .. or let it finish indexing ... it will be quite tame when its finished its job.
For example - if you have no reason to index your steam library, exclude it, etc.
Either way .. when everything is indexed (that is - to make it near-instant searchable) it wont be bogging down the system.
That said .. if you dont need/want all of your files indexed .. you can disable baloo altogether.

2 Likes

I had an issue with this - you can eliminate your game directories (for me, it was eliminating PLEX server). I had problems with fsearch.

Similarly, if you run backups - back-in-time works well enough but does load the system, so make sure it only scans when you're not busy.

I'd suggest you sort out a basic conky so you can keep an eye on what's happening... I set mine to run for 5 minutes, so I can launch it only when I need it.

Conky

1 Like

This section following Audacious gives me running data and information about backup status:

Summary

${color2}$hr
${font :bold:size=9}${color }Top Name ${goto 120} CPU MEM ${alignr} PID${font }
${color #dddddd}${top name 1} ${goto 120}${top cpu 1} ${top mem 1}${alignr}${top pid 1}
${color #aaaaaa}${top name 2} ${goto 120}${top cpu 2} ${top mem 2}${alignr}${top pid 2}
${color #999999}${top name 3} ${goto 120}${top cpu 3} ${top mem 3}${alignr}${top pid 3}
${color #888888}${top name 4} ${goto 120}${top cpu 4} ${top mem 4}${alignr}${top pid 4}${color }
${color2}$hr
${color }${font :bold:size=9}Top Memory ${goto 120} CPU MEM ${alignr} PID ${font }
${color #dddddd}${top_mem name 1} ${goto 120} ${top_mem cpu 1} ${top_mem mem 1}${alignr}${top_mem pid 1}
${color #bbbbbb}${top_mem name 2} ${goto 120} ${top_mem cpu 2} ${top_mem mem 2}${alignr}${top_mem pid 2}
${color #aaaaaa}${top_mem name 3} ${goto 120} ${top_mem cpu 3} ${top_mem mem 3}${alignr}${top_mem pid 3}
${color #888888}${top_mem name 4} ${goto 120} ${top_mem cpu 4} ${top_mem mem 4}${alignr}${top_mem pid 4}
$color2}$hr${font :bold:size=9}${color 25C29C}
${goto 30}${utime %H%M} GMT ${alignr} ${time %A} ${time %d} ${time %B} ${time %Y}
${goto 30}Snapshot: ${goto 120} ${execi 250 ls -r -l /mnt/T3/timeshift/snapshots | sed -n '2p'| cut -c 29-40}
${goto 30}Backup: ${goto 120} ${execi 250 ls -r -l ~/.local/share/backintime | sed -n '2p'| cut -c 27-41}

It would be simple to set up a mouse shortcut (maybe draw a 7 on the desktop with the middle mouse button to launch it or kill it) in your shortcuts. I set the shortcut to point to a script:

#!/bin/bash
 if pgrep -x "conky"
    then killall conky
    else 
        conky -d -c ~/Admin/conky/network.conky
fi

Thanks guys! You're the best!

Head over and see my newly made video of Manjaro Plasma and see how well it works now. :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by