I tried everything, there's no sound in my headphone! please help.

Hello,
I have dual booted manjaro with windows 10, my headphone is working with windows 10 but not work with manjaro, I installed pulse audio controler, my headphone recognixed, but still no sound, I tried alsamixer, everything unmuted but still no sound, and I tried most of the old threads in here, nothing worked. I don't know how to fix it please help.

 Host: Kurdi-PC Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: Gnome 3.36.4 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: OMEN by HP Laptop v: N/A 
  serial: <root required> 
  Mobo: HP model: 8467 v: 68.21 serial: <root required> UEFI: AMI v: F.09 
  date: 04/24/2019 
Battery:
  ID-1: BAT0 charge: 58.6 Wh condition: 63.1/63.1 Wh (100%) 
  model: HP Primary status: Discharging 
CPU:
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 52815 
  Speed: 900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 899 2: 900 
  3: 900 4: 900 5: 901 6: 902 7: 900 8: 901 9: 900 10: 900 11: 898 12: 900 
Graphics:
  Device-1: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Hewlett-Packard 
  driver: nvidia v: 440.100 bus ID: 01:00.0 
  Display: x11 server: X.org 1.20.8 driver: nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GTX 1060 with Max-Q Design/PCIe/SSE2 
  v: 4.6.0 NVIDIA 440.100 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Device-2: NVIDIA GP106 High Definition Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k5.6.19-2-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel bus ID: 00:14.3 
  IF: wlo1 state: up mac: 0c:54:15:88:26:0b 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 3c:00.0 
  IF: eno1 state: down mac: 10:e7:c6:f7:c4:08 
Drives:
  Local Storage: total: 1.14 TiB used: 711.23 GiB (60.8%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW256HEHP-000H1 
  size: 238.47 GiB 
  ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 
  size: 931.51 GiB 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 bus ID: 00:17.0 
Partition:
  ID-1: / size: 68.40 GiB used: 10.93 GiB (16.0%) fs: ext4 
  dev: /dev/nvme0n1p7 
  ID-2: /home size: 26.94 GiB used: 5.66 GiB (21.0%) fs: ext4 
  dev: /dev/nvme0n1p8 
  ID-3: swap-1 size: 10.00 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p6 
Sensors:
  System Temperatures: cpu: 45.0 C mobo: N/A gpu: nvidia temp: 45 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 302 Uptime: 13m Memory: 15.52 GiB used: 2.07 GiB (13.3%) 
  Init: systemd Compilers: gcc: 10.1.0 Shell: zsh v: 5.8 inxi: 3.0.37 

Hello,
Since you mentioned in the title "I tried everything" - is quite impossible to give feedback, but here something to be sure about that everything :slight_smile:


Thanks, I tired everything in my limited knowledge in linux, so I'm sure there are some people can help, I tired your first link, it's not worked, the second one, it's seems like I can't install pulseaudio-git form the package manger: "could not satisfy dependencies:

  • removing libpulse breaks dependency 'libpulse-simple.so=0-64' required by fluidsynth"

I found this thread, I think we have the same machine, maybe this work for me, but I don't know how to create a script and as root in terminal, Can someone explain it to me:



I've managed to fix this problem on my machine (HP Omen 15 running Ubuntu 17.04 using codec for Realtek ALC295 sound device). To fix the problem, I can do the following:

Install alsa-tools if not installed:

sudo apt install alsa-tools

Create and save a script in /usr/local/bin:

#!/bin/bash
hda-verb /dev/snd/hwC0D0 0x20 SET_COEF_INDEX 0x67
hda-verb /dev/snd/hwC0D0 0x20 SET_PROC_COEF 0x3000

Run the script as root in a terminal to immediately fix the problem.

To run the script on startup, use cron with the @reboot command:

sudo crontab -e

and then add line in crontab:
@reboot [full path to script]

To run script on resume from suspend, copy the script to /lib/systemd/system-sleep

For more technical details regarding this fix, see https://bugzilla.kernel.org/show_bug.cgi?id=195457

Edit: I executed the script, still not work :frowning:

Hi, I think that script is not for Manjaro but for Ubuntu/Debian based distros. I think the easiest way for you is to install pavucontroland open it up, it should appear in your menu as Pulseaudio Volume Control (something like that) or you can just type in pavucontrol in the terminal to open it. Also, if you have time and will to learn, try reading this wiki page: https://wiki.archlinux.org/index.php/PulseAudio.
Good luck and welcome to Manjaro :slight_smile:

1 Like

I thought that comment about hda-verbs looked familiar
it was posted on here a couple of weeks ago - Crackling/Popping audio with headphones
didn't work for OP then
also didn't work for some users on the Launchpad bug report
and kernel was patched in Dec 2017 - Bug 195457 - Realtek ALC295 still unsupported

suggest add kernel v5.7
and install sof-firmware if not already installed
then reboot to load the newer kernel

and then use

 sudo alsa-info.sh --upload

and post the link here to data uploaded to alsa-project

1 Like

Thanks, I have pulseaudio and tried it, but still not work :frowning:

I did exactly what you said, and that's the link:
http://alsa-project.org/db/?f=6cbab5e92721ca518ae5a8b98c29183e0b009547

still not work

One thing I would check for is making sure the headphone jack is turn on on the volume isn't muted or turn all the way down. Also double check to if the audio hardware is actually enabled.

Everything is enabled nothing is muted, I after some other search I realized it's a common problem for people who have "Realtek ALC295", I don't know it's sound card or what, but still, there's not a solution yet, I hope someone help me.
I really really like this manjaro, I don't want to change it because of this problem

Well you could try this:
https://bbs.archlinux.org/viewtopic.php?id=256592
Are your other jacks working?

I tried this, manually edit the file and added the modification, but still not work, and this thread talk about microphone I think.

My laptop only have two jack, one for headphone and the other for microphone. the Pulse audio controller recognize the headphone when I plug it shows that I plugged in headphone and the voice chart in there changing, but still no sound im my headphone..

Please excuse my language my English is bad

Are your sure you are plugging in the headphones in the right jack? Not that I trying to be insulting, but it is easy to do this and it is very common mistake people make.

No no I'm sure it's the correct jack

Can you screenshot those tabs in pavucontrol? If the voice chart is moving it seems like your sound should work. Maybe the app is not pointed to the correct sound card?

Output devices:

While playing a Youtube video:

while playing a Youtube video

While the playing stopped:
Playing stopped

Input devices
Microphone while speaking:

Micophone while speaking

Configration:

Configration

In the playback tab, when an application is playing audio, is the device pointed to Built-in Audio Analog Stereo? Also, in the configuration tab, can GP106 be enabled?

That's the playback tab:
playback

In GP106 all of them are HDMI Stereo (HDMI) Output (Unplugged) (Unavailable) and HDMI Surround (HDMI) Output (Unplugged) (Unavailable)

and I think the device pointed to Built-in Audio Analog Stereo, as it's in tab "output".

i did not no expect audio device to start working, suggestion worked to get data about ALSA configuration

Cannon Lake PCH onboard audio device does not appear to be correctly detected
I would expect it to show subsystem ID similar to the GPU/HDMI audio device

Subsystem: Hewlett-Packard Company Device [103c:8467]

00:1f.3 Audio device [0403]: Intel Corporation Cannon Lake PCH cAVS [8086:a348] (rev 10)
	DeviceName: Onboard - Sound
01:00.1 Audio device [0403]: NVIDIA Corporation GP106 High Definition Audio Controller [10de:10f1] (rev a1)
	Subsystem: Hewlett-Packard Company Device [103c:8467]

HP Omen 15 8467 could be one of 16 possible HP laptop models
https://support.hp.com/gb-en/products/identify?q=omen%2015%208467&filter=-1&origin=pdp
cannot get to specific model of laptop due to limited ALSA data

Intel laptop with Cannon Lake Audio device usually requires kernel v5.7 and sof-firmwareand pulseaudio v13.99 (pulseaudio-git)
onboard audio would use sof-hda-dsp driver to support internal digital microphone array
but system is currently using legacy driver snd-hda_intel which does not support DMIC

as pulseaudio-git could not be installed previously, suggest use this workaround to disable internal DMIC. This will allow the audio device to work with legacy driver (until pulseaudio v14 is released)

echo 'options snd-intel-dspcfg dsp_driver=1' | sudo tee -a etc/modprobe.d/alsa-hda.conf
1 Like

I tried to install pulseaudio v13.99 manually in here: https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/Developer/PulseAudioFromGit/

and after I rebooted it, it destroyed the manjaro, so I reinstalled manjaro from zero. By the way it's seems like I can't fix this problem, when is pulseaudio v14 will release?

Edit:

I tried this command and I got this:

tee: etc/modprobe.d/alsa-hda.conf: No such file or directory
options snd-intel-dspcfg dsp_driver=1

sudo nano /etc/modprobe.d/alsa-hda.conf

paste text into file - options snd-intel-dspcfg dsp_driver=1

save file - Ctrl+O

close nano -Ctrl + X

reboot

Forum kindly sponsored by