I3 Manjaro - unable to detect secondary monitor

I recently installed "Manjaro i3" on my primary machine "Acer Predator helios" and it's working all fine. The only problem is that I am unable to detect my secondary monitor which is connected through HDMI cable.

Windows, Linux mint can auto detect it. However, xrandr isn't detecting anything at all except the primary monitor of my laptop. Can anyone guide me here a little please?

[nishant@nishant ~]$ inxi -Fxz
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_MEASUREMENT = "en_IN",
	LC_PAPER = "en_IN",
	LC_MONETARY = "en_IN",
	LC_NAME = "en_IN",
	LC_ADDRESS = "en_IN",
	LC_NUMERIC = "en_IN",
	LC_TELEPHONE = "en_IN",
	LC_IDENTIFICATION = "en_IN",
	LC_TIME = "en_IN",
	LANG = "en_IN"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:    Host: nishant Kernel: 4.19.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: i3 4.16 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Predator PH315-51 v: V1.22 serial: <filter> 
           Mobo: CFL model: Sienta_CFS v: V1.22 serial: <filter> UEFI: Insyde v: 1.22 date: 10/31/2018 
Battery:   ID-1: BAT1 charge: 47.7 Wh condition: 47.7/48.9 Wh (97%) model: LG PABAS0241231 status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 53004 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.3 driver: intel resolution: 1920x1080~144Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 18.2.5 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k4.19.2-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8168 
           v: 8.045.08-NAPI port: 3000 bus ID: 06:00.1 
           IF: enp6s0f1 state: down mac: <filter> 
Drives:    Local Storage: total: 1.03 TiB used: 5.84 GiB (0.6%) 
           ID-1: /dev/sda vendor: SK Hynix model: HFS128G39TND-N210A size: 119.24 GiB 
           ID-2: /dev/sdb vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:17.0 
Partition: ID-1: / size: 547.41 GiB used: 5.77 GiB (1.1%) fs: ext4 dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 41.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 270 Uptime: 4m Memory: 7.63 GiB used: 725.3 MiB (9.3%) Init: systemd Compilers: gcc: 8.2.1 Shell: bash 
           v: 4.4.23 inxi: 3.0.27 
[nishant@nishant ~]$ 

inxi -Fxz will be helpful for anyone that will try to help you.

Try with arandr.

arandr isnt helping :frowning:

thanks, added in the main post.

That means you have a laptop with hybrid graphics ... Let's see what drivers you have installed from terminal:
mhwd -li

Or simply decide what you want to use:

Thanks for your reply, here you go.

[nishant@nishant ~]$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI


Warning: No installed USB configs!

Have you test if the Nvidia GPU is working properly by:
optirun -b none nvidia-settings -c :8
Also, did you check the how too from here?

Side note, unrelated to the GPU:

It seems you have some issues with the locale :wink:

Yeah man I am in middle of a mess here. Just trying to get some help from you guys to fix it.

[nishant@nishant ~]$ sudo !!
sudo optirun -b none nvidia-settings -c :8
[sudo] password for nishant: 
[10876.779631] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[10876.779655] [ERROR]Aborting because fallback start is disabled.

About the locale, I've edited /etc/locale.gen and this is the only content in there
"en_US.UTF-8 UTF-8"
Then I ran "sudo locale-gen" but that doesn't seem to fix it.

Any help is appreciated.

Try to edit /etc/locale.conf

for instance set it to en_UK and then to back to your language (for example en_US). There was a cache issue for me when I first installed i3 which was solved by doing this.

THis post might be totally useless though because I'm a noob :smiley:

this file should include all available locales. I assume you did not open this, but /etc/locale.conf instead.
If I am wrong then you have to delete that file, and re-install glibc which owns that file, so it should be created with default contents.

About your Original Topic issue, try running intel-virtual-output. It may help if your external monitor output is connected to the nvidia card.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by