Ibus not getting installed properly Manjaro Gnome 16.06.1

I have been trying to install ibus for my local language support. (ibus-avro-git)
The package might seem old but it used to work with manjaro 15.12 XFCE version.
Recently I installed manjaro gnome 16.06.1 from scratch.
Now when I am installing ibus this error pops out.

sudo pacman -S ibus

[sudo] password for user: 
resolving dependencies...
looking for conflicting packages...

Packages (1) ibus-1.5.13-2

Total Installed Size:  6.29 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
:: Processing package changes...
(1/1) installing ibus                              [######################] 100%
:: Running post-transaction hooks...
(1/6) Compiling GSettings XML schema files...
No such key 'documen-font-name' in schema 'org.gnome.desktop.interface' as specified in override file '/usr/share/glib-2.0/schemas/99_manjaro-settings.gschema.override'; ignoring override for this key.
No such key 'scroll-method' in schema 'org.gnome.desktop.peripherals.touchpad' as specified in override file '/usr/share/glib-2.0/schemas/99_manjaro-settings.gschema.override'; ignoring override for this key.
(2/6) Probing GTK2 input method modules...
(3/6) Probing GTK3 input method modules...
(4/6) Updating icon theme caches...
(5/6) Updating manpage index...
(6/6) Updating the desktop file MIME type cache...

I also looked in the /usr/share/glib-2.0/schemas/99_manjaro-settings.gschema.override file:

[org.gnome.desktop.background]
picture-uri='file:///usr/share/backgrounds/black_leather_manjaro_linux_by_tefrem34.jpg'
show-desktop-icons=false

[org.gnome.desktop.interface]
cursor-theme='Simple-and-Soft'
documen-font-name='Sans 10'
enable-animations=true
font-name='Cantarell 10'
gtk-im-module='gtk-im-context-simple'
gtk-theme='Vertex-Maia-Dark'
icon-theme='Vertex-Maia'
monospace-font-name='Monospace 10'

[org.gnome.desktop.wm.preferences]
titlebar-uses-system-font=false
button-layout='appmenu:minimize,maximize,close'

[org.gnome.shell]
always-show-log-out=true
favorite-apps=['pamac-manager.desktop', 'firefox.desktop', 'empathy.desktop', 'org.gnome.Nautilus.desktop', 'gnome-terminal.desktop', 'org.gnome.gedit.desktop', 'hexchat.desktop', 'org.gnome.Screenshot.desktop', 'ca.desrt.dconf-editor.desktop']
enabled-extensions=['dash-to-dock@micxgx.gmail.com', 'gnomenu@panacier.gmail.com', 'mediaplayer@patapon.info', 'openweather-extension@jenslody.de', 'drive-menu@gnome-shell-extensions.gcampax.github.com', 'user-theme@gnome-shell-extensions.gcampax.github.com']

[org.gnome.shell.extensions.user-theme]
name="Vertex-Maia"

[org.gnome.nautilus.icon-view]
default-zoom-level='small'

[org.gnome.desktop.peripherals.touchpad]
natural-scroll=false
scroll-method='two-finger-scrolling'
tap-to-click=true

[org.gnome.shell.extensions.dash-to-dock]
background-opacity=0.90000000000000002220
custom-theme-running-dots=true
dash-max-icon-size=32

[org.gnome.desktop.interface]
cursor-theme='Simple-and-Soft'
documen-font-name='Sans 10'

Looks like a typo. Should be "document".

1 Like

As you can see here:


"scroll-method" seems to be deprecated. Two finger scroll-method is default, so you probably just ignore it.
1 Like

:sweat: ops tank you to point me to typo error

1 Like

Well now the documen-font-name error is gone but now I have this weird problem. I am installing ibus-avro-git which is used for Bengali language input but I am getting Arabic. :neutral_face:

1 Like

I don't use ibus, so I can only guess. Have you set your locale? See archwiki
https://wiki.archlinux.org/index.php/IBus#GNOME

Yes I have looked there.
Doesn't seem to solve the issue. :sweat:
And now I have discovered that when I choose Input source (ibus-avro) the layout is of another language(Malay).

same here ... even the avro bangla entry is not shown in the Language preference.

1 Like

This is June 16 2020 and I'm using the latest Manjaro KDE. Avro is working. Even Bijoy (unijoy) is working. Some people prefer openbangla-keyboard instead of avro.

Forum kindly sponsored by