Ideapad 130 - 15IKB. Touchpad not working

you may have to check bios settings after its flashed and make sure any applicable settings are still set or if not, set them appropriately.

if none of that works, this is a fix that works for ideapad330 that may also work for your laptop.

To download and install, run this in a terminal:

git clone
cd elan_i2c_dkms
sudo dkms install .

Then reboot your machine.

EDIT: the above git is for IdeaPad330 made by Jookia, and below is a version to work for the IdeaPad 130 modified by @aswathkk

git clone
cd elan_i2c_dkms
sudo dkms install

Thank you for this one.
It is not working for Lenovo Ideapad 130.

But, I made a clone of that which is even working for Ideapad 130

To download and install, run this in a terminal:

git clone
cd elan_i2c_dkms
sudo dkms install .

Then reboot your machine.
1 Like

so this worked well for you after a little modification?
you may want to edit the readme, it still reads:

This is an updated kernel module to fix touchpad detection on the Ideapad 130 15IKB.
Builds on Mint 18 (kernel 4.4) and 19 (kernel 4.15).

Yeah. It worked for me after adding a line.
Btw, what edit should I make in the README?

that it works on distro's other than just mint, and other kernels as well. you are using 4.19 right?

btw, glad to hear its working after all that trial/error

I tested this on Ubuntu 18.04 (Kernel 4.19).
It will work for other distros as well

glad i was able to help at least steer you in the right direction, and after helping you with your touchpad, i decided to swing back around to an issue ive tried to fix many times with my touchpad and failed. my touchpad worked perfectly but my journal would get flooded with hundreds of errors for every second i had a finger on the touchpad which was not only very annoying but also made it much harder to diagnose anything else that would go wrong and also eating up storage space like crazy with log after log adding up gb's of data in short periods of time. anyway finally fixed, good job making that work out for ya.

@dglt Some problem with my backup software, backintime. I am not able to take backups. I will post that as a separate question here. Till then, I will not tinker with /boot/efi. Just playing it safe :slight_smile:

@aswathkk @dglt Sorry to report but that is not working in my case. I did exactly as was told. There was no error reported while those commands were executing. After rebooting, the touchpad remains dead. Settings -> Mouse and Touchpad shows no section for touchpad. Please let me know if you need any further information about my computer.

AFAIK - in Gnome, you should have the /etc/X11/xorg.conf.d/30-touchpad.conf have a similar entries with this:

Section "InputClass"
    Identifier "libinput touchpad catchall"
    Identifier "tap-by-default"
    MatchIsTouchpad "on"
    MatchDriver "libinput"
    Option "Tapping" "on"
    Option "ScrollMethod" "edge"
    Option "TappingDrag" "on"
    Option "TappingDragLock" "on"
    Option "NaturalScrolling" "true"
    MatchDevicePath "/dev/input/event*"

You could start by sharing what config you have there related to touchpad.

1 Like

@bogdancovaciu Thanks. But there is only one file in that directory 00-keyboard.conf.

Then create the file i mentioned and add those entries. Reboot and test the touchpad ...

1 Like

timeshift works great for me, just a recommendation based on my experience with it, backintime didnt do it for me.

That won't allow me to go to the GUI. I went to the console, deleted the file and all was well.

Are you on wayland session ?
Let's find out from terminal:

Apparently, no. It returns x11

@aswathkk @dglt Whatever changes those commands brought about remain in my system. They do not seem to cause any harm. But just to know, how do I undo those effects?

maybe start a new thread and link to this one, explain what is wrong, what you have tried to fix it, and provide needed info for others to help you. im more than happy to try.

After upgrading to kernel 4.19.8-2, all is well. I can use touchpad.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by