- if i close the lid - the notebook does not shutdown..

hello dear all,

i have issues with the power-functions on a laptop. I run Manjaro 18.04
weeks ago - i was able to do a automatic shut-down while closing the lid.

but now it is not possible!?

is there a option in Setting utility for configuring laptop lid close actions.
Are there KDE or GNOME Tweaks that offer a switch to enable / disable ‘Suspend when laptop lid is closed’.

well, i allways thought that Linux is able to do a...

a. automatic shutdown, hibernate, or do nothing when laptop lid is closed,
...on the configuration file.

but what i have is! it (the notebook) still runs....

note: weeks ago i have had some issues with hibernation-device...

hibernation-device UUID xyz not found -> dropped into emergency shell

see the attached image ...

the hardware: laptop Asus Model A54L

see: https://www.asus.com/Laptops/X54L/

Windows 7 Home Premium or other editions available
IceCool Technology keeps the palm rest area cool, placing heat-producing components away from users
Experience high transfer speeds with USB 3.0 10x faster than USB 2.0
Power4Gear automatically adjusts fan speeds for quiet computing and prolonged battery life
Palm Proof Technology disables the touchpad for uninterrupted typing and accuracy

see what i have had weeks ago -. i runned in a hibernation issue..

hibernation_issue_manjaro|690x414 .

1 Like

I think you messed your fstab and probably the grub default:
From terminal:
cat /etc/fstab
cat /etc/default/grub

For the root shell


hello dear bogdancovaciu

many thanks for the quick reply. i am sure that you hit the point - your ideas were very very impressive.

i am convinced. See what i have gathered form the terminal...

[martin-pc martin]# cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=A790-35CD                            /boot/efi      vfat    defaults,noatime 0 2
UUID=1bf0c824-0645-47da-b8a1-88eaaabecc33 /              ext4    defaults,noatime 0 1
UUID=ae33e597-0c72-4c66-9f16-6606322111c3 swap           swap    defaults,noatime 0 2
[martin-pc martin]# cat /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=ae33e597-0c72-4c66-9f16-6606322111c3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
[martin-pc martin]#

well - i hope that i can fix the things ...with some corrections

Change this

UUID=ae33e597-0c72-4c66-9f16-6606322111c3 swap swap defaults 0 0

and remove ,noatime from the /boot/efi in your fstab ... All the rest seems ok ...

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by