[Illyria] Manjaro KDE v18.0-beta7 online now!

Hi,

Have install on new pc this beta but first run have this issue

error: file '/boot/grub/locale/en.gmo' not found

After first run have install frenhc packages and now have this :

error: file '/boot/grub/locale/fr.gmo' not found

You have idea to fix that ?

it not just you, im on firefox/manjaro and i cant see it either unless i open it externally. (looks great btw)

1 Like

I like the option of showing the logo! It is way more user friendly then “starting version 239” and a few errors. And also knowing I can switch off the option for debugging is cool!

Thank you for the release Phil...Appreciate it...

  1. Any plans for the minimal install release on this one ?
  2. 5.14.1 - Release scheduled for 16-Oct and 5.14.2 scheduled for 23-Oct..So Illyria final release will happen after that ?

Thank you for all the efforts..

Hmm. You can list the given locales of grub:

phil@development ~ $ ls /usr/share/locale/*/LC_MESSAGES/grub.mo
/usr/share/locale/ast/LC_MESSAGES/grub.mo
/usr/share/locale/ca/LC_MESSAGES/grub.mo
/usr/share/locale/da/LC_MESSAGES/grub.mo
/usr/share/locale/de_CH/LC_MESSAGES/grub.mo
/usr/share/locale/de@hebrew/LC_MESSAGES/grub.mo
/usr/share/locale/de/LC_MESSAGES/grub.mo
/usr/share/locale/en@arabic/LC_MESSAGES/grub.mo
/usr/share/locale/en@hebrew/LC_MESSAGES/grub.mo
/usr/share/locale/en@piglatin/LC_MESSAGES/grub.mo
/usr/share/locale/en@quot/LC_MESSAGES/grub.mo
/usr/share/locale/eo/LC_MESSAGES/grub.mo
/usr/share/locale/es/LC_MESSAGES/grub.mo
/usr/share/locale/fi/LC_MESSAGES/grub.mo
/usr/share/locale/fr/LC_MESSAGES/grub.mo
/usr/share/locale/gl/LC_MESSAGES/grub.mo
/usr/share/locale/hr/LC_MESSAGES/grub.mo
/usr/share/locale/hu/LC_MESSAGES/grub.mo
/usr/share/locale/id/LC_MESSAGES/grub.mo
/usr/share/locale/it/LC_MESSAGES/grub.mo
/usr/share/locale/ja/LC_MESSAGES/grub.mo
/usr/share/locale/ko/LC_MESSAGES/grub.mo
/usr/share/locale/lt/LC_MESSAGES/grub.mo
/usr/share/locale/nb/LC_MESSAGES/grub.mo
/usr/share/locale/nl/LC_MESSAGES/grub.mo
/usr/share/locale/pa/LC_MESSAGES/grub.mo
/usr/share/locale/pl/LC_MESSAGES/grub.mo
/usr/share/locale/pt_BR/LC_MESSAGES/grub.mo
/usr/share/locale/ru/LC_MESSAGES/grub.mo
/usr/share/locale/sl/LC_MESSAGES/grub.mo
/usr/share/locale/sr/LC_MESSAGES/grub.mo
/usr/share/locale/sv/LC_MESSAGES/grub.mo
/usr/share/locale/tr/LC_MESSAGES/grub.mo
/usr/share/locale/uk/LC_MESSAGES/grub.mo
/usr/share/locale/vi/LC_MESSAGES/grub.mo
/usr/share/locale/zh_CN/LC_MESSAGES/grub.mo
/usr/share/locale/zh_TW/LC_MESSAGES/grub.mo

Then copy it over as needed:

sudo cp /usr/share/locale/fr/LC_MESSAGES/grub.mo /boot/grub/locale/fr.mo

I don't know why the beta-6 boots and beta-7 not. On VirtualBox you told me it works for your. From the grub on the install media, we didn't changed on how we display it. Only the kernel changed to support the autohide menu as needed.

You can do this:

  • update beta-6 to the latest packages
  • reboot to see if all is still booting fine
  • install grub-quiet
  • sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
  • reboot to see if all is still booting fine
  • check that you have loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0 in /etc/default/grub
  • sed -i -e 's|fsck||g' /etc/mkinitcpio.conf
  • sudo mkinitcpio -P
  • sudo update-grub
  • reboot your system

Hi,

thanks for your reply. Am I right that I need a installation on hd in order to perform those steps?

I tried to boot both the beta-6 and the beta-7 from a live usb stick, whereas in virtualbox I created a new vm and booted from the beta-7-iso directly. So maybe I can't see the boot menu because the beta-7 is the only os on the live usb stick an it is booting quietly?

Regards,

Christoph

Ah, now we get you. We always thought the install media you had copied via dd to the USB-Stick doesn't boot-up to install Manjaro. However, you use the OS from the stick. That is a complete different story.

Yes. Please excuse me if I was not clear enough.

I use etcher to create a live usb stick in order to boot from this stick, do some tests and maybe install Manjaro from this stick. This works fine with beta-6, but not with beta-7.

Regards,

Christoph

Is there an easy way to toggle this default behavior for those who prefer grub menus to be displayed?

1 Like

You've still got the normal "grub" for that. So either replace "grub-quiet" with normal grub, or edit grub conf and change "GRUB_TIMEOUT" to your liking and optionally comment out "GRUB_HIDDEN_TIMEOUT" and "GRUB_HIDDEN_TIMEOUT_QUIET".

I think that is all.

No, we added new features to grub-quiet. On this we worked with Fedora together.

On systems with only a single OS installed, the grub menu's only function is to allow booting older kernels, which is only necessary as a rescue option in case of a severe kernel bug and as such not something which is directly useful for normal use.

Manjaro already has a lot of work done to not show too technical boot messages to end users during bootup, e.g. we pass quiet to the kernel and we had plymouth to show a bootsplash instead of a bunch of "Starting service-foo: OK" messages.

The grub menu with its kernel versions is another example of showing too technical info to end-users and on non multi-boot systems it normally is not necessary, so it is better to hide it.

This change will add menu-auto-hide functionality to grub, which when enabled will hide the menu if:

  • The machine only has a single OS installed; and
  • The previous boot has set a flag to indicate it successfully booted

To make the menu easier to reach when hidden this change will also extend how the menu can be unhidden. Currently to show the menu when hidden the user needs to press ESC during boot. There are 3 problems with this

  • It is not easily discoverable
  • Timing the ESC key press right may be hard
  • ESC makes the machine enter its firmware/BIOS setup screen on some machines (especially with the #bladebook)

So we added 2 new unhide methods to address these problems:

  • Press F8 to unhide the menu (F8 has been the key to show the Windows boot menu for many older Windows versions)
  • Keep SHIFT pressed during boot, this fixes the timing problem and this is what Ubuntu does

This new auto-hide functionality will be automatically enabled on new Manjaro 18.0 installs. This can be disabled by running:

sudo grub-editenv - unset menu_auto_hide

You can also show the menu once for 60 seconds on next boot:

sudo grub-editenv - set menu_show_once=1

3 Likes

Thanks for the clarification Phil.

I don't mind verbose boots myself, I'm actually kind of fond of them, but you guys had done a wonderful job with this TBH. Specially for the "mainstream" usergroup. And contributing with Fedora guys to the "bleeding edge" side of Linux is super cool in my mind. Keep up the great work.

1 Like

Most of the work is done due to the projects we have with our partners of the Manjaro-Hardware projects.

1 Like

Recently using usb live running this beta 7, it's worked. Nothing press shift, just look like previously on beta 6.

Tested the new autohiding method on a new installation. For me, it hides the menu even when there are 2 manjaro installations on the machine. It seems multiple manjaros doesn't count as multi boot? Holding shift does not work, beating F8 does, so it is good that there are multiple options.

If we disable fsck by default, shouldn't we enable the corresponding systemd service to compensate?

https://wiki.archlinux.org/index.php/silent_boot#fsck

Hello, I remember in previous ISO releases, there was a dark theme, not Breeze-dark mind you, but it was Manjaro-specific, maybe Breath-dark? I forget.

Regardless, would it be possible to implement this in the ISO once more?

+1 for breath dark as default color scheme.

Installed into a VM, so issues.

It is strange not having any text on the screen at all during boot, this text can very useful when a system doesn't boot for some reason, or when a kernel panic occurs.

Is the best way to display boot text to remove grub-quiet and replace it with grub?

1 Like

I found an old LiveUSB of 16.08 today, and I love the dark theme preinstalled.

I'm tempted to use it just because of the "flat" look. Now, the icon for Firefox isn't flat, yet on Manjaro MATE using the 'Papirus Adapta Maia' icon set, Firefox is flat.

I like my flat GUI okay? :smiley:

As the release is approaching I cannot but share an info about a minor bug affecting Elan Touchpads: a HUGE number of the following messages spamming dmesg output as soon as touchpad is used:
[ 362.702654] i2c_hid i2c-ETD2303:00: i2c_hid_get_input: incomplete report (14/65535)
I've searched for a solution here and there, and according to what I've found this is a kernel-related problem. This is not a serious issue but it results in logs consuming much space on a drive.
I have this issue since I installed Manjaro in the end of December, 2017, and I am sure it affects every kernel version from 4.14 to 4.19.
PS: 18.0-beta7 boots just fine on my UEFI laptop.

Forum kindly sponsored by