[Illyria] Manjaro KDE v18.0-beta8 online now!

Hi community,

it is now a long time ago I felt the need of announcing one of our development releases. However, with all the changes we did so far, it is time to do so.

Features

  • we are using now linux419 kernel series, which is the next LTS release by upstream.
  • grub automatically hides the menu when Manjaro is installed as single OS. Use holding shift or pressing F8 to display grub-menu.
    • last beta we had issues with grub-quiet package. With this ISO we ship now grub-quiet-fedora.
  • we added a feature to display the manufacturer logo of your UEFI-BIOS thru-out the boot process.
  • currently we ship with Plasma 5.13.5, but plan to release Illyria with v5.14.1 packages.
  • lot of changes went into Octopi. (shipping with Pamac-QT might happen in a later point-release of v18.0 series)

So tell us how you like our v18.0 development release so far and what we might still need to fix.

Best, Philip


5 Likes

Kind of a first for me, in a couple of ways. Firstly, I normally only play in live mode, but I now have the option to install to a drive. I tried a few times and it failed on every occasion to install over my Fedora 29 beta install. It seemed to take an inordinate amount of time at the 'gathering system information' stage, and only once allowed me to select the 'install over/replace' option after that and even then came up with a message that the installation failed. I'm so used to everything 'just working' for Manjaro. That said, it would probably have allowed me to 'play' quite nicely in 'live mode'. This is the same as what happened with the Xfce beta 8.

Cheers
Michael

Changes from v17 -> v18, or changes since 18.0 beta 7?

I had the same experience whit this as with the XFCE one, as mentioned here:

Same issue for me with the new KDE beta 8 :frowning:

I have Xiaomi Mi Notebook Pro with Insyde UEFI. Beta-7 booted fine, however, Beta-8 does have an issue: when trying to boot from usb media it immediately falls to grub-rescue. I tried only UEFI mode, however. Fedora Workstation 29 beta 1.5 boots fine, but I didn't try to install it.

UPD: It's likely there was an error during copying iso content on usb stick, because next time it worked OK!

Tested. Booted install media 3 ways.

  1. live usb in uefi
  2. live usb in bios-legacy
  3. iso file from grub2 (both uefi and bios-legacy)

All went fine. None gets into grub rescue and all (except isofile - it does not do that, it boots straight into OS) and all have grub menu background image (not black background).

But I don't test with VirtualBox. Maybe png image of background...never mind, I don't know.
Anyway, VM is not the same as live and actual installs.

Cheers, all good.

1 Like

No spare PC to test with right now, so it's VirtualBox only for me :frowning: Hopefully the issues here are easy to fix, and at least the ISO is working outside of VirtualBox (which is the most important thing).

I also had the issue with Virtualbox when installing on a "bios-system". I then tried it as a "efi-system", and then it worked. It seems that the new grub only works with efi in virtualbox?

1 Like

That fixed it thank you \o/ (might be worth trying @bogdancovaciu ).

libktorrent is now included, so KGet now downloads torrent files :+1:

I turned the manufacturer logo off in my BIOS years ago, and when I turned it on again yesterday, it was blank :thinking: So I tried installing bootsplash in the VirtualBox test, but that did not seem to work :frowning:

1 Like

When booting up the VB install, I get the following error before the VB-logo from grub:

Boot Failed. EFI DVD/CDROM
error:fs/fshelp.c:258:file '/boot/grub/locale/nl.gmo' not found

It boots up just fine after that.

Mc-Loving it! Thanks. @philm. :slight_smile:

Yes, I get the first line of that error message too, but it boots fine for me as well.

Just booted from a USB stick with Beta 8, and my missing manufacturer logo did not show (just a blank screen until Plasma loads). It's a five year old Clevo laptop from PC Specialist (and a PC Specialist logo used to display before I turned it off in the BIOS). I have replaced the original hard drive since, but would not expect that to have an impact. Will bootsplash be available for Manjaro 18 Illyria?

(Can't install on this laptop right now, too many mission critical projects.)

OK, we have to be precise here. I got reports about a black screen of Grub with beta7. Then I tried to figure out if the fedora-grub might work for us. It seems with beta8 we have different issues than with beta7.

What I know from beta7 (grub-quiet 2.02.0-12):

  • on some cases you have a black screen, but you can blindly navigate
  • when set to legacy BIOS mode the menu shows
  • when set to first boot device from USB it seems to work
  • was booting from DVD tested yet?

Then we have beta8 with grub-quiet-fedora 2.03.60.f29-2:

  • it seems to boot fine in live-session mode
  • it can be installed in VB via UEFI mode
  • it seems to have issues with BIOS mode in VB

I'm currently reviewing all patches applied to normal grub-quiet and may try to come up with a new patch-set. I assume normal grub seems to work at all times.

I created another test-iso. Changes can be reviewed here. Does it show up normally?

Xiaomi Mi Notebook Pro, Insyde UEFI, grub-quiet-2.03.0-14 (and 2.03.0-15 too):

  • UEFI: boots, grub menu is present

  • UEFI, set as default boot device: boots, grub menu is present

  • Legacy/CSM: boots, grub menu is present

  • Legacy/CSM, set as default boot device: boots, grub menu is present

It looks like the issue I had with Beta-8 was caused by a failure during writing iso file from my network location to my usb stick, because I tried again with the same Beta 8 iso and it worked OK too.

1 Like

Seems we found the issue by now. A regression with a patch showing text when needed IN EFI. I have to check with Hans, what we can do about it.

4 Likes

glad to hear ! so i will wait with install until next iso will be release

Same for me (Lenovo T410, legacy BIOS (non-efi) Boot), but in case my experience differs from the three previous reporters, in addition to the unrecognized number / you need to load the kernel first, followed by a similar menu picker, when I select Manjaro, I loop back to the unrecognized number / you need to load the kernel first.

Edit to add. I will be trying the beta9, but not until Tuesday.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by