[Illyria] Manjaro XFCE v18.0-beta8 online now!

Hi community,

it is now a long time ago I felt the need of announcing one of our development releases. However, with all the changes we did so far, it is time to do so.

Features

  • we are using now linux419 kernel series, which is the next LTS release by upstream.
  • grub automatically hides the menu when Manjaro is installed as single OS. Use holding shift or pressing F8 to display grub-menu.
    • last beta we had issues with grub-quiet package. With this ISO we ship now grub-quiet-fedora.
  • we added a feature to display the manufacturer logo of your UEFI-BIOS thru-out the boot process.
  • the theme changed to Matcha.
  • manjaro-hello can now install packages as needed.
  • currently we ship with XFCE 4.13 packages.
  • lot of changes went into Pamac.

So tell us how you like our v18.0 development release so far and what we might still need to fix.

Best, Philip


6 Likes

Initial boot of the ISO in VirtualBox looks good.

After installing in VirtualBox, this seems to have some issues starting.

Checked the ISO with sha256sum. Attempted install 3 times to make sure.
Identical install of Beta 7 does not encounter this issue.

(Install was to a blank VDI with msdos partition table. Chose "Erase disk" for the partitioning)

image

Additionally, the menu has no formatting, but that's just a cosmetic issue (is this intended with the silent grub now?)
image

Already downloading!, i'm really wanting to try the new smooth-bootup, i think we should do something about those panel buttons tho :thinking: , i hope the adapta dev comes back or someone volunteers.

Kind of a first for me, in a couple of ways. Firstly, I normally only play in live mode, but I now have the option to install to a drive. I tried a few times and it failed on every occasion to install over my Fedora 29 beta install. It seemed to take an inordinate amount of time at the 'gathering system information' stage, and only once allowed me to select the 'install over/replace' option after that and even then came up with a message that the installation failed. I'm so used to everything 'just working' for Manjaro. That said, it would probably have allowed me to 'play' quite nicely in 'live mode'.

Cheers
Michael

We have several changes in regard of grub-quiet. For some unknown reasons with Beta7 it does not show up on some Lenovo hardware.

Fedora F29 seems to work. Grub is there heavily patched. Over 250 patches on top of 2.02. With Beta8 I managed to get it somehow working.

However it seems to create more issues than I expected. I'll try to review the patches and might use or old patches we used in the past for grub-quiet package.

A small ISO for testing the hardware. I might even come up with a simple solution.

I'm sorry for the hassle with the current release. Since this is the last thing we want to tackle I'm still sure we will release as scheduled. However we might have some more ISOs before a stable ISO.

3 Likes

DomY3x9W0AAAQ9x

can you set the places I showed in the photo to black? @oberon @philm
(sorry for my English)

1 Like

Take your time @philm better to delay a release than to rush and have to deal with the fallout.

Release when it’s ready, don’t worry about time lines. You’re all doing a great job :beers:

10 Likes

Try installing as an "EFI-system", that worked for me. It seems that the new grub only works with EFI within Virtualbox. If it also would not start on A actual BIOS/MBR system after install, but on EFI would, I don't know (can't test that).

2 Likes

OK, we have to be precise here. I got reports about a black screen of Grub with beta7. Then I tried to figure out if the fedora-grub might work for us. It seems with beta8 we have different issues than with beta7.

What I know from beta7 (grub-quiet 2.02.0-12):

  • on some cases you have a black screen, but you can blindly navigate
  • when set to legacy BIOS mode the menu shows
  • when set to first boot device from USB it seems to work
  • was booting from DVD tested yet?

Then we have beta8 with grub-quiet-fedora 2.03.60.f29-2:

  • it seems to boot fine in live-session mode
  • it can be installed in VB via UEFI mode
  • it seems to have issues with BIOS mode in VB

I'm currently reviewing all patches applied to normal grub-quiet and may try to come up with a new patch-set. I assume normal grub seems to work at all times.

Installing as an EFI system (selecting Enable EFI in Vbox settings) also worked for me. Thank you!

Perhaps some further clues as to what's going on here:

I noticed, before enabling EFI, that this message was briefly displayed in several popups just after the live environment loaded:

VBoxClient: Failed to connect to the VirtualBox kernel service

This problem went away after enabling EFI.

Finally, if after installation I reboot without enabling EFI, this message is displayed:

FATAL: No bootable medium found! System halted.

Bootup is successful if I re-eneable EFI.

More test results for booting Manjaro Xfce Beta:

Legend:

Successful boot (is quiet) = Y
Successful boot (is verbose) = V
No boot = N

Dell Latitude E7440:

(Booted from Flashdrive written with dd)

Beta 7 Beta 8
Live Legacy V V
Live EFI V V
Installed Legacy Y N1
Installed EFI Y Y

---------------------------------

VirtualBox:

Beta 7 Beta 8
Live Legacy V V
Live EFI V V
Installed Legacy Y N1
Installed EFI Y Y

Errors:

1 Both cases with unsuccessful boot used Legacy BIOS (and were after installation). Both had the same errors from my original post.

Separate (minor) issue: Neither beta 7 or beta 8 have the option to shutdown/restart the computer from the login screen.

I'll try to get a Lenovo laptop to test...

1 Like

Thx for the tests. Can you check if this works on your end on live-session: I created another test-iso. Changes can be reviewed here. Does it show up normally?

Booted manjaro-18.0-beta-8-grub-quiet-2.03.0-14-x86_64.iso with VirtualBox and Latitude E7440 in both Legacy and EFI mode. Menu looked normal in all 4 test cases. All got this message when attempting to boot the Manjaro grub option (tho, that's probably normal since it is just a test ISO):

image

Thx for testing. I assume you had never an issue with this getting a black screen when booting it up with beta7.

I tried running this (from the original post) but the live session failed as soon as the welcome screen appeared. The screen garbled for a second and then the lightdm login screen appeared. Logged back in, and it booted me right out again. I may be an outlier case since I've got a perhaps weird monitor setup.

You assume correctly.

I was able to find a functional Thinkpad X260. Currently testing Beta 7 to try to reproduce that issue...

Latest test results:

Lenovo Thinkpad x260

Beta 7 Beta 8
Live Legacy V V
Live EFI V V
Installed Legacy Y N1
Installed EFI Y Y
test-iso grub-quiet-2.03.0-14-x86_64
Live Legacy Y
Live EFI Y

Latitude E7440

test-iso grub-quiet-2.03.0-14-x86_64
Live Legacy Y
Live EFI Y

Errors:

1 Same issue as previous tests

1 Like

More tests. Live only.

Lenovo Thinkpad W540

17.1.12 Beta 7 Beta 8 grub-quiet-2.03.0-14 grub-quiet-2.03.0-15
Live Legacy V V V V V
Live EFI V N2 N2 N2 Y

Errors:
2 I was able to replicate the blank screen issue. You can interact with it, but it is invisible.

Edit: Added test results for grub-quiet-2.03.0-15: It works!

I wonder if a matcha-darker theme could be crafted. that could combine the darker taskbar items and application menu with the light program UI. arc-darker did this and matcha is forked from arc.

arc-themes are in the community repositories if you are interested

OK, so we found the regression in the EFI show text mode when needed. This helps.

Forum kindly sponsored by