Inbuilt monitor speaker not outputting any sound

Hello, sorry if i sound like a noob, that is because i'm, new to linux.
making it short, i installed and dualbooted Arch a couple months back, worked perfectly.
tried Pop OS, broke on me for some reason and to add insult to injury i didn't really like it that much
Now switching back to an Arch based distribution, mostly for the AUR and Pacman, and drifted to Manjaro.

I have a monitor with it's own speaker, sounds pretty good, on the live ISO there was no sound, installed it anyway since my previous distro broke. I would really like to get my audio working, i opened PulseAudio volume control and it is detecting audio but my monitor is not playing any audio. Plugged in external devices like speakers and headphones always works, however. Need help to walk me trough the steps of solving this problem, Manjaro is a really nice distro and it would be sad to pass it up.

Do be able to help you we need more information as described here:

Besides the output of these commands, here are some questions.

Does the monitor get the sound over 3,5mm jack or via HDMI or Display Port?
Where do you plug-in your headphones?

What source for the audio did you select in the Volume Control?

inxi output :

  Kernel: 5.6.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=be7c038a-7e7c-47f7-a111-280411fe9b64 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
  Type: Desktop Mobo: Micro-Star model: Z390-A PRO (MS-7B98) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 1.80 date: 12/25/2019 
  Topology: 8-Core model: Intel Core i7-9700K bits: 64 type: MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: D (13) 
  microcode: CA L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 57616 
  Speed: 4600 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 4600 
  2: 4600 3: 4600 4: 4600 5: 4600 6: 4600 7: 4600 8: 4600 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: tsx_async_abort mitigation: TSX disabled 
  Device-1: NVIDIA TU116 [GeForce GTX 1660 SUPER] vendor: Micro-Star MSI 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:21c4 
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nouveau 
  alternate: fbdev,nv,vesa compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.6 
  compat-v: 3.1 direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Device-2: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:1aeb 
  Sound Server: ALSA v: k5.6.7-1-MANJARO 
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e 
  v: 3.2.6-k port: efa0 bus ID: 00:1f.6 chip ID: 8086:15bc 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee 
  v: kernel port: 3000 bus ID: 03:00.0 chip ID: 10ec:8179 
  IF: wlp3s0 state: up mac: <filter> 
  Local Storage: total: 1.38 TiB used: 276.27 GiB (19.6%) 
  ID-1: /dev/nvme0n1 vendor: A-Data model: SX6000LNP size: 476.94 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: V9002s16 scheme: GPT 
  ID-2: /dev/sda type: USB vendor: Seagate model: M3 Portable 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  serial: <filter> rev: 1306 scheme: MBR 
  ID-1: / raw size: 476.64 GiB size: 468.16 GiB (98.22%) 
  used: 10.25 GiB (2.2%) fs: ext4 dev: /dev/nvme0n1p2 
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: nouveau temp: 39 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 1419 
  Processes: 243 Uptime: 2h 28m Memory: 15.58 GiB used: 3.18 GiB (20.4%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 
  running in: konsole inxi: 3.0.37

The monitor i use gets its audio via HDMI cable.
Trough an audio port.
I'm a bit confused on the last one, i have no input, i added an input, but the only input i have is "Monitor of TU116 High Definition audio controller digital stereo" and it's the monitor. Still doesn't work though. Ouput is just the "TU116 High Definition audio controller digital stereo".

Go to 'System settings -> Audio -> and select the HDMI device as output
If you can't find the setting make a screenshot and post it here. I'm not a KDE user myself.

Here it is, it's already selected in audio.

What does the Devices tab show?

So I figure that it worked with the others Distros but doesn't under Manjaro?

This is what the devices tab shows
Yes it works with the recent distros i have used, and i saw on the download page Manjaro has moved from 19.04 to 20.00? i looked at my old Manjaro gnome ISO and it was labeled as 19.04. Maybe this new version does not accept audio to be played back over the HDMI cable for my specific hardware? should i maybe try use the gnome preinstalled version? i haven't tweaked this new install much so that may be a viable option if nothing works?

What does


show? (Select the right audio device)

If you try something else why not go with XFCE. I switched recently (back) to it from KDE and am much happier.

This is what it shows, and when i press F6 it only shows those two, both don't work. I think i'm actually just going to try gnome and xfce, thanks for the help though! :grin: it may be much beneficial anyways in the long run since KDE sometimes lags on my hardware (or maybe sddm)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by