Incorrect pacman-mirrors.conf on fresh install 17.1.2

Hey @philm I just upgraded a friend at work today from Windows to Manjaro. Everything installed fine, he loves his now much faster machine :+1:

However I noticed a small issue when updating his mirrors for https only.

The version of pacman-mirrors.conf that is installed by default is a very old version, much like the issue I found on @jonathon 32bit install media.

It was easy to rectify, delete config and reinstall pacman-mirrors which then uses the up-to-date config, but this is something that should maybe be addressed before new installation media is created.

Just to clarify, this was a freshly downloaded XFCE 64bit 17.1.2 ISO.

Defaulting to https only mirrors, does not seem to be a bad thing though....

No, I was going to set him to be https only. The config installed by default wasn’t even formatted for this option anywhere.

Just like here...

Hm. Okay. I misunderstood you then.

Wouldn't it do that on the first run of pacman-mirrors then, @linux-aarhus?

I thought this too but it doesn’t seem to. It’s easy enough to “fix” as I mentioned and isn’t a big deal, but it just isn’t right OOTB.

Oh on a side note, the branch is correct, it’s everything below the branch which isn’t.

I have no clue as the config has not changed for the last 2 months and the last change was removal of the OnlyCountry setting.

As I understand it the issue occurs on x32 iso's. Something tells me that an old pacman-mirrors.conf is placed in /etc on iso-build.

I remember that when @artoo and I worked the api out together we had to ensure a certain structure was present which otherwise would make the build fail.

Short story is:

If pacman-mirrors is run with the `--prefix $install` argument it will ensure a working structure in `$install` by copying the hosts `pacman-mirrors.conf` to `$install`.

@philm @Strit @jonathon @anon34396487
In which case - if that file is an old version of the config then - whoever is building the iso, has to verify that the host systems pacman-mirrors.conf is the current as shown ^^^^^ above.

Note on branch
What the branch is named on a fresh install does not matter since on the first run of pacman-mirrors it will detect it is running on i686 and prepend x32- to the branch name.

Note on config file
Please check if a .pacnew exist for pacman-mirrors.conf.


Just noted ^^ this. It confirms my thought. I think @philm is building the iso's - so Philip will you please confirm your pacman-mirrors.conf on the machine building the iso's?

I suspect the same as you do. Just for the record all my existing installs from around 2 or 3 years ago are fine. I merged the .pacnew settings.

It's only this fresh install for a friend, annoyingly i never noticed on any other friends PCs that i upgraded to Manjaro as they didnt care for https only mirrors.

Also this is the pacman-mirrors.conf the XFCE 17.1.2 ISO uses.

This is what the freshly installed system has.

As you can see they (the live iso and fresh install) are the same, a some what old configuration version. And just for reference this is what my personal machine has.

Thanks for your time :grinning:

1 Like

:+1: - FYI - https are preferred over http - of course to avoid http at all

sudo pacman-mirrors -aP https --no-mirrorlist

When you are saying delete the conf and reinstall pacman-mirrors then on a fresh install there is a pm 4.7 and no .pacnew but an old config?

Not quite. I delete the old freshly installed .conf and then just reinstall pacman-mirrors and then the correct up-to-date .conf is generated.

There is no .pacnew


Just bumping to inform this is still not fixed with the latest XFCE ISO 17.1.4 @philm

1 Like

What is the situation of the files in your system when this appear ? We have to check if the hook work fine .. I can look into it ..

Has the format changed again? With Manjaro-Tools we still use this one. I've to double check if we handle some with the conf in manjaro-tools.

I found the issue. I never updated manjaro-tools-base with the needed fix.

New ISO's with fixed mirrorlist? :stuck_out_tongue:

This issue is just minor. Will be fixed by creating new ISOs via the new tools. so v17.1.5 or later might have this fix.

Now fixed in 17.1.5 :+1:

Forum kindly sponsored by