Inkscape crashes while copying images when build in clipboard is enabled

This topic has been started by someone else in this closed thread
The last reply in the thread said the problem was fixed after doing the latest updates at that time. However, today I did a pacman upgrade, and installed inkscape. With these up to date state, I encountered the same problem described in the closed thread.

Here is what happened.
I selected an area containing multiple items including an image (size 228kb) and pressed the shortcut ctrl + c to copy it. But inkscape promptly crashed without warning and I lost all my progress. I reproduced the behavior by trying to copy the image and about 3 out of 5 times, it results in a crash.

The problem is however not seen at all when I disable the build in system tray clipboard manager from 'Configure system tray' window. I believe this is a serious bug as it could result in loss of precious hours.

System info:

Operating System: Manjaro Linux
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.69.0
Qt Version: 5.14.2
Kernel Version: 5.4.23-1-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-2450M CPU @ 2.50GHz
Memory: 7.7 GiB of RAM

Inkscape crash log (Inkscape version 0.92.5)

The program 'inkscape' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 9397 error_code 3 request_code 18 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Steps to reproduce error:

Make sure system tray clipboard manager is enabled, import a 300 kb or above image to inkscape, select it and do a ctrl + c. In about 3-5 tries to copy the image, inkscape will crash.

Steps to troubleshoot error:

Disable system tray clipboard manager

I have to disable the clipboard, and inkscape is working fine, however the clipboard has proven useful outside of inkscape. Consider this a bug report as I do not know where else to report it. Any help with automatically disabling the build in clipboard manager while running inkscape is appreciated.

Thank you

1 Like


Images copied from Inkscape are always an XML like descriptor, hence you can only copy and paste images from one Inkscape document to another Inkscape document.
The issue is quite tricky one, and on my end happened rarely and randomly. I changed my workflow in Inkscape a bit so i do not copy images inside nor from Inkscape document itself. Either have the image in original format elsewhere, or i export it as *.png and then open it in Gimp or Krita (for example). The initial Inkscape document i import the images as LINK and not embed. That way the copy paste will not crash Inkscape when copying between Inkscape documents because that XML clipboard will have a better format to be handled. You still can perform same "edits" to the images.
When grabbing a screenshot and then directly pasting it in Inkscape will also create a better image information than when importing an image by EMBED option, and that too will allow the copy paste between Inkscape documents.
So, recap - use images as LINK when importing them.
Hope this helps and is clear.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by