Inspiron 15-3552 suddenly freezes

My laptop suddenly freezes when I watch movies through VLC (2 Times now) and while configuring Lutris (Just one time). The weird thing about it is that the capslock key flashes repeatedly when that happens. Here's the inxi -Fxz output.

  Host: Karl515 Kernel: 5.4.18-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: Xfce 4.14.2 Distro: Manjaro Linux 
  Type: Portable System: Dell product: Inspiron 15-3552 v: 4.1.0 
  serial: <filter> 
  Mobo: Dell model: 00NY55 v: A00 serial: <filter> UEFI: Dell v: 4.1.0 
  date: 06/15/2017 
  Topology: Dual Core model: Intel Celeron N3050 bits: 64 type: MCP 
  arch: Airmont rev: 3 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 6402 
  Speed: 480 MHz min/max: 480/2160 MHz Core speeds (MHz): 1: 480 2: 480 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.7 driver: intel unloaded: modesetting 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (Braswell) 
  v: 4.6 Mesa 19.3.4 direct render: Yes 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.4.18-1-MANJARO 
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Dell driver: ath9k v: kernel port: f040 bus ID: 01:00.0 
  IF: wlp1s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-2.1:6 
  Local Storage: total: 465.76 GiB used: 40.37 GiB (8.7%) 
  ID-1: /dev/sda vendor: Western Digital model: WD5000LPCX-75VHAT0 
  size: 465.76 GiB 
  ID-1: / size: 457.16 GiB used: 40.37 GiB (8.8%) fs: ext4 dev: /dev/sda2 
  System Temperatures: cpu: 51.0 C mobo: 50.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 155 Uptime: 14m Memory: 3.76 GiB used: 1003.6 MiB (26.1%) 
  Init: systemd Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 inxi: 3.0.37

:+1: Welcome to Manjaro! :+1:

Please read this:

and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies... I.E. Are you watching YouTube Videos, 60FPS 4K local videos, Plex Videos...

:wink: :+1: :innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...

1 Like

It only happened when I watch movies on VLC (2 Times now) and when I configure Lutris (Just one time). I tried running dmesg but I don't see any errors.

My apologies for being unclear: We need more information on what you did exactly:

  • Did your computer freeze watching a specific video? (VLC is just a client application: it can be used to watch network videos, local videos, YouTube videos, Plex videos,...)
    If yes: what were the VLC statistics and codec information? (Press Ctrl+J to get to this information)
  • What were you doing exactly when you configured Lutris?
  • Did you start Lutris from the command line as per the FAQ?

Please be more specific to help us help you...


It just freezes on random circumstances. On VLC it freezes when I watch a local video (I haven't tried watching online video through VLC) and in Lutris I was adding some games to wine and it's not started through the command line. The only way to recover from it is to remove the charger from the laptop (I don't have a battery installed). And also the freezes seemed to have calmed now.

  1. Ouch!!! Bad idea to remove the charger! Try this instead:
  1. It freezes when watching multiple videos or the same video or all videos?

Please help us help you!

Search the forum for Baytrail. Your processor has known issues on Linux.

  1. Thanks for the REISUB! I'll try that out when my laptop freezes again.

  2. I tried playing the video again but my laptop didn't freeze. It's very hard to reenact what I've done when that happens so I can't really give important facts about it.

Can you point me towards the right topic? I tried searching It but I can't find a related topic to my problem.

Your problem very likely has nothng to do with VLC or Intel Graphics. They have been trying to fix baytrail for years, and with every new kernel patch I have experienced disappointment. Some have worked well enough to run 8 hours or so without a freeze, but there is always inevitably a freeze. I would try some of the old fixes, I had very good luck with those, but they affect battery life negatively.


Yeah, I kinda figure that out because I've been watching some videos and playing games without experiencing some freezes here and there. I'm gonna try the fixes that you've linked here when the issue happens again. I'm a very light user (I only use it when my phone needs to charge) so I don't really suffer from this. It's just annoying that it gets interrupted and I don't know what the problem is. Thanks for your time!

Update: It froze again when I was editing the pacman.conf through the terminal. The last thing that I have done is to launch mousepad through the terminal. My keyboard was connected and after a minute the keyboard's LED shut down. So I know that the entire system froze (with the keyboard and such) so I can't use the REISUB solution.

Another Update: Froze again while watching a Youtube video on Firefox.

if you do a search for the intel i915 graphic driver you'll find it's causing random freezes on kernels 5.4 and above. i had this issue and the solution was, for now, using kernel 4.19.

(sorry i can't link pertinent threads now, but i'm sure you'll find them :nerd_face:)

Yeah, I found that post. It also says that I can use kernel 5.5 so I'm gonna switch to that.

I tried switching to kernel 5.5 but it lags my system so I switched to kerne 4.19 and the lag got fixed. I'm gonna have to check if the freezes stopped too.

5.5 for me was better than 5.4, but it still froze (it froze once every three days instead of three times a day, but still froze). 4.19 works perfect. Hope it works for you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by