Inspiron 7590 - integrated microphone not detected

Hi everyone,
I have trouble using the integrated microphone on my Dell Inspiron 7590. The audio (integrated speaker, usb adapter, blutooth, etc.) works perfectly, the webcam works great, but the microphone is not detected at all, not even in the settings.
I'm also kind of a noob so don't hesitate to ask for details... Thanks in advance!

So there is information I should have provided so here it is ^^'

$ inxi -Fxxxza --no-host
  Kernel: 5.3.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 
  root=UUID=b8b8e174-70de-4977-a6d5-f9120a6e8e3e rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Gnome 3.34.3 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
  Type: Laptop System: Dell product: Inspiron 7590 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 08717F v: A00 serial: <filter> UEFI: Dell v: 1.5.1 
  date: 11/06/2019 
  ID-1: BAT0 charge: 82.7 Wh condition: 92.1/97.0 Wh (95%) volts: 12.6/11.4 
  model: SMP DELL GPM0365 type: Li-ion serial: <filter> status: Discharging 
  Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: CA L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 38408 
  Speed: 900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 900 2: 900 
  3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA driver: N/A bus ID: 01:00.0 chip ID: 10de:1f91 
  Display: x11 server: 1.20.7 driver: intel compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.6 Mesa 19.3.3 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.3.18-1-MANJARO 
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel port: 4000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlo1 state: up mac: <filter> 
  Local Storage: total: 476.94 GiB used: 55.04 GiB (11.5%) 
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: BC511 NVMe 512GB 
  size: 476.94 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 11001101 scheme: GPT 
  ID-1: / raw size: 97.66 GiB size: 95.62 GiB (97.92%) 
  used: 54.97 GiB (57.5%) fs: ext4 dev: /dev/nvme0n1p7 
  System Temperatures: cpu: 43.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 fan-2: 0 
  Processes: 275 Uptime: 3m Memory: 15.49 GiB used: 1.49 GiB (9.6%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 alt: 8 clang: 9.0.1 Shell: zsh 
  v: 5.7.1 running in: gnome-terminal inxi: 3.0.37

Then I tried looking the "dmesg" infos but I did not find any error related to what would be my internal microphone, and the journal did not contain anything related to the problem either. (i could have missed it though)

1 Like

:+1:Welcome to Manjaro!:+1:


Okay, I edited my post to include the output of the inxi command. I did not find anything in the dmesg output or the journal and they are probably too long to be posted here in their entirety.

Nearly midnight here now, so I'll respond tomorrow. In the meantime, please execute:

  • Press F6 and take screenshot, press Esc
  • Press F2 take /proc/sound/devices, press Enter, take screenshot, press Esc, press Esc, press Esc

Post screenshots

I'm in no hurry, thank you for helping me :smiley:
Screenshot from 2020-02-12 23-58-05
Screenshot from 2020-02-13 00-00-50 Screenshot from 2020-02-12 23-58-59

You seem to have 2 capture devices (=microphones) so that's good:


then press F4 and use and to switch between devices and use to ensure the volume is higher than 0 and if you end up making your microphone too loud.


I tried that but I only have one capture device displayed (see image below) and it is not detected by any application that I use (gnome settings, discord, firefox, etc.) :confused:
Screenshot from 2020-02-13 13-40-43

Install cheese and see if that works? :scream:

I tried recording a video and rubbing the microphone and speaking near it, but to no avail :frowning:
And to be clear the microphone works like a charm on windows.

@nikgnomic Calling the surgeon to the operating room! :innocent:

I'm at the end of my troubleshooting steps here... Can you have a look, please?

:scream: :mask:

Still no one? I can provide any other information if you tell me how to get it!

@nikgnomic Do you have any idea? If no, do you know who might be able to help here?

@Olomorn can you provide some info from Windows??? (EG, driver, hardware, ...)

I really don't know how to proceed any further here: all out of ideas...

I didn't find much, in the device manager it is listed as Intel Smart Sound Technology (Intel SST).
rundll32_xxmoLvoaJy mmc_oNjxGGebv9 mmc_nSFQHsH9IL

That should just work!

Does it still work under Windows??? (Try a Skype test call if you have Skype or Sound Recorder if that still exists nowadays or whatever...)

Yes it does, I often have to reboot on windows to make my video calls, and then come back to manjaro to work :confused:

Hold on for a minute!

Try the following:

  • Shut down the machine completely.
  • Cold boot straight into Manjaro and see if it works then!

(Grasping at straws now)

I'll do that, but I mean, I am in manjaro right now, and barely ever use windows except for the aforementioned video calls (and the occasional video game)

Okay so this did not help but also I noticed that the integrated speakers no longer seems to work and have been replaced with a "dummy output", and after seeing that I tried to plug in my jack headset and it is not detected anymore either, but my bluetooth earbuds works perfectly :scream:


That sounds like a side effect issue:

  • warm boot into Windows,
  • warm boot into Manjaro,
  • unpair the BlueTooth
  • and try again...

There is still only the dummy output!
And since I would only use the integrated speakers for video calls, I am not sure if this is a new problem or not! I am quite sure I didnt do anything to the drivers or anything...

Forum kindly sponsored by