Inspiron 7590 - integrated microphone not detected

@bogdancovaciu @nikgnomic

Can you guys have a look, please?

Pretty please with
:unicorn::unicorn::unicorn:
:rainbow::rainbow::rainbow:

Because I must be missing something stupid or this is a hardware failure or a side effect from Windows drivers messing up the system...

:upside_down_face: :cry:

I'm going to sleep now, but thank you very much for trying to help!

1 Like

Hello,
have a look here
https://wiki.archlinux.org/index.php/Dell_Inspiron_15_(7590)#Sound_card_not_detected
Add snd_hda_intel.dmic_detect=0 as kernel parameter and see if things change. :wink:

1 Like

Okay this definitely fixed the speaker issue and my headset is recognized \o/

The integrated microphone is still not recognized but there is a weird thing when I plug the headset in the audio jack: its speakers are recognized, its microphone too, but also a second microphone appears in the list and it does not seem to be usable or anything.
And if I plug just a microphone, the same thing happen but also a headset output is added (and its weird because it's just a microphone). It seems that no matter what I plug in the jack it enables an output, an input and a second input that does not work. (And as soon as I unplug it, the output and both inputs disappear)

1 Like

In pavucontrol , try changing the Pulseaudio output profile from "Analog Stereo Output" to "Analog Stereo Duplex", as per wiki ... might help :wink:

The "duplex" option was marked as "unavailable", I was able to select it but it did not seem to change anything. Also, reading the link you provided I noticed this:
image
So I guess this answer my question :frowning:
If you have any more recommendations regarding this "duplex" option, I'd be really grateful but it works as it is, so I think I will be okay either way. Thank you both for your help :smiley:

2 Likes

@Fabby - thank you for the mention. thought i had spotted all the posts on here about Intel Cannon Lake PCH audio devices

Intel Smart Sound Technology (Intel SST) DMIC is digital microphone array that was not supported for kernel v5.4.x
kernel boot paramater snd_hda_intel.dmic_detect=0 is needed to disable microphone for rest of audio to work with snd_hda_intel driver

dmic device needs new sof-firmware driver supported from kernel v5.5.2
archived.forum.manjaro.org/no-sound-card-detect-on-laptop-after-kernel-update

Intel Coffee Lake should be supported according to official documentation, but not much information there at the moment - thesofproject.github.io - supported-platforms

seems to be no definite solution yet from the main kernel bug report
https://bugzilla.kernel.org/show_bug.cgi?id=201251

this discussion seemed like it was close to a solution
archived.forum.manjaro.org - Laptop microphone not working (HP Omen 15)
but that seemed to have hit a bug with sof drivers not loading in absence of i915 gpu driver
that is only topic i have seen so far that has some ALSA data showing new drivers

might also see a resolution on - https://github.com/thesofproject/linux/issues

all i can suggest at the moment is try kernel v.5.5.x and get ALSA data for new drivers
sudo alsa-info.sh
but keep v5.4.x kernel for a 'mostly working' version
and check later kernel again if any future updates include alsa-lib

1 Like

new information has come to light...

Arch users had new drivers working with kernel v5.5.5, but it fell over again for v5.5.6
Arch bug report closed as confirmed fixed for kernel v5.5.7
https://bugs.archlinux.org/task/65635

kernel v5.5.7 is in Manjaro testing, should be in stable soon

confirmed working for Lenovo X1 Carbon (7th gen) and Acer Swift 5 (SF515-51T)

Archwiki has information about how to add an extra sink and source in Pulseaudio
wiki.archlinux.org - Lenovo ThinkPad X1 Carbon (Gen 7)#Audio
i think that is to get analog audio inputs and outputs with snd_hda_intel driver

suggest add this to Pulseaudio with a user configuration at /.config/pulse/default.pa, instead of editing system configuration /etc/pulse/default.pa

1 Like

Stable Update released yesterday [2020-03-03] includes kernel v5.5.7

new SOF driver confirmed working on Inspiron 7391

so if sof-firmware is installed
and boot parameter snd_hda_intel.dmic_detect=0 removed
microphone should work now

but if any audio devices are still not working
get ALSA data with sudo alsa-info.sh --upload and post the URL link here

2 Likes

Wow yeah, sorry I haven't replied to your previous messages as I didn't get to look into it but I just installed the update and sof-firmware and it works like a charm thank you !

1 Like

Hi @nikgnomic,
On my Inspiron 7590, withsof-firmware installed and snd_hda_intel.dmic_detect=0 removed, kernel 5.5.7, the system freezes after login. I'll post ALSA info later after changing the kernel.
Please help and have a look into this.

Hi Jeff,

:+1: Welcome to Manjaro! :+1:

It is better for you to open a new topic in the Newbie corner for your specific problem as this problem has already been solved whereas yours isn't... :innocent: :wink:

That way you'll get more eyeballs on your issue than here!

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by