Install Manjaro Linux hängt sich auf

Hallo!
Ich möchte gern Manjaro installieren, muß aber feststellen das sich der Installer immer bei der Hardwareerkennung aufhängt.
Selbst nach einer Stunde stand er noch bei 84%.

Wie bekomme ich es nun zum laufen, hat sich was am Installer geändert?
Ich hatte auf diesem Rechner schon früher Manjaro und das ohne Probleme.

Mein System ist ein Dell Optiplex mit 4 GB Ram und einer 1 TB Samsung V-Nanad SSD 860 QVO

Vielen Dank im voraus.

Ich habe es jetzt etwas anders gelöst. Ich habe mir eine älter Version ( KDE 12.1.7-stable-x86_64 von https://sourceforge.net/projects/manjarolinux/files/archive/ ) runtergeladen, auf DVD gebrannt und die Installation lief dann auch sauber durch.

Allerdings habe ich nun ein Problem, nachdem ich sudo pacman-mirrors -f && sudo pacman -Syyu gemacht habe.
Ich bekomme im Moment folgende Meldung:

Suche nach in Konflikt stehenden Paketen...

Pakete (3) archlinux-keyring-20200603-1  manjaro-keyring-20200603-1  manjaro-system-20200427-1

Gesamtgröße der installierten Pakete:  1,39 MiB
Größendifferenz der Aktualisierung:  0,33 MiB

:: Installation fortsetzen? [J/n] j
(3/3) Prüfe Schlüssel im Schlüsselring                                                             [##########################################################] 100%
(3/3) Überprüfe Paket-Integrität                                                                   [##########################################################] 100%
(3/3) Lade Paket-Dateien                                                                           [##########################################################] 100%
Fehler: Konnte Datei /var/cache/pacman/pkg/archlinux-keyring-20200603-1-any.pkg.tar.zst nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/cache/pacman/pkg/manjaro-keyring-20200603-1-any.pkg.tar.zst nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/cache/pacman/pkg/manjaro-system-20200427-1-any.pkg.tar.zst nicht öffnen: Unrecognized archive format
Fehler: Konnte den Vorgang nicht durchführen (Kann Paketdatei nicht öffnen)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

:: Starte vollständige Systemaktualisierung...
:: ca-certificates-cacert durch core/ca-certificates ersetzen? [J/n] ^C
Interrupt signal received

Kann es damit zusammenhängen das diese Version fast 2 Jahre alt ist?
Aber die 20.0.3 läßt sich ja leider nicht installieren.

Ja.
Alte pacman (und evtl. tar)-Versionen unterstützen noch keine ZSTD-komprimierten Pakete.
Wie alt genau weiss ich jetzt nicht, aber soweit ich mich erinnere ist diese Unterstützung noch relativ neu.

Hast Du die DVD auf Fehler überprüft?
Eventuell ISO auf USB Stick drauf tun, sind meist zuverlässiger als optische Medien.
Checksums und/oder digitale Unterschrift der ISO ebenfalls überprüft?

Ok, würde es helfen wenn ich sudo pacman -S pacman machen würde und anschließend noch einmal das Systemupgrade ?

Ich habe es auf DVD gebrannt weil ich Probleme hatte ein tool zu finden mit dem ich es auf einen USB-Stick ziehen konnte. Ich hatte es mal mit Etcher versucht und dann startete es nicht vom Stick.

Überprüfungen habe ich nicht gemacht, da ich damit noch nie Probleme hatte.

So ein Tool ist auf der jeder ISO mit dabei: dd:

z.B.
dd if=/Pfad/zur/ISO of=/dev/sdX status=progress conv=fdatasync

Die Pfade müssen natürlich entsprechend angepasst werden.
Mehr (englische) Infos habe ich hier gefunden:

Verständlich, aber solltest Du trotzdem tun, zumindest die SHA1 Checksum ist schnell überprüft.

Das ist eine gute Überlegung, aber ich bezweifle dass es funktioniert; kannst natürlich trotzdem mal probieren :wink:

1 Like

Wegen dem pacman Fehler:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu
1 Like

Danke, das wars anscheinend.
Ich mache gerade ein Upgrade von 1281 Paketen ( das lohnt sich ) und dann werden wir mal sehen wie es anschließend läuft.

Wenn es einwandfrei läuft werde ich morgen wahrscheinlich endlich meine gesicherten Daten rüberziehen können.

Meine Versuch hat natürlich nicht geklappt. Was ich vergaß - das neue Pacman wird natürlich auch im neuen Zstd angeliefert und dann bin ich wieder da wo ich vorher auch war - nur eben mit Pacman.

Es lief ganz gut - aber leider wurde das Upgrade abgebrochen.


...
lib32-vulkan-icd-loader-1.2.141-1-x86_64                              120.3 KiB   885 KiB/s 00:00 [##########################################################] 100%
 steam-manjaro-1.0.0.62-2-x86_64                                         2.9 MiB   827 KiB/s 00:04 [##########################################################] 100%
(1194/1194) checking keys in keyring                                                               [##########################################################] 100%
downloading required keys...
:: Import PGP key 428F7ECC7117F726, "Helmut Stult <helmut@manjaro.org>"? [Y/n] y
:: Import PGP key E742683BA08CB2FF, "Morten Linderud <foxboron@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key F893C674816AA95D, "Filipe Laíns <lains@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 019A7474297D8577, "Daniel Bermond <dbermond@archlinux.org>"? [Y/n] y
:: Import PGP key 019A7474297D8577, "Daniel Bermond <dbermond@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dave@sleepmap.de>"? [Y/n] y
:: Import PGP key EA4F7B321A906AD9, "Daniel M. Capella <polyzen@archlinux.org>"? [Y/n] y
:: Import PGP key 428F7ECC7117F726, "Helmut Stult <helmut@manjaro.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 3B94A80E50A477C7, "Jan Alexander Steffens (heftig) <heftig@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dave@sleepmap.de>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dave@sleepmap.de>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dave@sleepmap.de>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dave@sleepmap.de>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dave@sleepmap.de>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dave@sleepmap.de>"? [Y/n] y
:: Import PGP key F98EF2A7B0A098AE, "Chih-Hsuan Yen <yan12125@archlinux.org>"? [Y/n] y
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
:: Import PGP key 150C200743ED46D8, "Mark Wagie <mark@manjaro.org>"? [Y/n] y
y
(1194/1194) checking package integrity                                                             [##########################################################] 100%
error: krb5: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/krb5-1.18.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: libseccomp: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/libseccomp-2.4.2-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: qt5-base: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust
:: File /var/cache/pacman/pkg/qt5-base-5.15.0-3-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: acpid: key "E742683BA08CB2FF" is unknown
:: Import PGP key E742683BA08CB2FF? [Y/n] y
:: File /var/cache/pacman/pkg/acpid-2.0.32-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: tdb: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/tdb-1.4.3-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: dav1d: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/dav1d-0.7.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: tevent: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/tevent-1:0.10.2-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: exfat-utils: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/exfat-utils-1.3.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: hwloc: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/hwloc-2.2.0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: openmpi: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/openmpi-4.0.3-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: gconf: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust
:: File /var/cache/pacman/pkg/gconf-3.2.6+11+g07808097-7-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: python-distro: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/python-distro-1.5.0-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: jre8-openjdk-headless: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/jre8-openjdk-headless-8.u252-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: jre8-openjdk: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/jre8-openjdk-8.u252-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: jdk8-openjdk: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/jdk8-openjdk-8.u252-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: lib32-lz4: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/lib32-lz4-1.9.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: confuse: signature from "Baptiste Jonglez <baptiste@bitsofnetworks.org>" is unknown trust
:: File /var/cache/pacman/pkg/confuse-3.2.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: vpnc: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/vpnc-1:0.5.3.r468.r81-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: openconnect: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/openconnect-1:8.10-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: pkgconf: signature from "Johannes Löthberg <johannes@kyriasis.com>" is unknown trust
:: File /var/cache/pacman/pkg/pkgconf-1.7.3-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: python-cachecontrol: signature from "Eli Schwartz <eschwartz@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/python-cachecontrol-0.12.6-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: python-yaml: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: File /var/cache/pacman/pkg/python-yaml-5.3.1-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: qbittorrent: signature from "Eli Schwartz <eschwartz@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/qbittorrent-4.2.5-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: game-devices-udev: signature from "Mark Wagie <mark@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/game-devices-udev-0.7-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Kann es sein das es hieran liegt ?

sudo pacman -S pacman-static
:: Some packages should be upgraded first...
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (3) archlinux-keyring-20200603-1  manjaro-keyring-20200603-1  manjaro-system-20200427-1

Gesamtgröße der installierten Pakete:  1,39 MiB
Größendifferenz der Aktualisierung:  0,33 MiB

:: Installation fortsetzen? [J/n] j
(3/3) Prüfe Schlüssel im Schlüsselring                                                             [##########################################################] 100%
(3/3) Überprüfe Paket-Integrität                                                                   [##########################################################] 100%
(3/3) Lade Paket-Dateien                                                                           [##########################################################] 100%
Fehler: Konnte Datei /var/cache/pacman/pkg/archlinux-keyring-20200603-1-any.pkg.tar.zst nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/cache/pacman/pkg/manjaro-keyring-20200603-1-any.pkg.tar.zst nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/cache/pacman/pkg/manjaro-system-20200427-1-any.pkg.tar.zst nicht öffnen: Unrecognized archive format
Fehler: Konnte den Vorgang nicht durchführen (Kann Paketdatei nicht öffnen)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Warnung: pacman-static-5.2.1-3.2 ist aktuell -- Reinstalliere
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (1) pacman-static-5.2.1-3.2

Gesamtgröße der installierten Pakete:  4,78 MiB
Größendifferenz der Aktualisierung:  0,00 MiB

:: Installation fortsetzen? [J/n] 

Dann pacman mauell herunterladen: dazu im Forum suchen

1 Like

Upstream notice

Arch updated their default compression to zstd . We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static
sudo ./pacman-static -Syyu

...

1 Like

Ich habe jetzt die 19.0.2 von Wo finde ich die ältere Version KDE 19.0 Kyeria runtergeladen und installiert.
Es lief schon wesentlich besser als die 17.1.7 und das Upgrade scheint auch besser durchzulaufen. Mal sehen bis es durchgelaufen ist.

Wenn es keine Probleme gibt werde ich noch heute meinen Umstieg von Win 7 nach Manjaro abschließen.

Ein Dankeschön an alle die mir geholfen haben.

Forum kindly sponsored by