Install Manjaro on Surface Book 2 13" GTX1050

They are looking for information regarding the surface book 2 not the macbook pro.

You have gone in and switched to AHCI via the bios, correct? That seems to be the solutions that is mentioned the most when your internal hard drive is not recognized.

That was a hint to the search function in the forum.

Hello. Surface Book UEFI doesn't have any options for ACHI. I feel like this is the issue but I literally can't find a way to turn it on via BIOS/UEFI menu on this Surface Book 2. I did attempt to change regedit values but those seems to change back to defaults.

I literally don't understand how to get Manjaro on this.

I wonder if TLP is getting in your way. And acting weird on your Surface Book. Another thing you can try. Set up your partition on Ubuntu. Then try again on Manjaro Architect. Try looking in to any power management. Disable it.

What's TLP?

Another question if anyone can answer, maybe I am just confusing myself. Does the EFI partition have to be on the same as windows? I am thinking EFI, root/home can be on separate drives.. The bootloaded does have to be on the same one as the Windows right?

https://wiki.archlinux.org/index.php/TLP advanced power management for Linux without the need to understand every technical detail

As for partition. If your not sure what to do. You be safer to make the partition on another hdd.
EFI, root, and home partition is fine. You might want to make root a little bigger. like 20GB root.
As for dual booting. There a guide on the forum.

1 Like

15697253082653344186290875894196

I can't even install on the microSD?
All mount points were established properly.

Have a look in SurfaceUEFI. I own gen 1 surface book. I notice when this area was lock. It block me from installing bootloader
_20190928_211418

2 Likes

the problem is with calamares

try downloading
another version of calamares in liveboot
with

sudo pacman -Syy calamares

or

sudo pacman -Syy calamares-git
1 Like

Unlocked the boot order lock. I never thought of this.
Also performed the command on Konsole.

Shouldn't I have done -Syu ?
I'm still trying to familiarize myself with the commands.

Its currently at 29% of the install. It usually failes around the bootloader towards the end. We'll see how it goes. I'll post an update soon.

Wow! So installation was successful. It may have been the boot order lock causing it.

But now I cannot load into Manjaro. I changed my bootorder just like above image.

Shouldn't I be seeing Grub selection screen?

My only concern is because its on the microsd thus won't be bootable?

Sadly internal SSD doesn't show up at all.

@Librewish @Days

check if fat32 partition has
boot flag.
from liveboot.

20190929_005422

I had ran this prior to rebooting after install.

Is there a specific command to run so I can check this?

check in kde partition manager

20190929_011425

I got this using Parted and seems that flag is up.

From KDE Partition Manager
20190929_011807

I think boot flag is up.

You have a Microsoft Surface Book 2. And that's tied to boot using only Microsoft keys. You were able to install Ubuntu because Ubuntu use shim boots that has microsoft keys that it paid for it, reluctantly. Unlike Red Hat who pushes for it. Manjaro will have nothing to do with it, hopefully based on principles and not lack of capability.

You can still install Manjaro in it (make sure secure boot is off - fastboot also off, though not connected to this specific issue). But you probably cannot boot it.

[A] -

Check if the $esp still has ubuntu shim.efi
You can check with a microsoft key capable (prefer the word sanctioned) linux OS livecd.
I don't know how to check through windows, should be a way, but I don't know how.
Check this topic

Key point..

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/Ubuntu/shimx64.efi

[B] -

If there is no longer any ubuntu efiboot entry (or shim keys)
See this topic.
Key points --
move microsoft efi file up a level

sudo cp /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi /boot/efi/EFI/Microsoft/bootmgfw.efi
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi

Add a custom.cfg entry

1 Like

So the install was successful to the microSD. But can't seem to boot into it. I do have secure boot disabled and fatboot also.

I did look at this before but I am not so familiar with the process as I lack linux skills but am willing to try and see where it goes.

But with Secure Boot disabled and the full install of Manjaro shouldn't it Boot still? Does this have anything to do with it being on the microSD? The bootorder? Which I have changed to like above.

Not a good thing.
For one, it is slow.
For two, some bios cannot detect it and won't boot.
For three, .... :grinning:

Ahh.. yes I agree. But my internal SSD doesn't even show up on the install.. nor on KDE partition manager. The drive isn't even listed in the drop down menus.

Forum kindly sponsored by