Install New Manjaro 19 Can't Go To Sleep

A week ago, I installed new Manjaro 19 Pre2 (stable branch), KDE. When going to suspend (sleep), monitor and keyboard turned to sleep, it's look like hard disk also turn to sleep, but cpu fan (and led) still on. I've tried to identified from other forum but nothing success. What's happened? I have Manjaro KDE installed (testing), but it can go to sleep mode. It is the first time installing Manjaro on second system, but it can't go to sleep mode.

$ inxi -Fxxxz
System:    Host: leo-pckde2 Kernel: 5.5.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           Desktop: KDE Plasma 5.17.5 tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: H110M-E D3 v: Rev X.0x serial: <filter> 
           UEFI: American Megatrends v: 2604 date: 02/22/2018 
CPU:       Topology: Dual Core model: Intel Pentium G4400 bits: 64 type: MCP 
           arch: Skylake-S rev: 3 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13205 
           Speed: 800 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 800 2: 800 
Graphics:  Device-1: NVIDIA G94 [GeForce 9600 GT] vendor: Gigabyte driver: nouveau 
           v: kernel bus ID: 01:00.0 chip ID: 10de:0622 
           Display: x11 server: X.Org 1.20.7 driver: nouveau unloaded: modesetting 
           alternate: fbdev,nv,vesa compositor: kwin_x11 resolution: 1366x768~60Hz 
           OpenGL: renderer: NV94 v: 3.3 Mesa 19.3.4 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK 
           driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
           Sound Server: ALSA v: k5.5.2-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
           chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.48 TiB used: 257.92 GiB (17.0%) 
           ID-1: /dev/sda vendor: Intel model: SSDSC2BW180A3L size: 167.68 GiB 
           speed: 6.0 Gb/s serial: <filter> rev: LE1i scheme: GPT 
           ID-2: /dev/sdb vendor: Samsung model: HD103SJ size: 931.51 GiB speed: 3.0 Gb/s 
           rotation: 7200 rpm serial: <filter> rev: 00E5 scheme: MBR 
           ID-3: /dev/sdc vendor: Seagate model: ST3320311CS size: 298.09 GiB 
           speed: 3.0 Gb/s rotation: 5900 rpm serial: <filter> rev: SC13 scheme: MBR 
           ID-4: /dev/sdd vendor: SanDisk model: SD6SB1M128G1022 size: 119.24 GiB 
           speed: 6.0 Gb/s serial: <filter> rev: 600 scheme: GPT 
Partition: ID-1: / size: 43.92 GiB used: 9.15 GiB (20.8%) fs: xfs dev: /dev/sda6 
           ID-2: /home size: 50.93 GiB used: 10.06 GiB (19.7%) fs: ext4 dev: /dev/sdd3 
           ID-3: swap-1 size: 7.24 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdd4 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 50 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 0 
Info:      Processes: 178 Uptime: 3m Memory: 7.72 GiB used: 842.9 MiB (10.7%) 
           Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
           running in: konsole inxi: 3.0.37
GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=66d1ac91-d2c9-420c-a6cc-13589aa24490 udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

Also it is the first time using free driver.

Sleep and Hibernate is two different issues.

Sleep leaves some led on while hibernate shuts down everything.

maybe this system requires some usage of OSI or ACPI parameters (because ASUS) that the other doesn't to make power states work correctly. Two references for you to work through:

I'm using "Sleep Mode" since first time using Manjaro several years ago. I have another Manjaro installed (testing branch) on my PC. It's had no problem with sleep or hibernate mode. But few days ago, installed Manjaro KDE on other partition, it can't go to sleep mode. CPU/GPU fans still active. The system going to freeze.

I think I found the solution by install Kernel linux419. Just installed, the choose from grub to boot. My pc going to sleep well (normal), also go to hibernate. It's curious, because I have manjaro kde installed before using linux54, but with nonfree driver vga. I don't know it's about kernel or nouveau?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by