Install Nvidia Drivers Problem (Libhd.so.21)

Hello! I am having a problem with installing Nvidia Drivers. Every time I try and install the driver, it says "Cannot load library /usr/lib/qt/plugins/msm_mhwd.so: (libhd.so.21: cannot open shared object file: No such file or directory." Also, when I try and go to hardware configuration the same exact thing happens. Hardware configuration also states:
"An error occurred during you last system upgrade, leaving an orphaned control module behind", and
"You have old third party modules lying around"
I have restarted my computer, and done sudo pacman -Syyu, both which did nothing. Any help? Thanks :slight_smile:

Hello,

Is part of manjaro-settings-manager-kcm

Is from hwinfo

My suggestion is to run this command:

sudo pacman-mirrors -f && sudo pacman -Syyu manjaro-settings-manager-kcm hwinfo

Reboot once is done, and try to install nvidia driver again.

Thank you! I'm installing it rn. I'll let you know how it turns out.

Great! My Nvidia drivers are working, but now my laptop is not connecting to my monitor. I am using a DP port rn.

In that case, even tho is a different issue, check this out

Well, uh, I think I broke Manjaro... Its kicking in a stupid amount of fan and also showing a terminal window and my background and that's it. Um, not really sure what optimum manager really did, but gonna have to reinstall Manjaro I think.

Please provide from terminal
inxi -Fxxxza --no-host
You have to make sure you read that tutorial twice, then start doing what is instructing.

I mean it worked, I saw the Intel and Nvidia switcher, but the second I switched to Nvidia then it gave me all of this weird stuff. Also, I'll attach what I'm seeing with my phone. Here's what I got:

System:    Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=1349d4f1-3e87-48c0-91d6-ab09d92207de rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.19.3 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81LF v: Lenovo Legion Y7000P-1060 serial: <filter> Chassis: type: 10 
           v: Lenovo Legion Y7000P-1060 serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN serial: <filter> UEFI: LENOVO v: 9VCN18WW date: 04/28/2019 
Battery:   ID-1: BAT0 charge: 34.2 Wh condition: 48.9/57.0 Wh (86%) volts: 11.1/11.5 model: SMP L17M3PG2 type: Li-poly 
           serial: <filter> status: Discharging cycles: 180 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: D6 L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 874 2: 823 3: 841 4: 840 5: 841 6: 837 7: 800 8: 800 
           9: 801 10: 836 11: 868 12: 842 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Lenovo driver: nvidia v: 440.100 bus ID: 01:00.0 
           chip ID: 10de:1c20 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia compositor: kwin_x11 tty: N/A 
           OpenGL: renderer: GeForce GTX 1060/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f1 
           Sound Server: ALSA v: k5.6.19-2-MANJARO 
Network:   Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: Lenovo ThinkPad E595 driver: rtw_pci v: N/A 
           port: 4000 bus ID: 07:00.0 chip ID: 10ec:b822 
           IF: wlp7s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000 
           bus ID: 08:00.0 chip ID: 10ec:8168 
           IF: enp8s0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 37.94 GiB (3.2%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKW256G8L size: 238.47 GiB block size: physical: 512 B logical: 512 B 
           speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: L08C scheme: GPT 
           ID-2: /dev/sda vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: LXM3 scheme: GPT 
Partition: ID-1: / raw size: 238.17 GiB size: 233.43 GiB (98.01%) used: 37.94 GiB (16.3%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 59.0 C mobo: N/A gpu: nvidia temp: 50 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 289 Uptime: 1m Memory: 15.51 GiB used: 1011.2 MiB (6.4%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.18 running in: konsole inxi: 3.0.37

15960507413734671955465279235524

If you will edit the comment above, please use code tags ``` above and bellow the output text.
The interface is up scaled, hence is not fitting the monitor resolution.
Type in that terminal
systemsettings5
And try to navigate to Display Settings and change the resolution and layout.

My monitor is still not showing anything on Nvidia, Intel, or Hybrid mode. The resolution is now fixed, but is there a reason my monitor stopped working?

Ok, now that you updated the system, you have to change the kernel. The one you are using is EOL. Run this command
sudo mhwd-kernel -i linux57
Reboot after that. Take a look again if there are any inconsistencies mentioned for optimus-manager.

Forum kindly sponsored by