Install of grub fails (calamares)

I've used manjaro for a while an it's really nice.
I bought a new SSD and decided to install new because in the past I didn't encrypt the whole system, only /home. Install / new and encrypt it was no solution for me, because I don't want to type one more password.

Edit: I want my whole system encryptet, without /boot/efi (as I understand, it has to be decrypt to get this setup work)

The last 3 days I tried two ways to install manjaro, both have issues.

I made 2 partitions with gdisk:

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048         1050623   512.0 MiB   EF00  
   2         1050624      1875384974   893.8 GiB   8300  Linux filesystem

cryptsetup encrypted partition 2
lvm made 3 partitons and activated with

vgscan --mknodes
vgchange -ay

outupt lsblk

nvme0n1     259:0    0 894,3G  0 disk  
├─nvme0n1p1 259:1    0   512M  0 part  
└─nvme0n1p2 259:2    0 893,8G  0 part  
  └─lvm     254:0    0 893,8G  0 crypt 
    │       254:1    0   150G  0 lvm   
    │       254:2    0    64G  0 lvm   
            254:3    0 679,8G  0 lvm 


nvme0n1     259:0    0 894,3G  0 disk  
├─nvme0n1p1 259:1    0   512M  0 part  /mnt/boot/efi
└─nvme0n1p2 259:2    0 893,8G  0 part  
  └─lvm     254:0    0 893,8G  0 crypt 
    │       254:1    0   150G  0 lvm   /mnt
    │       254:2    0    64G  0 lvm   [SWAP]
            254:3    0 679,8G  0 lvm   /mnt/home


The graphical installer finds all partitions, starts the installation and ends with this error: Installer%20grub%20error

Boost.Python-Fehler in Job "bootloader".
Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force' returned non-zero exit status 1.
Installing for x86_64-efi platform. grub-install: error: cannot find a device for /boot/grub (is /dev mounted?).

File "/usr/lib/calamares/modules/bootloader/", line 444, in run

  File "/usr/lib/calamares/modules/bootloader/", line 411, in prepare_bootloader
    install_grub(efi_directory, fw_type)

  File "/usr/lib/calamares/modules/bootloader/", line 285, in install_grub

  File "<string>", line 5, in <module>
grub-install /dev/nvme0n1p1
x86_64-efi wird für Ihre Plattform installiert.
grub-install: Fehler: EFI-Verzeichnis kann nicht gefunden werden.

Same disk setup. The installation finish and I can boot. The Problem in this case: I have to enter the password before grub and this is really annoying because I have a german keyboard and grub only accept us layout.

Has anyone an idea how I get this setup work like: grub starts, I enter my password with german key layout and the login screen appears.

Thanks and regards

And again:

Why do you want a crypted swap ?

I found the easiest way is to follow installer automatically creating partition.
On my machine installer sipped Swap but I recreated later on swap as file, which I think is better way anyway.
If for any reason i need more swap then my current configuration I can delete the file and recreate new one bigger.

On some systems like "BSD" and others there is a option for crypt in the "swap-tools". So its normal...

I encrypt swap because I want to use hibernate. Another point is, that I needed in the past to change my partitionsize and with lvm I thought this would be pretty easy

Try using this.

I tried

grub> search.file /intel-ucode.img root

but I find nothing. How could? The installer isn't able to install.
I installed ubuntu, just to get a grub installation but it doesn't work, same error.
I hope someone has another idea..
I don't know if this matters, the ubuntu liveCD wasn't able to mount my logical volumes

That's for a separate boot partition.
A /boot/efi is not a separate boot partition.
Have you tried ?

grub> search.file /etc/manjaro-release

Any output?
If yes, continue with

grub> search.file /etc/manjaro-release root

and follow up with the rest of the commands.
Remember, when booted up, do the 2 [Additional UEFI commands] as well.

it shows: error: no such device.
My /boot/efi is an extra unencrypted partition, so I tried the other command.
If I hadn't installed ubuntu there would be no grub. That is my problem

First, a caveat. I do not use encryption. A full encrypted disk has different device mapping nomenclature as well as UUID convention in the sense that after decrypting the partition the uuid 'changes'. See /etc/crypttab for details.

But from what you wrote, I take it that you only has your /home encrypted. Not /boot/efi $esp nor your /boot (in / partition) nor your /. But /home would be in your fstab anyway and here I do not understand if you will need to decrypt it at grub or at OS boot up. Please help me understand this.

Also, you said

What do you mean by that? Are you using Ubuntu's grub to boot Manjaro? If so, provide the manjaro entry at Ubuntu grub.

Lastly, as said, not having any experience with encryption may prove not possible for me to help at all. Be prepared for this and unfortunately, unless pleasantly disproved, you will be not be able to have much help in this forum.

Oh, late here. Good night.

Thank you for your help. I'm full of hope that someone will have the missing hint for me :wink:

You need an unencrypted boot partition AFAIK.

But IMHO you should look for a solution to your real problem, which sounds it is

enter password with German keyboard.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by