Install problem, stops at PXE boot screen

I suspect there's a slight language barrier here. Have you considered posting in #deutsch:installation-und-konfiguration ?

Gave that a try but the germans are asleep at that time :smiley:

check also in bios
order on boot
dont let PXE / TPM appears in the list

Deactivated that option already, but now it only kicks me back to the boot menu..

Sounds like a missing boot loader.

Or, just try installing again.

(Why don't people try this without prompting? If the installation fails for some reason, why not just try installing again? I don't get it...)

Thanks a lot! The terminal is asking for a password to acess root.

manjaro, my bad :smiley:

You need to provide far more information (e.g. a full description of the issue) if you want to get effective help. This link provides a good starting point for things to think about:

Otherwise, waiting until a German-speaker is able to respond will make this easier for everyone.

(Unless someone else here is happy to spend the time extracting information from you...)

sudo pacman -S mhwd-chroot says that core, extra.. does not exist

Try a search. Hint: the solution involves -Sy.

Had no sucess.

Still trying to fix this issue.

[manjaro-gnome manjaro]# # mkdir /mnt/manjaro
[manjaro-gnome manjaro]# # mount /dev/sda1 /mnt/manjaro
[manjaro-gnome manjaro]# cd /mnt/manjaro
bash: cd: /mnt/manjaro: No such file or directory
[manjaro-gnome manjaro]#

What are you trying there ? :slight_smile: You have extra # in those commands ...
At this point is not clear for me if you installed Manjaro on your internal HDD or not, if is the only OS or not.
My suggestion if you want only Manjaro on your Laptop, to let the installer create the partitions and boot, don't make it manually. If is installed and there is still no GRUB BOOT menu, then boot from your installation media again, open terminal and do:
sudo pacman-mirrors -f10 && sudo pacman -Syy mhwd-chroot
once that is done run
sudo mhwd-chroot
considering that the Manjaro is installed on sda3, and /dev/sda1 is Boot partition while /dev/sda2 is the Swap partition then you run (still in terminal):
mount /dev/sda3 /mnt
but since you want to fix the Boot, then you do this:
mount /dev/sda1 /mnt/boot
then you install grub and since your machine has UEFI then:
sudo mkdir /boot/efi
sudo mount /dev/sda1 /boot/efi
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
sudo update-grub

All this can be found here and was explained also in more detail here and is for a Lenovo laptop, so i would consider following those instructions:

1 Like

Thanks a lot! I followed your steps, but got stuck in
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi
because it says that /boot/efi doesn´t look like an EFI partition

Well, did you make a fat32 partition for /boot/efi when you installed?

Tried Using livecd v17.0.1 (and above) as grub to boot OS with broken bootloader but had no luck. I have no idea what could cause the problem.

But after the install I only have sda1 as a partition listet, so Manjaro is installed there. Sda2 is swap and that's it :roll_eyes:

My guess is that you install it in legacy mode because you set your computer like that when boots from USB, not UEFI, hence the separate partition for boot is not created, but rather is part of the system partition as if was MBR install, not GPT, not suitable for efi --target ... Take a look again and pay attention to the difference. As @Strit pointed out, you might have to

That means you have to make the partitions manually and also set the correct boot flags for them.

Hey people, it's fixed here.
He wrote another topic under another name.
Like akontio, he's not specific how's that's fixed, I can guess but perhaps their writing skills aren't that great.


Forum kindly sponsored by