Install rtl8812au-dkms-git driver

I'm trying to install the following rtl8812au driver ( … mments=all) on Manjaro for my wifi adapter (Archer T4U AC1300 V2). But when I run the make command, I get the following message:

make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.14.53-1-MANJARO/build M=/home/genius/Desktop/rtl8812au-driver-5.2.20-master  modules
make[1]: Entering directory '/usr/lib/modules/4.14.53-1-MANJARO/build'
make[1]: *** No rule to make target 'modules'.  Stop.
make[1]: Leaving directory '/usr/lib/modules/4.14.53-1-MANJARO/build'
make: *** [Makefile:1830: modules] Error 2

I have already (re)installed linux-headers and base-devel. My kernel version is:

I'm starting to get really frustrated because I can't find a direct answer. All I can find is "build your modules" or "compile your headers"... But I've just picked up linux and I don't have any idea how any of that works...
Anybody, please help?

Your link is bad, and as there are a few 8812's its hard to know which you are talking about

If its this one

Please try again with 4.17 kernel

Realtek rtl8812au DKMS driver install:

If your Realtek WiFi connection is not working at all you will need an alternate means to connect to the internet. You can use a wired LAN connection if your computer has a NIC, (and a wired connection is available). The other alternative for wired connectivity is to use a USB to Ethernet adapter if you have one.

If a wired connection is not an option, then you have several other wireless connectivity options. If you have an older USB WiFi dongle available with built in kernel support this is a good option to use temporarily. The other option that is widely used is Android USB phone tethering. Ensure you have some method to install a new driver and other required packages before attempting to replace any currently installed driver.

If you have no connection means available on your Manjaro computer it is still possible to install your drivers. However, the procedure is a little complicated and outside the scope of what a general tutorial can provide.

This guide assumes you already have some method of connecting and downloading the required files locally. We will now proceed with the instructions on the correct procedures for preparation and installation of the driver.

You may have already tried unsuccessfully to install your Realtek rtl8812au drivers.

If you have installed the linux-headers, or any other rtl8812au driver packages previously, please uninstall them before proceeding.

If you have installed any other DKMS packages related to rtl8812au, then uninstall them completely as well.

See the end section "Uninstalling A Non-Functioning Driver".

After uninstalling all related rtl8812au driver, header, or dkms packages, perform the following steps.

Ensure your Manjaro installation is fully up to date with this terminal command:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu

Once the command has finished running, reboot the computer.

Installing the required linux headers:

You must install the required linuxXXX-headers package before installing the rtl8812au drivers.

Install all the required linux-headers packages for all kernels installed on your system with this command:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

*credit @dalto for the above command

Once the linux headers installation is complete:


Installing the rtl8812au-dkms-git driver:

The rtl8812au driver may not install correctly if the USB adapter is plugged-in before the driver is installed.

Do not insert the rtl8812au WiFi dongle into any USB port until the driver installation is complete.

You may install the "rtl8812au-dkms-git" driver package using any AUR helper. However, my instructions are for installing via the terminal with pamac-cli.

Install pamac-cli along with the required driver dependencies:

sudo pacman -S bc dkms git base-devel pamac-cli --needed

To install the driver for the rtl8812au adapter from the AUR issue this command:

pamac build rtl8812au-dkms-git

After installation, ensure all network adapters are not blocked.

Enter the following command in the terminal.

sudo rfkill unblock all

Then, power down the computer.

Plug in your USB network adapter directly into the computer, (not through a USB hub).

The rtl8812au adapter has been reported to sometimes work better over USB 2.

Try plugging the adapter into a USB 2 port to start with.

Unplug your wired network LAN cable prior to powering up the computer.

Restart the computer, and test if your connection is now working.

If your WiFi is still not working properly after restarting continue with the following steps:

  1. Stop Network Manager:
sudo systemctl stop NetworkManager 
  1. Load your module into the kernel:
sudo modprobe 8812au
  1. Raise your Device (WiFi adapter):
DEVICE=$(hwinfo --wlan | grep "Device File" | cut -d " " -f5) && sudo ip link set $DEVICE up
  1. Ensure all network adapters are unblocked:
sudo rfkill unblock all
  1. Then restart network manager:
sudo systemctl start NetworkManager

If your WiFi is still not working properly after running those commands, then run:

sudo depmod -a
sudo mkinitcpio -P

If still not working, then unplug the wireless network adapter from the USB port.

Then, power down the computer.

Once the computer is off, plug the WiFi dongle into a different USB port.

Ensure the WiFi dongle is attached directly to the computer, (not through a USB hub).

If the WiFi was on a USB 2 port initially, then switch it to a USB 3 port, (& vice versa if an alternative is available).


If your connection is still not working then you will need to post diagnostic outputs on the forum.

Enter the following commands individually in the terminal, and post the command output on the forum:

Please post the input/output of the following commands:

lsmod | sort
dkms status
sudo rfkill list 
lspci -knnvvv | grep -i net
hwinfo --netcard --bluetooth | grep -Ei "(speed|hotplug|model|status|cmd|file|detected|driver:)" | grep -v "Config S"  
inxi -Fxxxz  && inxi -Fxxxz  | grep -q ANJ || echo check required && ls /usr/share/xsessions/ && head -n1 /var/log/pacman.log | cut -d " " -f1 | cut -c 2-11
sudo dmesg  | grep -Ei 'error|segf|fail|broke|warn|dump|denied|firm|qos|oops|bug|regdom|wmi|rtl|wl|ath|b43|bcm|brcm|eth|enp|r816|blue|deauth' | grep -viE 'acpi|ras'
grep -r "blacklist\|install\|options"  /etc/modprobe.d/ /etc/modules-load.d/ /usr/lib/modprobe.d/ 
pacman -Qsq ^linux | grep ^linux | grep -viE 'api|firm|nvidia' && echo  Running Kernel $(uname -r)
journalctl --no-pager -S "$(date +'%Y-%m-%d')" -u NetworkManager  | grep -i 'discon\|error\|seg\|fail\|broke\|warn\|change\|wl\|rtl\|8812' 

Please post the input/outputs of all the above commands, (as well as any error messages returned during the installation process).

Uninstalling A Non-Functioning Driver:

Ensure your Ethernet connection is working properly before uninstalling a problematic WiFi driver.

First, uninstall all unneeded linux headers packages from your system,(substute your kernel number):

sudo pacman -Rns linux414-headers

Remove any other linuxXXX-headers packages that were installed for other kernel versions as well.

If you would rather use one command to uninstall all the linux-headers packages automatically, use the following command (courtesy of @AgentS):

sudo pacman -R $(ls /boot | awk -F "-" '/^linux/ { print $1"-headers" }')

Now we begin the process of completely uninstalling any improperly installed drivers.

Unload the module of the driver you want to uninstall:

sudo rmmod 8812au

Uninstall the non-functioning driver package:

sudo pacman -Rns rtl8821au-dkms-git

Note: it has been reported the rtl8821au-dkms-git package is no longer working with the rtl8812au adapter of late.

Substitute the driver you installed in the above command in place of "rtl8821au-dkms-git" (if you installed a different driver version).

Uninstall the dkms package if it is still installed:

sudo pacman -Rns dkms

Unloading the wifi modules is not always successful with an rmmod command. Rebooting is the surest way to ensure the uninstalled driver modules are removed.


Then continue following the directions in the "Installing the required linux headers" and "Installing the rtl8812au-dkms-git driver" sections (from the beginning).


You sir, are my personal hero. Thank you very much!

1 Like

You're welcome.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by