Install the driver for the RTL8188FU adapter

systemctl status NetworkManager
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: dis>
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
             └─NetworkManager-ovs.conf
     Active: active (running) since Thu 2020-07-02 16:24:09 IST; 12s ago
       Docs: man:NetworkManager(8)
   Main PID: 9043 (NetworkManager)
      Tasks: 4 (limit: 2322)
     Memory: 3.8M
     CGroup: /system.slice/NetworkManager.service
             └─9043 /usr/bin/NetworkManager --no-daemon

the adaptor is plugged in.

Was there any output from the first set of commands?

If there was no error message your adapter's driver should now be loaded. Did you test for connectivity?

Please post:

inxi -nz

ping -c5 8.8.8.8; ping -c5 google.com
1 Like

No

Outputs -

 inxi -nz
Network:
  Device-1: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Realtek 802.11n type: USB 
  driver: usb-network 
 ping -c5 8.8.8.8; ping -c5 google.com
ping: connect: Network is unreachable
ping: google.com: Name or service not known

By the way, I am connected to the internet via a USB dongle. That's how I am writing this reply on here.

@tbg is there any tools that I might have removed accidentally? When I installed Manjaro, I did not need wifi so I deleted items right after install and masked the rest for a faster boot up

No, that is not the problem. I just ran a search on your adapters ID. That is not the correct driver for Arch/Manjaro based systems on the CD. This is a very, very difficult adapter to get working. I rarely every see this adapter come up on the forum.

I'll try to find some new drivers for you.

1 Like

But 8188eus is exactly what they sent me in the CD

You need to uninstall the driver you installed before. They ship the wrong driver on the factory installation media. It is not the correct driver for this adapter and will not work. It must be removed and the proper driver needs to be installed.


Install the driver for the RTL8188FU adapter:


Install kernel 4.19:

sudo mhwd-kernel -i linux419

Then boot into kernel 4.19.

Press the ESC key repeatedly during boot up to select kernel 4.19 from the grub boot menu.

The following command will install the linux-headers automatically for all installed kernels:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

Command courtesy @dalto

Install the rtl8188fu driver

Follow these instructions to install the rtl8188fu driver:

git clone https://github.com/corneal64/Realtek-USB-Wireless-Adapter-Drivers.git

cd Realtek-USB-Wireless-Adapter-Drivers

sudo dkms add ./rtl8188fu

sudo dkms build rtl8188fu/1.0

sudo dkms install rtl8188fu/1.0

sudo cp ./rtl8188fu/firmware/rtl8188fufw.bin /lib/firmware/rtlwifi/

sudo depmod -a

sudo mkinitcpio -P

Then create the driver options config file:

echo "options rtl8188fu rtw_power_mgnt=0 rtw_enusbss=0" | sudo tee /etc/modprobe.d/rtl8188fu.conf

Then disable MAC Address Randomization with the following command:

echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf

After creating the new conf file, reboot both your router and your computer.



Edit: added instructions to install on kernel 5.4 after initial installation on kernel 4.19. This step should not be required for most users.



Boot into 4.19, then uninstall kernel 5.4 with:

sudo mhwd-kernel -r linux54

Then reboot into 4.19.

Then do:

sudo pacman-mirrors -f5 & & sudo pacman -Syyu 

Then reboot into kernel 4.19 again.

Once in kernel 4.19 reinstall kernel 5.4

sudo mhwd-kernel -i linux54

This shouldn't be necessary, but do it again anyways.
Install the linux-headers for all installed kernels:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

Then reboot into kernel 5.4 and hopefully your wifi will be working.



3 Likes

Yes, but it is the wrong driver. I have been down this road before. That driver will not work.

1 Like

Connected via the adapter as I reply, I still have a few question-

  1. Why did you suggest installing from source, when 8188fu is available in AUR?
  2. Will I not be able to use other kernels with this adapter?

This is only a 32 bit driver and it will not build on 64 bit systems.

Generally I avoid suggesting building from source unless there is no other alternative. This adapter has no other alternative that I am aware of. Using a driver built from source using DKMS is just as good as using a dkms variant built from the AUR.

It should auto update on kernel updates, but may require the occasional rebuild over time.

You probably can, but I suggested kernel 4.19 just because I wanted to be sure it built correctly. I would install timeshift and make a system backup.

Then install kernel 5.4 and test building it on 5.4.

It may build correctly on 5.6, but I doubt 5.7 will work yet.

Your hardware is older and you do not need the newest kernels, so I just wanted to be sure the driver built correctly on an older compatible kernel for you.

Glad things worked out for you.

2 Likes

I already have 5.4 installed. What do you mean by building it on 5.4. Can't kernel 5.4 access the same files as 4.19?

I wonder why this adapter is older. I just bought it on wish.com. I prefer retail shopping but I was unable to this time (due to corvid). Did wish send me an old and outdated product? Here is it if you are curious.

If it is too old, I can return it in 30 days. That they sent me the wrong driver was already strike 1

Sometimes you get what you pay for on wish. The adapter is an older N model. There is nothing wrong with adapters using N, but then you'd prefer driver kernel support included.

Personally, this would be one of the last adapters I'd buy because of all the extra steps required to get it working. For the cost of shipping it back, it might just be simpler to keep it though (now that you have it working).

If you already have kernel 5.4 installed DKMS may have already built the driver for kernel 5.4. Test out 5.4 to see if it works.

1 Like

I logged in to 5.4. It simply did not recognize the device. However, I noticed something different. Under 5.4.44.1, the corresponding recovery mode and fallback are 5.4.23.1. Aren't the numbers supposed to be exact same? I think I installed 5.4 from manjaro setting manager because it was lts. In grub-customizer, however, it does say in smaller fonts -- default name: Manjaro Linux (kernel 5.4.44.1)

is there anything wrong here?

I would boot into 4.19, then uninstall kernel 5.4 with:

sudo mhwd-kernel -r linux54

Then reboot into 4.19.

Then do:

sudo pacman-mirrors -f5 & & sudo pacman -Syyu 

Then reboot into kernel 4.19 again.

Once in kernel 4.19 reinstall kernel 5.4

sudo mhwd-kernel -i linux54

This shouldn't be necessary, but do it again anyways.
Install the linux-headers for all installed kernels:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

Then reboot into kernel 5.4 and check your wifi out.

You did pay attention to the part a few posts back where I mentioned to install timeshift and do a system backup... right?

That was because I foresaw these kinds of issues getting the driver working on a newer kernel. You want to make sure you don't mess up your working configuration trying to get things going with a newer kernel.



1 Like

Just FYI.

I just noticed this comment about grub customizer. Grub customizer can cause very serious problems. Anyone who is an expert on Grub recommends to never install that utility.

Search the forum about this if you have questions.

@tsunami please double check my kernel installation instructions again as I added another step.

1 Like

Well, now it works on all kernels. Now, I am ready to make a backup. I was gonna do it last night, but it was too late and it looked like it might take more than 21 minutes.

How do I mark two answers as "the solution". The second made it work on all kernels though.

Appreciate it.

The sentiment is appreciated, but that option is not possible with the forum software. You should mark the driver installation as the solution. I will edit in a copy of the kernel installation instructions as well. That way both will be together.

Glad you got everything working.

1 Like

Sorry for posting on a solved thread, but I think all Realtek wifi devices should end in "FU"

Sincerely,
A guy who spent hours configuring RTL8812AU drivers for an RTL8812BU adapter.

Sadly this is becoming all too common on the forum lately. You can not always go by old posts from the past when it comes to installing your wifi driver. Manufacturers often change the wifi chips used in the same model numbers they produce over time.

Therefore, you must search for your specific chip ID in any USB Wifi dongle you have purchased before you install the incorrect driver versions. Even drivers listed on the manufacturers website or install CD does not guarantee that is the correct wifi driver for an Arch Linux based system. Several Realtek adapter's are sold with the wrong driver on the installation media. This help thread is a prime example of how this often happens.

The point being, please make sure you have confirmed the chip ID of your WiFi adapter before making a request for technical assistance on the Manjaro forum. Without doing this in advance you are potentially wasting not only your own time, but that of many forum assistants as well.

There has been a rash of users misidentifying their Realtek adapter models latlely. This can be avoided quite simply by running the lsusb command while your USB Wifi dongle is plugged into your computer. In the lsusb output you should find a line identifying your adapter. There will be an alphanumeric string of four numbers or letters separated by a colon, followed by another four number/letter combination.

In the OP of this threads case the chip ID pertaining to the WiFi was:

The next step to properly identifying the wifi chip in use is to input the chip ID 0bda:f179 into the search engine on a Linux chip identification website such as:

https://wireless.wiki.kernel.org/

Or:

https://wikidevi.wi-cat.ru/Main_Page

Or, simply perform a general internet wide search for terms such as:

Linux wifi driver  0bda:f179

This will hopefully save everybody a lot of wasted time.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by