Installation Issue:Missing bios

Installation was successful, I installed it on my laptop which has windows and ubuntu16, created the /boot/efi partition everything looked fine in the installation, but can't load manjaro in grub bootloader which came with the ubuntu (it listed manjaro thereafter I did update-grub from ubuntu), which is not the problem that I am here for.

the issue is i can't access bios menu by pressing f2 which I was able to access before the installation, and im still able to access once if i remove all the newly added partitions, which are root, swap, and the /boot/efi,but im able to choose bootloader by pressing f12 and when if i choose manjaro bootloader its loading manjaro and ubuntu and windows fine, but again missing bios is the issue.

so the issue has to be with manjaro i3 installation.

faced the same behavior when i tried to install this when only windows was there in my laptop.

totally new to manjaro and thanks for the help.

This is not a Manjaro specific issue but an issue with the EFI firmware.

I remember a recent thread on this. Please search the forum.

Some users have solved it by using efibootmgr to remove and recreate the boot entry.

systemctl reboot --firmware

can you boot on iso USB manjaro
open a terminal and a browser on this topic
and returns

inxi -Fxxxza
sudo parted -l

Thanks for the early reply,

[manjaro@manjaro-i3 ~]$ inxi -Fxxxza
System:    Host: manjaro-i3 Kernel: 5.6.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC driver=free nouveau.modeset=1 
           i915.modeset=1 radeon.modeset=1 misobasedir=manjaro misolabel=MANJARO_I3_2001 quiet systemd.show_status=1 
           apparmor=1 security=apparmor 
           Desktop: i3 4.18.1 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Predator PH315-52 v: V1.02 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: CFL model: Covini_CFS v: V1.02 serial: <filter> UEFI: Insyde v: 1.02 date: 04/15/2019 
Battery:   ID-1: BAT0 charge: 56.4 Wh condition: 56.4/56.4 Wh (100%) volts: 17.5/15.4 model: SMP KT00407009 AP18E7M 
           type: Li-ion serial: <filter> status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: CA L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 802 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:3e9b 
           Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Acer Incorporated ALI driver: nouveau v: kernel 
           bus ID: 01:00.0 chip ID: 10de:2191 
           Display: x11 server: X.Org 1.20.8 driver: intel,modesetting,nouveau alternate: fbdev,nv,vesa 
           resolution: 1920x1080~144Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.6 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: NVIDIA TU116 High Definition Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:1aeb 
           Sound Server: ALSA v: k5.6.11-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] vendor: Bigfoot Networks driver: iwlwifi v: kernel port: 5000 
           bus ID: 00:14.3 chip ID: 8086:a370 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Acer Incorporated ALI driver: alx v: kernel 
           port: 3000 bus ID: 07:00.0 chip ID: 1969:e0b1 
           IF: enp7s0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.15 TiB used: 96.9 MiB (0.0%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN720 SDAPNTW-256G-1014 size: 238.47 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 10121000 scheme: GPT 
           ID-2: /dev/sda vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: ACM1 scheme: GPT 
           ID-3: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade size: 7.26 GiB block size: physical: 512 B 
           logical: 512 B serial: <filter> rev: 1.00 scheme: MBR 
Partition: ID-1: / raw size: N/A size: 11.62 GiB used: 96.9 MiB (0.8%) fs: overlay source: ERR-102 
Sensors:   System Temperatures: cpu: 63.0 C mobo: N/A gpu: nouveau temp: 45 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 366 Uptime: 8m Memory: 15.49 GiB used: 932.3 MiB (5.9%) Init: systemd v: 245 Compilers: gcc: 9.3.0 
           Shell: bash v: 5.0.16 running in: urxvtd inxi: 3.0.37 
[manjaro@manjaro-i3 ~]$ sudo parted -l
Model: ATA ST1000LM049-2GH1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      17.4kB  16.8MB  16.8MB                  Microsoft reserved partition  msftres
 2      16.8MB  78.7GB  78.6GB  ntfs            Basic data partition          msftdata
 3      78.7GB  351GB   273GB   ntfs            Basic data partition          msftdata
 5      351GB   352GB   537MB   fat32                                         msftdata
 7      352GB   356GB   4295MB  linux-swap(v1)                                swap
 6      356GB   394GB   38.1GB  ext4
 4      394GB   1000GB  606GB   ntfs            Basic data partition          msftdata


Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdb: 7799MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2429MB  2434MB  4194kB  primary               esp


Model: WDC PC SN720 SDAPNTW-256G-1014 (nvme)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  106MB  105MB   fat32           EFI system partition          boot, esp
 2      106MB   123MB  16.8MB                  Microsoft reserved partition  msftres
 3      123MB   207GB  207GB   ntfs            Basic data partition          msftdata
 4      207GB   211GB  4096MB  linux-swap(v1)                                swap
 5      211GB   255GB  44.2GB  ext4
 6      255GB   256GB  1074MB  ntfs            Basic data partition          hidden, diag


[manjaro@manjaro-i3 ~]$

thanks for the early reply,
i tried to rearrange the bootmanager oder using efibootmanager -o "neworder" but it didnot work, i mean it still went to the ubuntu bootloader,

and i dont know why u quoted this systemctl reboot --firmware
but with this too im going to the same state of no bios settings which is just a black screen with a curser

can you check in bios

  • secureboot disable
  • fastboot disable
  • csm disable
  • efi on others ( not windows )
  • disks on AHCI
  • legacy disable
  • maybe keep USB mass storage on

boot on USb iso manjaro ( Live )
open a terminal and browser on this topic
and reports

manjaro-chroot -a ( select 1 if only one line appears )
cat /etc/fstab
lsblk -fs
ls /boot/*
ls /boot/efi/*
exit (quit chroot)

saw 2 options there and i mounted manjaro

cat /etc/fstab

/etc/fstab: static file system information.

Use 'blkid' to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=88A9-78DE /boot/efi vfat umask=0077 0 2
UUID=f94403aa-535a-419f-a30b-e7633ad92683 swap swap defaults,noatime 0 2
UUID=aeae8245-c446-4cfe-972a-7a26ac7900a1 / ext4 defaults,noatime 0 1


lsblk -fs

NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
loop0
loop1
loop2
loop3
sda1
-sda sda2 -sda
sda3
-sda sda4 -sda
sda5 510.7M 0% /boot/efi
-sda sda6 26.9G 17% / -sda
sda7
-sda sdb1 -sdb
sdb2
-sdb nvme0n1p1 -nvme0n1
nvme0n1p2
-nvme0n1 nvme0n1p3 -nvme0n1
nvme0n1p4
-nvme0n1 nvme0n1p5 -nvme0n1
nvme0n1p6
`-nvme0n1


ls /boot/*

/boot/initramfs-5.6-x86_64-fallback.img /boot/initramfs-5.6-x86_64.img /boot/intel-ucode.img /boot/linux56-x86_64.kver /boot/vmlinuz-5.6-x86_64

/boot/efi:
'$RECYCLE.BIN' EFI 'System Volume Information'

/boot/grub:
fonts grub.cfg grubenv themes x86_64-efi

/boot/memtest86+:
memtest.bin


ls /boot/efi/*

'/boot/efi/$RECYCLE.BIN':
desktop.ini

/boot/efi/EFI:
Manjaro boot

'/boot/efi/System Volume Information':
IndexerVolumeGuid WPSettings.dat


the problem was that i cant access bios menu,so i cant check all these without removing every partitions related to manjaro, some of these values (secureboot,legacy) were as disabled but not sure,
do i need all these values as given above to work this fine? if so i will remove these manjaro partition innorder to get access to bios and make changes if needed and then install it again.

there is 2 /boot/efi
sda5 ( manjaro) and nvme0n1p1 ( with boot , esp)

that why you cant boot Efi manjaro

I installed Ubuntu on nvme so isn't that /boot/efi is of ununtus , and I installed manjaro on ssd. And if having two /boot/efi is the issue then why did I faced the same issue at the time there is only windows was there in my laptop?

The problem was missing bios by that I mean can't see bios settings. Or what I see is a black screen with a curser.

If I pressed f12 I can choose the bootloader and from that if I choose manajro bootloader , I can boot manajro,

Are we on the same page here? Am I missing something?

flags boot & esp are on nvme0n1p1 not sda5
that why you cant boot by bios :
need flag boot & esp ...

just changed the the flags to boot & esp on sda5 ,
but still its missing, i think i should try official versions,
i will check if official versions too going give me the same issue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by