Installation stuck at 89 % : installing bootloader.

I'm making this topic as new problems appeared in this one : Manjaro live cannot connect through ethernet, stuck in installer at "waiting for modules" and cannot install grub because something cross disk

I'm trying to install manjaro but :

  • I can't connect to ethernet
  • In order to solve that problem, I have to install manjaro offline first, but then the installer is stuck at 89 % : installing bootloader.
    I tried :
  • putting the bootloader in / (stuck at 89%)
  • putting the bootloader in the mbr of the hard drive where I'm installing manjaro (stuck at 89%)
  • putting the bootloader in the mbr of my main hard drive, but then it throws me some error about grub and cross disk installations.

Are you trying to install with proprietary drivers or free?

I would suggest trying the free option (if you chose otherwise) .

1 Like

free drivers

Could you post the output of the following command from your Manjaro live usb:sudo parted -l ?
This will give the forum some idea about your disk set-up.

The seemingly halt during boot loader step may be caused by the installer type.

I don't know exactly where it could go wrong but if I recall correct you have dual-boot system.

To make that work - you need the Manjaro installation to be of the same type as the other installation.

Some vendors preinstall Windows as MBR despite the system being capable of UEFI.

Manjaro prefers UEFI and will boot UEFI if it is available - which it often is because said vendor leaves the firmware in a compatibility mode which checks the boot media and chooses EFI if available MBR if not.

This often results in a hang - I don't know why - I am not sure whether my observations are correct.


So my guess on the other thread was correct - you were installing an MBR system.

You can use GPT with MBR and in doing so you have to create a 1MB partition as the first partition on the device designated as a BIOS boot partition. (type 0xef02).

But my first partition on the device is already windows, and if I understand correctly, if I shift this partition, it would cause tons of writes on my ssd, and I'm not a big fan of that. Is it possible that I switch windows to uefi instead ?

15813368259933016152171524309920

Sorry for not formatting the output, but I have no internet on that pc, so I can't just copy paste the output

This is simply going to be too complicated.

Your best chance of success - and the simplest as I see it now - is to ensure your firmware boots only using efi (disable Legacy/CSM) - if windows is required - reinstall windows in efi mode then install manjaro.

If you system came with Windows 10 don't worry the windows key is safe stored in the firmware.

I'll try doing that without reinstalling windows, I don't want to do a lot of rewrites on my ssd

If you can live with booting each OS from the BIOS boot menu, I guess it is sufficient to convert your Samsung drive to GPT and install Manjaro in UEFI mode. You will have to have CSM mode enabled in this case, I believe. Just back up your data from that NTFS partition before for not loosing it.

image I guess I can't

Modern SSDs doesn't care - I am using SSDs - some of them first generation kingston 120G - 10 years - they still work - no problems.

It is close to a myth that you can wear out your ssd by reinstalling your OS.

Spinning disks are more likely to fail than a SSD.

I have worn out Seagate 2TB - 24-7 disks in my NAS and I have SSDs dating before my NAS which are still going strong.

I have an idea : what if instead of using grub, I add manjaro to my windows bootloader. Is that possible ? I already have multiple windows entries in it, and I already saw other computers dual booting ubuntu like that, so why not manjaro ?

You have tried to many changes - your best shot is starting from scratch - believe me - experience tells me - in this case it is the best.

You have too many issues, but if it is just a case of bootloader installation failure, you can try this [Kernel Boot Method]. If it boots to your OS, you still have the issue od setting mbr to the wrong disk and at the installed Manjaro OS terminal, set mbr to the right disk. but if you are unsure, print out the output as detailed in that link.

Ok thanks, I'll try that

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by