Installation stuck at "Configure the hardware"

Hmm, yeah it looks similar :slight_smile:
Manjaro 17.1.2, downloaded it yesterday
Calamares version: 3.1.12-3

You have exactly the same network chip and the same problem than this post.
Could you please try the workaround of removing the 2 lines?

1 Like

Successfully installed and booted :slight_smile:
Thank you for guiding me through! :hugs:

1 Like

Nice! :smile:

Could you confirm that your network (both WLAN and LAN) works?

Well, kinda :smiley:
Wired is working just fine, but wireless is having trouble with listing available networks.
WLAN does not sees my 5Ghz network and only sometimes lists my 2.4 GHz network (both coming from the same router which is 5 meters away from me), so I'm using USB dongle for now, which is working correctly with my 2.4 GHz network.

This is a driver issue. mhwd is having problem with the BCM43228 chip, i.e. your WiFi chip.
Could you please check if the package broadcom-wl is installed (source)?

@philm Is it an expected issue from mhwd?

Package? You mean via pacman? ^^" Showing both pacman and grep

[wildcat@acer-aspire ~]$ pacman -Qi broadcom-wl
error: package 'broadcom-wl' was not found
[wildcat@acer-aspire ~]$ lspci | grep Broadcom | grep -v Ethernet
02:00.1 SD Host controller: Broadcom Limited BCM57765/57785 SDXC/MMC Card Reader (rev 10)
02:00.2 System peripheral: Broadcom Limited BCM57765/57785 MS Card Reader (rev 10)
02:00.3 System peripheral: Broadcom Limited BCM57765/57785 xD-Picture Card Reader (rev 10)
03:00.0 Network controller: Broadcom Limited BCM43228 802.11a/b/g/n

If you want to use the tested package, it's broadcom-wl-dkms from the extra repository. You can use pacman or pamac if you want a GUI.
If you wish to access the Arch User Repository (AUR), then use yaourt. AUR is user maintained so be careful.

In your case, I recommend:

sudo pacman -S broadcom-wl-dkms
1 Like

Ran the command -> installed -> reboot -> no wireless at all :smiley:
Only via dongle :smiley:
Output:

[wildcat@acer-aspire ~]$ sudo pacman -S broadcom-wl-dkms
[sudo] password for wildcat: 
warning: broadcom-wl-dkms-6.30.223.271-4 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) broadcom-wl-dkms-6.30.223.271-4

Total Installed Size:  7.68 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                            [##########################################] 100%
(1/1) checking package integrity                                          [##########################################] 100%
(1/1) loading package files                                               [##########################################] 100%
(1/1) checking for file conflicts                                         [##########################################] 100%
(1/1) checking available disk space                                       [##########################################] 100%
:: Running pre-transaction hooks...
(1/1) Remove DKMS modules
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_MEASUREMENT = "lt_LT.UTF-8",
        LC_PAPER = "en_US.UTF-8",
        LC_MONETARY = "lt_LT.UTF-8",
        LC_NAME = "en_US.UTF-8",
        LC_ADDRESS = "en_US.UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LC_TELEPHONE = "en_US.UTF-8",
        LC_IDENTIFICATION = "en_US.UTF-8",
        LC_TIME = "en_GB.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
==> No kernel 4.14.14-1-MANJARO headers. You must install them to use DKMS!
:: Processing package changes...
(1/1) reinstalling broadcom-wl-dkms                                       [##########################################] 100%

To load the new module, run as root:

  rmmod b43 b43legacy ssb bcm43xx brcm80211 brcmfmac brcmsmac bcma wl
  modprobe wl

or just reboot the system.

:: Running post-transaction hooks...
(1/2) Install DKMS modules
==> No kernel 4.14.14-1-MANJARO headers. You must install them to use DKMS!
(2/2) Arming ConditionNeedsUpdate...
[wildcat@acer-aspire ~]$ sudo rmmod b43 b43legacy ssb bcm43xx brcm80211 brcmfmac brcmsmac bcma wl
rmmod: ERROR: Module b43 is not currently loaded
rmmod: ERROR: Module b43legacy is not currently loaded
rmmod: ERROR: Module ssb is not currently loaded
rmmod: ERROR: Module bcm43xx is not currently loaded
rmmod: ERROR: Module brcm80211 is not currently loaded
rmmod: ERROR: Module brcmfmac is not currently loaded
rmmod: ERROR: Module brcmsmac is not currently loaded
rmmod: ERROR: Module bcma is not currently loaded
rmmod: ERROR: Module wl is not currently loaded
[wildcat@acer-aspire ~]$   modprobe wl
modprobe: FATAL: Module wl not found in directory /lib/modules/4.14.14-1-MANJARO

From what I see, I just need to update, haven't done it yet :slight_smile:
I Need to go now, so I will post results later (~tomorrow, I guess)
Thank you for your help!!

1 Like

Your LOCALES setting is pretty important...

2 Likes

Install linux headers:

sudo pacman -S linux-api-headers

it installed
Name : linux-api-headers
Version : 4.14.8-1

soo error for
sudo pacman -S broadcom-wl-dkms
left the same as before

Weird...

Have you tried to set you local settings (e.g. using manjaro-setting-manager) as @c00ter suggests?

Not really, only Numeric, Currency and Time Formats for clock :slight_smile:
Soo, I need to set it to my country, yep? Currently everything's set up for US (I just used to English, so I left as is during installation), although I live in Lithuania ^^""
I'll set everything up when I'll get back home :slight_smile:

You can keep using English, just ensure that everything is set and that the language packages are installed :slight_smile: .

1 Like

Locales are set (I guess :D) and language packs installed!
However, that does not changed the situation with WLAN, still same error ^^""

Good :slight_smile:.

Try removing broadcom-wl-dkms and installing linux414-broadcom-wl in place. Then reboot.

Better, I can see my networks, both 2.4 and 5GHz, but when I try to connect this is what happening:

  1. I select my network
  2. enter password
  3. "Confuguring interface"
  4. Asks for password in "Wi-Fi password dialog"
  5. Entering password
  6. Repeat step 3 :smiley:
1 Like

Sounds better! :smile: At least you see the networks now so the driver is working. Just keep in mind that you must install the package that machtes your kernel, so if you change kernel, install the corresponding package linux[kernel_number]-broadcom-wl.

The problem you run into now seems to be linked to you network manager. Please check the authentication method (should be WPA2). What DE are you running?

DE-Desktop Environment? KDE.
Yep, authentication method is WPA2

Forum kindly sponsored by