Installation stuck at "Configure the hardware"

Your LOCALES setting is pretty important...


Install linux headers:

sudo pacman -S linux-api-headers

it installed
Name : linux-api-headers
Version : 4.14.8-1

soo error for
sudo pacman -S broadcom-wl-dkms
left the same as before


Have you tried to set you local settings (e.g. using manjaro-setting-manager) as @c00ter suggests?

Not really, only Numeric, Currency and Time Formats for clock :slight_smile:
Soo, I need to set it to my country, yep? Currently everything's set up for US (I just used to English, so I left as is during installation), although I live in Lithuania ^^""
I'll set everything up when I'll get back home :slight_smile:

You can keep using English, just ensure that everything is set and that the language packages are installed :slight_smile: .

1 Like

Locales are set (I guess :D) and language packs installed!
However, that does not changed the situation with WLAN, still same error ^^""

Good :slight_smile:.

Try removing broadcom-wl-dkms and installing linux414-broadcom-wl in place. Then reboot.

Better, I can see my networks, both 2.4 and 5GHz, but when I try to connect this is what happening:

  1. I select my network
  2. enter password
  3. "Confuguring interface"
  4. Asks for password in "Wi-Fi password dialog"
  5. Entering password
  6. Repeat step 3 :smiley:
1 Like

Sounds better! :smile: At least you see the networks now so the driver is working. Just keep in mind that you must install the package that machtes your kernel, so if you change kernel, install the corresponding package linux[kernel_number]-broadcom-wl.

The problem you run into now seems to be linked to you network manager. Please check the authentication method (should be WPA2). What DE are you running?

DE-Desktop Environment? KDE.
Yep, authentication method is WPA2


Please check that your network SSID (= name) appears in the output of:

sudo ls /etc/NetworkManager/system-connections/

Yep, it lists 3 networks I tried to connect to
suddenly it connected to my 5 GHz network :smiley: I did nothing and was AFK, went back, awoke laptop from sleep and there is my Wi-FI :slight_smile:

UPD: 2.4GHz still stuck in the loop, but 5GHZ sometimes manages to connect, bust still getting stuck in a loop most of the time

UPD UPD: Situation: Loop. When it prompts me for password I press cancel and it automatically connects to 5GHz network. That's how it connected to the network. Hmm :open_mouth:

Just delete the 2.4 GHz network and recreate it...or not :wink:.

That didn't helped :smiley:
Manual connection still stucks in a loop, constantly asking me for password, but automatic is working. Weird :smiley:

I don't understand. Normally, you configure your connection once and then you just wait that the NetworkManager automatically connects. If when rebooting, your machine is able to connect to your WiFi without you, then it's fixed :slight_smile:.

NB: This has nothing to do with Manjaro installation but with KDE Plasma, which I don't use. You should consider searching for KDE network manager issues and starting a new thread if you don't find anything.

1 Like

I just don't normally use laptop at home a lot, I have a PC for that :slight_smile: I mostly use laptop at work, university or when traveling, so I am connecting to unknown networks quite often ;D
But nevertheless, it's working and it's time to configure and install software I need.
I've already found a lot of info about this bug and I'll deal with it later.
Sincerely Thank You for Your help, I really appreciate it :slight_smile:

1 Like

Have you updated your computer since Installing Manjaro, now that you are connected?

Yep, everything is up ta date :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by