Installation stuck at Grub installation on MacOS Catalina


I'm wanting to dual boot Mankato Linux on my MacBook Pro. But whenever I want to install it it get stuck at the job: Bootloader: grub (efi).

Any ideas?

1 Like

Install Manjaro instead :wink:!

ps. joking aside, please be a little more verbose about your system. To begin with:

What MacBook Pro? 2012 or 2019?

If your system is so new it can run Cataline - you will have a hard time getting Manjaro working - and even if you manage to somehow get it booted - it is not NooB task - it is a complicated process with lots of setbacks.

I tried once - twice with my MacBook 2017 - my unsolicited advice is - keep the OS that works

I run a Manjaro LXDE on my macBook using VirtualBox - but VMware Fusion may work as well.

I have a MacBook Pro 15 inch from 2019.
And I did get Manjaro to boot via USB but I just let the installer run through the night but to no avail.

Can I find a guide or thread on how to get it to work on my configuration. I could also dual boot windows but I only have limited storage on my device.

May ask you why do you want to use linux on Apples HW? For the same money you could have Lenovo with better spec. I am just curious.

Did you read my comment :point_up: - use the Arch Wiki - but I can say that - I am 99% sure you will not succeed.

First paragraph on the Arch Wiki

Warning: This does not apply to more recent macbooks. These are very poorly supported. See here for more information.

You will end up with a lot of pain, headaches and grief and you will not have a functional system - do yourself a favor - keep macOS - throw away the idea of installing Manjaro on such system (unless you virtualize Manjaro using VirtualBox).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by