Installation stuck on [Started TLP system startup/shutdown] on Raspberry Pi 3 b+

Hi, y'all. I'm trying to install manjaro arm on my raspberry pi 3 b+ but I'm encountering an issue. It would get stuck on startups. Right now it is stuck on "Started TLP system startup/shutdown." Couple of days ago it was "Started Network Manager Script Dispatcher Service."

I'm able to create my profile and all that but it gets stuck after it reboots. It never boots to the desktop.

I've tried buying a different SD card. My first attempt and several after that was on a Kingston 64gb, currently, I'm using a Sandisk 32gb and have tried twice on it.

I've also tried to redownload the image to make sure it wasn't a corrupted image. I use the "RASPBERRY PI 3 LXQT." I'll also list my process of flashing the image just in case that was the problem.

  1. Extract the .img
  2. Used SD card Formatter from
  3. Used balenaEtcher to flash SD card

Raspbian and OSMC work fine on it but Manjaro is the only one I've been having some trouble with. Please help. Thank you.


Your problem might be related to this...

I've connected to the internet and tried sudo pacman-mirrors -f 5 && sudo pacman -Syyubut it's giving me the error unable to unit server: could not connect: connection refused

I've tried `sudo pacman-mirrors -g' and it can't connect.

I have a feeling it's my DNS that's having an issue because I can't ping Says "Name or service not known" know anyway to fix that?

Can you ping IP addresses?

Yeah, I can ping ip addresses just fine. I just went away and don't have my pi with me. I'll try to solve it once I get home.

1 Like

We have had mixed results with the rpi3b+. Some have it working, others don't.

The display problem could be because of a missing driver. Some components are different in the 3b and 3b+.

Regarding the internet issue, you can disable systemd-resolved and see if that fixes it.

sudo systemctl disable systemd-resolved

and then reboot.
When you have internet, try updating your system and reboot again. Maybe some firmware update fixed it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by