installed grub-vanilla now system won't boot

I installed grub vanilla as I am not a fan of silent boot. Upon restarting the system fails to boot. I get the following message.

Mount: /new_root: can't find UUID=(long number)
You are now being dropped to an emergency shell.
Sh: can't access tty; job control turned off

I also have mint Installed on this same drive in another partition.

Have you recreated configuration before reboot?
If not, you should chroot to your installation (or manually boot via grub prompt) and run update-grub.

1 Like

No, I didn't. I tried using the guide you provided but am getting the same results. After getting to grub menu I hit c and followed the guide trying to boot directly to kernal, but after waiting twice for for /Dec/disk/by-uuid
I get the same error.

Is it possible that it is because the partition is encrypted? I didn't think this would be an issue since the password is entered previous to getting to grub menu.

Yes. You will need to load relevant grub modules at grub prompt.
Search the forum for such case (encrypted disk manual grub boot).
Or find how to chroot to encrypted system (using LiveISO).

1 Like

Thank you. Okay, I am chroot in using this guide How to chroot into an encrypted root partition and ran update-grub. Is there any output I can post here that would help further troubleshooting if this doesn't work?

sudo update-grub
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.3-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.3-x86_64.img
Found initrd fallback image: /boot/initramfs-5.3-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.2-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.2-x86_64.img
Found initrd fallback image: /boot/initramfs-5.2-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
Found Linux Mint 19.2 Tina (19.2) on /dev/sda2
done

Let's be positive!
It's so easy to chroot and try other things! :laughing:

Post results. :wink:

1 Like

I'm feeling less positive...same error. I feel like grub isn't using vanilla grub as the boot is still silent showing the HP logo instead of boot logs.

Install grub again (not update).

sudo grub-install /dev/sda (or other drive)
1 Like

My three partitions are

├─sda1 vfat C3B7-FB23 /boot/efi
├─sda2 ext4 7f6e1f9e-f607-4c96-8aa0-c6c6b0e9052a /
└─sda3 crypto_LUKS d0c8c5bc-d105-45df-a63a-203fede76bfe

Do I need to be specific about which partition or is just /dev/sda okay?

Yes. IIRC on UEFI installations you don't even need to specify a drive at all. Try without a drive first.

1 Like

I got the following

grub-install: error: attempt to install to encrypted disk without cryptodisk enabled. Set `GRUB_ENABLE_CRYPTODISK=y' in file `/etc/default/grub'.

Do what it says.
Also review and merge your old settings for grub (run sudo pacdiff)

1 Like

After running " Set GRUB_ENABLE_CRYPTODISK=y' in file /etc/default/grub'" should I still install grub or just run sudo pacdiff?

Please, invest some time reading the basics.
https://wiki.archlinux.org/index.php/Pacman/Pacnew_and_Pacsave
https://wiki.archlinux.org/index.php/GRUB

This may mean you might have destroyed your grub configuration, or not.
I can't take responsibility of destroying your system.
But you can do it yourself :stuck_out_tongue_winking_eye:

1 Like

Lol. Its okay. This isn't my main system so worse case if it gets destroyed I can reinstall, but thought this would be a good learning chance. I'll read what you posted.

*Was able to install grub-install.

1 Like

Any other ideas? Still unable to login after grub-install.

So I ended up reinstalling as I couldn't get grub to work. Is there an easy work around to undo silent boot?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by