Installed Manjaro in VirtualBox with guest additions, no fullscreen.

Trying several things, don't see specific instructions.

To make the guest window full-screen, press Host+F while the guest window has the focus. Ordinarily, your Host key is the right Ctrl key.

Telling us that you have tried "several things" is not very helpful to us. Without knowing what you have tried specifically, we're likely to tell you to do again what you have already tried.

Opened terminal as root: " sh VBoxLinuxAdditions.run" got error "This system is currently not set up to build kernel modules.
Please install the Linux kernel "header" files matching the current kernel for adding new hardware support to the system.

switched to the LTS kernel, no change.
Went to System/Add/Remove Software searched for header. nothing

Copied this from the wiki and tried to run in terminal regular and as root. 'pamac install virtualbox $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]"
did not work

Maybe drop the insouciant aggression & calm down a bit?

You quoted THE key message yourself. You have to have the header files installed, in the VMs. If you say you can't find them then you're simply not searching correctly.

You see in my picture they're not installed for me, coz this is in my real system. In contrast, in ALL my dozens of VMs, i do have the applicable headers installed for the relevant kernels, & so my GA works fine in them.

1 Like

Sounds as if the kernel headers need to be installed. You need to know which kernel you are using, for example type in a terminal:

uname -r

If you use for example kernel 4.19, you need to install the headers for 4.19:

sudo pacman -S linux419-headers

1 Like

Ensure your VM has VBoxSVGA graphics controller.

https://wiki.manjaro.org/index.php?title=VirtualBox#Running_Manjaro_under_VirtualBox

You just need to install virtualbox-guest-iso from repos. Not run any command script.
Better RTFM, I didn't and see what happened!... :face_with_head_bandage:

Manjaro in virtualbox does not need installation from the Guest Additions ISO.

Everything is available in the repo or provided by kernel.

If you set the VM graphics correct (VBoxSVGA) - the only extra thing you need to do in the Manajro Guest is installing the guest modules and that package only provides the shared folder module.

sudo pacman -Syu $KERNEL-virtualbox-guest-modules

Add you user to vboxsf group after installation of guest module

Start the vboxservice

sudo systemctl enable --now vboxservice.service

I don't even know what insouciant means. I was calm. I had just spent over an hour googling and found nothing that works. On other distros it is done differently. Host plus F does not work. Big screen with a little box in the center.
Went to System/Add/Remove Software searched for header. nothing Opened Add/Remove software typed header..Search. did not look like the one in the picture.
Zoid Thanks I will try your suggestion when I get home. I switched to the LTS kernel, will have to run the uname -r to find the number.
linux-aarhus Thanks
Ensure your VM has VBoxSVGA graphics controller.
Add you user to vboxsf group after installation of guest module? More googling.
I used Manjaro a few years ago, but gave up, determined to get it going now. Have zero chance with Arch. Favorite thing about Manjaro is not using the terminal. Graphical package manner and updater.

I am sorry @AgentS but this is plain wrong.

The guest iso is installed on the host - and inserted into the guest using the devices menu in the guest window.

But that is only used for Ubuntu or Windows guests - never Manjaro or Arch as those has packages in the repo.


That command is truncated - it is not complete.


I can't figure out if you are running Manjaro as host - as guest or both.

Because installation is a little different for the host and the guest as different modules are needed.


Host+F - no problem

I have just tested the host keys combo - it works - it takes a few seconds for the VM to adapt - but it works.


No need to use google - just the forum search

There is no reason. I was obviously not thinking. I will delete/repair.
Thanks for watching out!

Next time, when asking for help, please let people know exactly what you have done, and what the exact issues are within the body of your post. Without that information, we cannot help you.

According to the wiki, this should have been:

pamac install virtualbox $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-virtualbox-host-modules"}' ORS=' ') 

Though personally, I suggest installing it without using that. As the wiki tells you what you need to install:

To install VirtualBox, you need to install the packages virtualbox and linux*-virtualbox-host-modules . The latter must match the version of the kernel you are running.

sudo pacman -Syu virtualbox linux52-virtualbox-host-modules

Replace the 2nd one with whatever your kernel is.

And you need to install headers for your kernel, just like what your message says. Look for the one that matches your kernel. If you're using Kernel 5.2, you need linux52-headers.


As @linux-aarhus has indicated, we have a whole thread on how to install Virtualbox. It is best to search within our forums for help. Though Manjaro Wiki & Arch Wiki are also amazing resources as well.

I am running Windows 10 with Manjaro as a guest in VirtualBox. I have never had to change anything in the settings before. Just select the ISO and make a 20 Gig vdi for hard disk. Deleted everything and am trying again with the VBoxSVGA graphics controller. The default graphic controller picked by VirtualBox was the problem. Did not enable 3D, Seems to be working fine now. Full screen without using guest additions. Thanks

Ah yes, a self-solve. My but don't we simply luuuuuuuurve them here...

1 Like

"Next time, when asking for help, please let people know exactly what you have done, and what the exact issues are within the body of your post. Without that information, we cannot help you."
of course that is correct. I did not intend to ask for help. I figured with time and Google I could figure it out myself. Therefore I did not document each step. At first I was afraid to ask here. I expected to be called names and be told to Read The .......
Thanks to those of you who were polite. In the past, I did my testing on real hardware instead of virtualbox.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by