Installed Manjaro XFCE over Kubuntu on a laptop with Win10 dual boot and now I can't see Win10 anymore

So I was dual booting Windows 10 with Kubuntu, I then decided to install Manjaro. Flashed it on a USB thumb drive with the dd command but it wasn't booting up. On a forum I saw someone recommend to change BIOS boot to Legacy instead of UEFI to boot into the USB, and that worked. So I installed Manjaro over the Kubuntu partition and it worked without any problems.

Today I turned on my laptop to only find out that it boots straight into Manjaro. Changed BIOS boot mode to UEFI, and it straight up boots into the Grub command menu. Can't do anything else there.

I can only boot into Manjaro by changing BIOS to Legacy mode.

If you can't make it out already I am a noob and pretty new to this, so if someone can help me restore grub with the option to boot into Win10 or Manjaro while using the UEFI boot, that'd would be really appreciated. Thank you very much.

Win 10 probably need UEFI to boot.
What surprises me is the Manjaro installer, all the times I have installed it it automatically detects UEFI and runs with that.

What program did you use to make the USB?
My recommendation is to use Rufus in W10, I gave had bad luck with all Linux iso tools I have tried. DD mode is correct.

Also, did you check the checksum when you downloaded?

Refer this topic, first post..

  1. Take the manjaro livecd and start it up in uefi.
  2. Do not boot up to live OS, but press ‘c’ at the menu and we’ll get to the grub prompt (grub>).
  3. To be sure you've started up livecd in uefi, at grub prompt, check output of
grub> echo $grub_platform

If output is pc , you've booted up in bios-legacy.
If output is efi , you've booted up in uefi.
If you're in bios-legacy, restart livecd in uefi.

  1. Continue only when you're sure you're in uefi
    and I assume you do not have a separate /boot partition; if you do have a separate partition, get back to us and tell us.
grub> search.file /etc/manjaro-release  root
grub> configfile /boot/grub/grub.cfg
grub> boot

  1. When booted, provide from Manjaro terminal
sudo parted -l
sudo blkid
cat /etc/fstab
efibootmgr -v

After you get back to us, we'll fix it for you.

ps: make sure you have 'secure boot' turned off. If unsure, read the wiki.
You were lucky that your installation of kubuntu was started in uefi mode.

1 Like

My Manjaro USB was unable to boot with UEFI. It just kept showing GRUB menu (from the Win10/Kubuntu dual boot setup).

I did actually use Rufus in W10 first. Apparently the newest Rufus version does not have the option to select between ISO or DD mode, it does it automatically for you. Anyway, it didn't boot of course, like I said only the GRUB was showing up.

At first I thought it was a Rufus problem so I flashed the USB with this terminal command mentioned in the Manjaro wiki itself:

sudo dd bs=4M if=/path/to/manjaro.iso of=/dev/sd[drive letter] status=progress oflag=sync

Even this didn't make the USB boot directly. Did some rough Googling and someone somewhere suggested to change to Legacy mode. And that worked, as mentioned in the post.

I guess both Rufus and the dd command did their own jobs, but the problem is the UEFI or my setup.

I am literally typing this message on my Manjaro install, so I doubt it had much to do with the checksum since the system's working perfectly. I still wanted to check it but I think I had the ISO downloaded in the Kubuntu partition which is now the Manjaro partition so it has been deleted :frowning: I know, very stupid move.

If that is the case, you will not be able to install Manjaro, not least be able to boot it up after the installation, be in in bios-legacy.

1 Like

I do not understand your message. I flashed the Manjaro ISO on my USB, and installed it by changing my BIOS to legacy mode. (like mentioned in the post). I do not have the ISO image anymore, but I do have the Manjaro USB still. I also have Manjaro installed and running on my laptop but it only boots if I keep my BIOS to Legacy. Hope it clears the confusion.

Okay, now since you can boot manjaro (in bios-legacy), at terminal

sudo parted -l
sudo blkid
cat /etc/fstab
test -d /sys/firmware/efi && echo UEFI || echo BIOS

And since you can also boot Windows,, boot up to windows and let us know if it is in uefi or bios-legacy. Use this link to help you find out.
Note: Windows 10 can be installed in either uefi or bios-legacy.

1 Like

Nooo you see, that's the problem! I cannot boot into Windows anymore, even if I change to UEFI mode.

I can only boot into Manjaro by changing BIOS to Legacy mode.

.

Changed BIOS boot mode to UEFI, and it straight up boots into the Grub command menu. Can't do anything else there.

And Windows 10 was initially in UEFI (along with Kubuntu).

Okay, I'll take what you can give, and note please, I'm trying to help you. Not to give you problems.

Now boot into Manjaro and...

Unless you tell us you cannot boot into anything.

2 Likes

I suppose you can still go to UEFI/BIOS setup or Quick Boot menu and see if the LiveISO is recognised and have a boot option that includes the word UEFI.
You can't install Manjaro in UEFI, if you don't boot the installer in UEFI.

I am really grateful and thankful for your help. I used those commands in the terminal and here's what I got:

Model: ATA ST1000LM024 HN-M (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size   File system  Name  Flags
 1      1049kB  525MB   524MB  fat32              boot, esp
 2      525MB   161GB   161GB  ntfs               msftdata
 3      161GB   900GB   738GB  ntfs               msftdata
 4      900GB   1000GB  100GB  ext4
sudo blkid
/dev/sda1: UUID="9033-B2A1" TYPE="vfat" PARTUUID="3f2b1d47-ddb8-11e9-9688-ef54bfb8708b"
/dev/sda2: UUID="9E9CEFB59CEF865D" TYPE="ntfs" PARTUUID="3f2b1d48-ddb8-11e9-9688-ef54bfb8708b"
/dev/sda3: LABEL="im stuff" UUID="200C7C030C7BD1F0" TYPE="ntfs" PARTUUID="3f2b1d49-ddb8-11e9-9688-ef54bfb8708b"
/dev/sda4: UUID="6ba49d12-9d25-45d7-a5fd-af8663bd1631" TYPE="ext4" PARTUUID="38b481cd-d245-44f2-8761-4a70fd1e5626"
cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=6ba49d12-9d25-45d7-a5fd-af8663bd1631 /              ext4    defaults,noatime 0 1
test -d /sys/firmware/efi && echo UEFI || echo BIOS
BIOS

Right, we can fix it. But you must make sure your system can be started or booted in uefi.
If you cannot do that, the solution won't work and make it more problematic.
You said....

Now first make sure your bios can be set to boot in uefi mode.
Go to bios set up, usually F2, and go the the boot section.
See if you can make the make the system boot in uefi.
If that is set to only bios-legacy, you need to change that to boot in uefi.

I am almost sure your system can boot in uefi as your windows is most definitely in uefi (gpt and efi partition) - that's why you cannot boot windows now since the bios is set to bios-legacy.

After able to set your boot to uefi, boot up manjaro OS and ...

  1. add one entry of /boot/efi to your /etc/fstab and it will look like this.
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=9033-B2A1                      /boot/efi      vfat    defaults,noatime 0       0
UUID=6d67915e-8add-41ec-a47b-18a574659b8a swap           swap    defaults,noatime 0 0
UUID=2b259af0-f5c5-4b3d-a2f6-19f1d83ee208 /              ext4    defaults,noatime 0 1
  1. At Manjaro terminal, do
sudo mkdir /boot/efi
sudo mount /dev/sda1 /boot/efi
sudo pacman -S efibootmgr, efivar and dosfstools
sudo grub-install  --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --boot-directory=/boot  --recheck --debug
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

Reboot.

ps: one or more of the packages efibootmgr, efivar and dosfstools may already be installed. Make sure the rest are installed.
If any error message, print these out and let us see.

1 Like

I am really sorry for the late reply. So I changed my BIOS to boot in UEFI, and it booted straight into Windows 10!
IMG_20190929_145933%5B1%5D

So I got this step right all thanks to you. Now I don't understand this part:

Am I to insert the Manjaro USB and boot into the installer or something? I am sorry I do not understand anything after that. :frowning: The only way I can otherwise boot into my installed Manjaro is by setting BIOS boot mode to Legacy.

Yes. Then from the grub menu (don't boot to Live Installer), select "Detect EFI bootloaders" option, which hopefully will show your installed Manjaro as an option, so you boot on that.
If not Detected, then boot to the installer and chroot in your installed Manjaro, using manjaro-chroot.

Anyway, I would suggest you first post your findings before following blindly @gohlip 's instructions, in case something was not as assumed.
Mainly interested on these (from inside chroot). Post output:

findmnt -s
cat /etc/fstab
lsblk -f
efibootmgr -v
  1. If you can boot up install media in UEFI, do it. And tell us if you can or cannot, whatever tell us.
  2. If you cannot, from that screen shot, if you choose ubuntu instead, can you get to a grub prompt?
    Shown like " grub> "?
  3. And did you do the commands in post #12 ? While booted up in manjaro in bios-legacy?
    Where are the output and input of the commands?
    Any error messages? Print them.
  4. What is your computer make and model?

ps: you most likely cannot do AgentS method as
You don't have manjaro installed in uefi, so you don't have manjaro efi bootloader to boot.

Cannot use chroot either? (suggested as well). Inform me so I won't suggest again :man_shrugging::disappointed_relieved:

Sheesh, what happen to you?

Isn't this clear enough? Of course you can suggest and help.
If I'm wrong, I'd be happy if someone points that out to me.
And thank them as well.

Are you ever?

Come on, this is a lie... :stuck_out_tongue_closed_eyes:

It was assumed it was not UEFI installed, but it could be a boot order or other UEFI-related overwrite. That was my thought.
Sorry for the noise...

You mean I haven't been wrong?
I've been wrong about being wrong before?
Thanks, I'm happy you pointed this out to me.

Now, what's this lie you're talking about?

:crazy_face:

ps:
see his fstab somewhere above. there's no /boot/efi entry, just /
how would he get a grubx64.efi to boot from 'detect efi bootloader'?

1 Like

Oohh... That was what I was missing... :disappointed_relieved:.
Sorry Yoda Master!! :innocent:

1 Like

Forum kindly sponsored by