Installing anbox

I tried installing anbox from the AUR in order to run Android apps on my computer.
Therefore, I executed the following commands:

$ yay -S anbox-git
$ yay -S anbox-modules-dkms-git
$ anbox -version

Although the installation seemingly worked well, the anbox executable is not found.

bash: anbox: command not found

I hava no clue why. I also already reinstalled anbox completely, still with no success.

Therefore, I searched for the term "anbox" on my whole drive, and indeed there is no file in "/usr/bin/" or any of the other places where executable files are usually to be found. The only locations where anything was found were:

$ sudo find / -name "*anbox*"

Am I doing something completely wrong? Should there probably not even be an executable in "/usr/bin" as usually? And if so, how else should I run anbox?

have you tried anbox-git in terminal?

Is it a program which you need to start before you can use Android programs, or is it like Wine which will be started when you start a Windows program?
I don't know the program so I am just asking.

If you open the package file that yay created you should be able to see exactly where the files are placed on your system.

If the package is empty that's possibly a bug with the PKGBUILD file e.g. due to an upstream change.

Do you know whether this is a/the correct command? If not, it's probably better to do a little research before posting "unknown" commands for a newbie to try (as most newbies will happily copy and paste whatever command they're given).

For example, if you look at the anbox-git PKGBUILD file you can check the package() section to see how it is configured.

In this case, it's being installed to $pkgdir, but the software's make install might place the files in /usr/bin or /usr/local/bin (or something else entirely, e.g. /opt) depending on what they feel like.

According to the PKGBUILD it has placed a .desktop file, so it should show up in the menu, @Galveston01.

@loontmike Not working either
@jonathon I'm relatively sure, but I wouldn't go to the stake for it.
@Strit The menu is where I looked first of course. Problem is that I can't find "anbox" there because there is no anbox.desktop in "/usr/share/applications", although the PKGBUILD states there should be.
That's why I posted the list of files on my drive that are named sth like anbox. As you can see, there is no entry for an anbox.desktop anywhere on the system.
It seems to me that not anywhere near all files of the package were installed. Probably I should try purging it completely and reinstalling it once again.

Please post the output of yay -S anbox-git

Maybe go back to the AUR and verify that it was in fact installed? Maybe only the modules were installed?

@jonathon I think it wasn't installed correctly because pacman wasn't able to uninstall it.

I don't know what has went wrong. I just ended up just installing it using snap rather than the AUR package as described here

1 Like

Finally got everything working. Here is a description of what I did:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by