Installing nvidia and intel driver problem

Thanks I really appreciate your help

1 Like

Now the first problem appears again . The screen is all black the login screen won't appear. I have changed nothing i just restart to switch to intel

there is a FAQ/Troubleshooting section on the wiki i linked about that.

ALSO: did you select the correct kernel specific bbswitch when you pamac install optimus-manager???
check:
pacman -Qs bbswitch
if you dont see local/linux419-bbswitch 0.8-7 (linux419-extramodules)
if its not the linux419 version:
sudo pacman -S linux419-bbswitch
and try try again.

I installed it from tty2 but it didn't change anything

was the wrong one installed? if so uninstall it
sudo pacman -Rd linux414-bbswitch
edit to remove the one that does not belong since i dont know which one you installed by mistake. then follow the FAQ on wiki and search forum posts for optimus-manager related issues that fit if your unable to fix it with suggestions in FAQ's
also set the default card like i showed you above to either intel or nvidia and see which is having trouble booting, from the sound of it, the intel is having trouble so set nvidia for now and follow given solution to this is FAQ.

I find out that i can boot with nvidia with wrong resolution.but i can't switch back to intel

I did this part and it solved both of my problem
make sure you do not have any configuration file conflicting with the ones autogenerated by optimus-manager. In particular, remove everything related to displays or GPUs in /etc/X11/xorg.conf,/etc/X11/xorg.conf.d/and also in/etc/X11/mhwd.d/. Avoid runningnvidia-xconfig or using the *Save to X Configuration file* in the Nvidia control panel. If you need to apply specific options to your Xorg config, see the [Optimus_Manager#Configuration](https://wiki.manjaro.org/index.php?title=Optimus_Manager#Configuration).
Again thank you @dglt

1 Like

glad you got it working, im currently unable to get nvidia to work properly with optimus-manager . i'm very happy with PRIME, i just wanted to see how it works (less than enthused), but my optimus laptop has always been more difficult to make work. bumblebee is an absolute no no on this lappy, not that i would want it anyway.
so both nvidia and intel are working properly? switching working well?

Everything works great i can easily switch graphics and no black screen and wrong resolution.but there is one minor problem when i run screenfetch command on intel gpu it says the gpu is unknown.
but i don't have this problem on nvidia gpu.

screenfetch


 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     meshikhah@pipboy
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     OS: Manjaro 18.0 Illyria
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Kernel: x86_64 Linux 4.19.8-2-MANJARO
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Uptime: 3h 34m
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ            β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Packages: 1224
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Shell: zsh 5.6.2
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Resolution: 1920x1080
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     DE: Cinnamon 4.0.5
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     WM: Muffin
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     WM Theme: Mint-Y-Dark-Blue (Mint-Y-Dark)
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     GTK Theme: Mint-Y-Dark-Blue [GTK2/3]
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Icon Theme: Papirus-Dark
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Font: Cantarell 10
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     CPU: Intel Core i7-7500U @ 4x 3.5GHz [50.0Β°C]
                                  GPU: Unknown
                                  RAM: 1931MiB / 11891MiB

i have no idea and im already back to using the PRIME setup but my suggestion would be to search for optimus-manager related behavior both here and from outside sources google/ddg. i believe solus,ubuntu and maybe some others as well have their own equivalent to optimus-manager so reading through posts/wiki's related to those may tell you what you want to know.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by