installing nvidia-utils breaks dependency nvidia-utils required by 4xx-nvidia

Got this while updating in Pamac.

Read it might be a kernel thing. I'm on 4.20, which is unsupported (while 4.19 is "recommended" somehow). Downgrading would wound my pride, so I tried installing the 5.1 kernel. Again, I'm told, this time in the kernel GUI,

:: installing nvidia-utils (1:430.26-1) breaks dependency 'nvidia-utils=1:430.14' required by linux414-nvidia

:: installing nvidia-utils (1:430.26-1) breaks dependency 'nvidia-utils=1:430.14' required by linux419-nvidia

:: installing nvidia-utils (1:430.26-1) breaks dependency 'nvidia-utils=1:430.14' required by linux420-nvidia

error: failed to prepare transaction (could not satisfy dependencies)

What do?

Rumors say this is one of those things that benefits from waiting. It's some mix-up, they assure, in the inscrutable, alien othernesses that deliver updates and packages down to us. Give it a while and the packages will rearrange themselves into alignment, with no dependency collisions.

Read the effing update announcements thread, fer chrissake. Does nobody do that lately?

Do I have to get my ruler back out and start spanking hands again? :smiley: :smiley: :smiley:

What day is it? Somebody gimme a cheeseburger.

1 Like

boot with 4.19 or 5.10, after remove 414 and 420

mhwd -r linuxXXX

A thousand apologies!

I'm assuming you mean this thread, where someone brought up the same issue.

(By the way, as an excuse, I find this forum hard to navigate. Too Web 2.0ish. Have you heard of Beeminder? They use the same forum software, with the same exact bots that pitch you tutorials or achivements for doing things. It's adorable, but insofar as traditional fora are still a viable social medium, I think they benefit from the rich, HTML-brutalist interfaces of yore. And I say this as someone who was too young to be able to use traditional forums back when they were traditional. But I'm also pretty stupid.)

Via aforementioned thread, I managed to solve the issue! I posted the solution there and reiterate it here for completeness! My detailed record of events included:

  • Couldn't update via Pamac due to the nvidia-utils dep breakage
  • Couldn't install kernel 5.1 via Manjaro Settings Manager GUI due to the nvidia-utils dep breakage
  • Rebooted with Advanced Manjaro Settings at GRUB, selecting to boot with kernel 4.19
  • Removed kernel 4.20 and 4.14 via Manjaro Settings Manager GUI
  • The list of updates in Pamac had changed and Pamac could now update successfully
  • Kernel 5.1 could then be installed via Manjaro Settings Manager GUI successfully

:smile:

2 Likes

I was too afraid to try this spooky terminal command, so I managed with the GUI, but thanks regardless!

LOL! Never take chastising comments I make seriously. Always look for the :grin::grin::grin:

1 Like

For me the issue was that I had an unsupported kernel installed. Since I was already running 5.1, it was just a matter of uninstalling the unsupported kernel (in my case 5.0) after which updates worked again. Hope this helps someone!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by