Installing on Mac Mini 2006 Core Solo

I've got an old Mac Mini from 2006. I'd like to install Manjaro on it, but as the rumors go, so does my installation.

I downloaded the 32bit Architect ISO from and burnt it to a usb stick using dd. Then plugged in the USB stick and turned on the mini. Holding the Option/Alt key gives me a boot menu of sorts (it's graphical...), but my USB stick doesn't show up, just the hard drive on the machine. Holding Cmd+Shift+S gives me a root shell of sorts, but I'm not quite sure what to do with that. I can post some pics of that prompt and all the output I get. Does anyone have any advice/has tried to run Manjaro on a Mac Mini of this age before?

I may try following the instructions here, as a starting point.

Your link there has an interesting line:
There are a few additional considerations when booting the USB stick on Apple hardware. This is because Apple's ‘Startup Manager', summoned by holding the Option/alt (⌥) key when booting, won't detect the USB stick without a specific partition table and layout. We'll cover this in a later step.

That said, it looks like that guide may be geared towards newer mac machines. But who knows, give it a whirl.

Its been some time for me now, but last time (some years back) I put linux on a macbook I had to use Refind to boot.

There is definitely a graphical startup manager with 10.4. Like I said, I'll try those steps in the morning and see what I get. Currently installing Manjaro on a flash drive...

Sure, but thats not the point. If it only recognizes HFS or NTFS then it doesnt matter if it is graphical or not. Refind attempts to extend the built-in functionality of the EFI loader. They can be especially finnicky on certain macs. If you make darn-sure everything is correct after followng the guides out there and you still get no traction, then you may just need to go with an alternative loader.

But I agree, try first ( theres no need doin unecessary things :wink: )

Oh, and you might also want to try converting the .iso to an img for macs sake, as outlined here:

1 Like

Still can't get the USB stick to boot. I also can't get it to read a blank DVD so installing via that isn't going to be easy either. I ended up following those instructions you linked for writing the iso as a .img.dmg, but that didn't work either. I'll try reformatting the drive and trying again.

Does anyone have any advice for getting a manjaro disk to boot on EFI? I'm really stuck...

There might be some help somewhere on this page:

ooo wait ... it looks like some work, but have a look here:

The error message the guy describes in your second link is exactly what I experienced with a boot disk! That was the only one I could get EFI to recognize, but I got that error. I've run the C program on the ISO and I'm currently moving the file around my netowork to the family mac to get a disk burned. I'll post as soon as I know whether or not it worked.

1 Like

There was atleast one comment confirming success with a Manjaro 17 image using the described method. Best of Luck!

Never been so happy to see Welcome to GRUB! in my life!!! Thanks a bunch! We're going to see how the install goes (probably take most of the night because of my slow internet + architect), but hopefully it will work. Also hoping that it will boot from the hdd once that's been accomplished...

Right, it choked on loading some kernel modules. My guess is that it just ran itself out of RAM. That'a fairly easy fix, once I manage to find two 1GB sticks of DDR2 RAM...

EDIT: I ordered two 1GB sticks from ifixit on Sunday. Probably get here some time next week.

1 Like

Ram came today! I am very pleased with the shipping time. I think they predicted sometime between the 28th and the 1st.
In any case, I managed to upgrade the RAM without any more trouble than the usual hiccup getting the case shut again... OSX boots like a charm. And registers that there are now 2GB of RAM. I get the same issue I had before when trying to boot Manjaro. Here is a pic of the kernel booting:
I'll do some googling around, but I'm assuming the issue is definitely not the RAM...

EDIT: A lot of what others with this error are seeing is not what I am seeing. They say the timer goes forever, but I'm actually frozen. I took that pic about 10 mins ago, and it still says 32s / 1min 30s, and the red progress thingy hasn't moved.

I can change the job that it freezes under by choosing the non-free drivers on the grub boot menu, and I can add --add rw init=/bin/bash after the linux command when editing the grub config with the e option to get a root shell. However, that isn't really ideal...

Can you make sure that you have a display manager installed, and also that you are updated and have correct selections in mhwd.

This is trying to boot the live dvd (yes, I can't get efi to recognize a usb stick) of Manjaro-Architect.

With such untypical hardware I would try some other distros. Especially because Core Solo makes no sense, hence Arch is dropping i686 support, leaving Manjaro no choice to drop it, too.

I'm planning to try out the arch32 repos, because I love how slim Manjaro is, and that it's rolling. I may grab one of the arch32 isos though. We'll see.

Don't expect much support for your hardware issues there. They have enough to do with build errors with packages to resolve.

Void booted like a charm. We're going to see how I like it, and If it's good enough, I'll continue to use it on that machine.

1 Like

Having some difficulty trying to get the HDD to be bootable. I'm asking for help on their IRC and browsing their wiki, since that's pretty far out of scope over here...

Keep an eye on this other thread, they seem to have run into HD issues aswell:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by