Installing USB Wifi Driver

Hello i am having trouble installing drivers for my wifi dongle, I have the following wifi dongle:
http://www.jensenofscandinavia.com/en/downloads/al500ac-v1/
The instructions for the driver are:

  1. Copy the linux driver rtl8812AU_8821AU_linux-master.zip to your local drive
  2. Open a console window
  3. Unzip the archive
  4. Enter make (and click enter)
  5. Enter sudo apt-get install build-essential (and click enter)
  6. Enter sudo modprobe 8812au (and click enter)

I have problems already on step 4 as i get "make: command not found" all the solutions i found online involved installing other things but i don't have internet on the computer yet and the way i got the driver files to it was transfering to an USB on another computer.

Thanks in advance c:

Please post:

lsusb

If you are on kernel 4.14 install the Linux headers package for that kernel.

sudo pacman -Syu linux414-headers

If you are on a different Kernel, the number in the package should correspond to your kernel version.

After installing the Linux headers package, reboot.

In your graphical package manager perform a search for your driver.

Search for "8812" in Pamac or Octopi. It should return a hit on a dkms package in the AUR.

Install the package:

rtl8812au_8821au_linux-dkms-git

Then reboot.

Hopefully your adapter will be working now.

$ lsusb
Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 004: ID 046d:0843 Logitech, Inc. Webcam C930e
Bus 003 Device 003: ID 0c45:0133 Microdia
Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1e7d:2e22 ROCCAT
Bus 001 Device 006: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac 2T2R DB WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Not sure how to do the pacman command without an internet connection, the computer in question has no lan connection

Then you need to use a cell phone and enable phone tethering for an internet connection, otherwise the process gets very complicated as you would need to download all required packages on another computer.

Darn, ill try to figure something out

I managed to share the internet from a laptop to the computer so i did as you suggested, but after rebooted i got no results when searching for 8812 so i tried just manually adding the package from the command line but that didn't work either. I got the following as the output:


sudo pacman -Syu rtl8812au_8821au_linux-dkms-git
[sudo] password for meee: 
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
error: target not found: rtl8812au_8821au_linux-dkms-git

I checked in the Manjaro setting and i am indeed running Kernel 4.14.69-1 so i dont know why it didnt work.

It didn't work because it is an AUR package. You must have AUR support enabled. Which gui package manager do you use Octopi or Pamac.

Im not sure which one it is as its not branded, it came with budgie. I found out how to turn on listing of AUR and that made it work. Wifi works now, thank you very much!

Awesome, please mark my first post as the solution, and you're welcome.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by