Installing Veikk drivers on manjaro

I am trying to install the latest Veikk (wacom like devices meant for graphics input) drivers for Manjaro. I am current on Manjaro 20.0.3, with kernel 5.6.16-1.
The Linux driver source was pulled from jlam55555 on github and I managed to make it but when I tried installing the driver, i ran into an issue as you can see below

$ sudo make all install clean
make -C /lib/modules/5.6.16-1-MANJARO/build M=/home/brkumar/Downloads/veikk-linux-driver-2.0 modules
make[1]: Entering directory '/usr/lib/modules/5.6.16-1-MANJARO/build'
  MODPOST 1 modules
make[1]: Leaving directory '/usr/lib/modules/5.6.16-1-MANJARO/build'
make -C /lib/modules/5.6.16-1-MANJARO/build M=/home/brkumar/Downloads/veikk-linux-driver-2.0 modules_install
make[1]: Entering directory '/usr/lib/modules/5.6.16-1-MANJARO/build'
  INSTALL /home/brkumar/Downloads/veikk-linux-driver-2.0/veikk.ko
At main.c:160:
- SSL error:02001002:system library:fopen:No such file or directory: crypto/bio/bss_file.c:69
- SSL error:2006D080:BIO routines:BIO_new_file:no such file: crypto/bio/bss_file.c:76
sign-file: certs/signing_key.pem: No such file or directory
  DEPMOD  5.6.16-1-MANJARO
make[1]: Leaving directory '/usr/lib/modules/5.6.16-1-MANJARO/build'
modprobe veikk
modprobe: FATAL: Module veikk not found in directory /lib/modules/5.6.16-1-MANJARO
make: *** [Makefile:15: install] Error 1

Luckily this seems to be a known problem and there is a solution given by a user who has said that doing sudo depmod and sudo modprobe veikk on ubuntu before running the 'make install' willfix this issue. I wanted to know, if I can run the same on Manjaro as well to install the driver?

:slight_smile:
Mind you, but there is something else in the README on the github link you shared.

That means, you just run:
pamac build input-veikk-dkms
then
sudo modprobe veikk

1 Like

The input-veikk-dkms AUR, is an old package and has not been kept up to date. I am trying to build and install the latest 2.0 version. Do you think even for this we will need to use the AUR before running make install?

The PKGBUILD might be old, but it builds from the git, that means is latest source ... Anyway, i'll read more about it later.

Thanks for the help. I will wait for you to confirm, if the drivers are the latest.

Ok, so here it is:

image

The 815cff1 is the last commit on the github and version is 2.0 no doubt. It adds correctly the /etc/modules-load.d/veikk.conf to load the module at boot.
Of course i can't test it since i do not have a VEIKK device at hand, but i'm sure once you install the linux headers for your running kernel, then install it, all will be fine.

The GUI i didn't tested yet.

I tried this but it doesn’t seem to finish..

It unable to remove input-veil...
And
Unable to install module input-veil...
For the kernel 5.4.52....

image

I'll ask then why not installing the linux headers first as it shows are missing
image
and why not installing it from AUR?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by