Installing video-nvidia using mhwd always leads to Failed to start load kernel modules

A lot of people have got similar problems, still not able to find a good solution.
I want to use dGPU without bumblebee. I have a dual graphics laptop (Nvidia+Intel). I did the following:

  1. Installed video-nvidia using mhwd
  2. Reboot

System hangs at Failed to start load kernel modules and a black screen with a bunch of things similar to this (Not my screen though, just for reference):
jB4NT

1)Only fix is uninstall video-nvidia and use bumblebee
2)Or use only free drivers

I really want to utilize the dGPU fully for some tensorflow-gpu tasks.

Any help appreciated.

System:    Host: pc Kernel: 4.19.24-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: KDE Plasma 5.15.1 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 3558 v: N/A serial: <filter> 
           Mobo: Dell model: 0G1TDD v: A00 serial: <filter> UEFI: Dell v: A16 date: 05/23/2018 
Battery:   ID-1: BAT0 charge: 17.0 Wh condition: 28.0/41.4 Wh (68%) model: Panasonic DELL 78V9D66L 
           status: Charging 
CPU:       Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell rev: 4 
           L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17566 
           Speed: 1094 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 996 2: 938 3: 895 4: 1013 
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GK208BM [GeForce 920M] vendor: Dell driver: nouveau v: kernel bus ID: 08:00.0 
           Display: x11 server: X.Org 1.20.3 driver: intel,nouveau unloaded: modesetting 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 18.3.3 
           direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.19.24-1-MANJARO 
Network:   Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel port: 5040 bus ID: 06:00.0 
           IF: wlp6s0 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel 
           port: 4000 bus ID: 07:00.0 
           IF: enp7s0 state: down mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 68.24 GiB (7.3%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
Partition: ID-1: / size: 114.22 GiB used: 17.19 GiB (15.1%) fs: ext4 dev: /dev/sda5 
           ID-2: /home size: 95.38 GiB used: 51.04 GiB (53.5%) fs: ext4 dev: /dev/sda8 
           ID-3: swap-1 size: 5.25 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 50.0 C mobo: 54.0 C gpu: nouveau temp: 49 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 201 Uptime: 12m Memory: 3.76 GiB used: 1.47 GiB (39.2%) Init: systemd Compilers: 
           gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 3.0.30

Then you have to go by

or by

Make sure you don't do both, and always double check what you do :slight_smile:

if your able to disable the intel gpu from bios, thats the easiest way. prime is the best performance all around if you cant disable the intel gpu. if you want both prime and ability to switch to intel-only mode (for power savings) and prime mode for gpu intensive tasks, in addition to what @bogdancovaciu suggested.

Call for testing: optimus-switch

heres a description of each of the various options

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by