Installing Windows made Manjaro boot in Emergency Mode

Perhaps this isn't the right place for this, and perhaps it's already been answered before, but I've tried searching all of my errors and either they were shrugged off as unimportant or were irrelevant.

First I'll explain what I was doing that caused this issue. I always dual booted Manjaro with Windows on the same 250gb SSD, each with their own partition. I decided to move windows to a 1TB HDD because bloat, blah blah blah. With the horrible history windows has with linux and the recent 1809 update deleting users files, I unplugged my drives just incase, doesn't hurt to be precautious. After installing windows onto the new drive, and getting it all set up, I plugged my linux SSD back in, and messed with the boot loader since grub wasn't automatically being detected anymore due to what I assume windows messing with the master boot loader. Launched grub, and booted into Manjaro. A handful of messages would appear and then it would say I'm in emergency mode. I have no clue why exactly this happened, from what I've searched it seems to be due to corrupted files, but how did they get corrupted?
I've seen some posts say something is wrong with my motherboard, but I hadn't touched my motherboard, I find that highly unlikely, but I could be wrong. I've also unplugged the windows drive, but that changed nothing.

The messages/errors that are displayed

[    0.014984] [Firmware Bug]: AMD-Vi: IOAPIC[0] not in IVRS table
[    0.014991] [Firmware Bug]: AMD-Vi: No southbridge IOAPIC found
[    0.014984] AMD-Vi: Disabling interrupt remapping
starting version 239
[    1.906830] usb 8-1: device descriptor read/64, error -62
/dev/sda4: clean, 445482/4194304 files, 9317950/16777216 blocks
[    3.119207] sp5100_tco: I/O address 0x0cd6 already in use
[ TIME ] Timed out waiting for device dev-disk-by\x2duuid-6025\x2dDE36.device.
[DEPEND] Dependency failed for /boot/efi.
[DEPEND] Dependency failed for Local File Systems.
[DEPEND] Dependency failed for File System Check on /dev/disk/by-uuid/6025-DE36 

There were more but they were all essentially

[  OK  ] Reached target Sound Card.

After those messages, it tells me to type "journalctl -xb" to view system logs, but the only issues I had noticed were the same as up above. I'll add them if anyone believes it'll help though. As for my system, this is the output of inxi -Fxxxz

System:    Host: elikay-pc Kernel: 4.14.71-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Console: N/A 
           dm: N/A Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: A78M-E35 (MS-7721) v: 6.0 serial: N/A BIOS: American Megatrends 
           v: 30.2 date: 02/21/2014 
CPU:       Topology: Quad Core model: AMD Athlon X4 750K bits: 64 type: MCP arch: Piledriver rev: 1 
           L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 27156 
           Speed: 1394 MHz min/max: 1400/3400 MHz boost: enabled Core speeds (MHz): 1: 1392 2: 1397 3: 1396 
           4: 1394 
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: driver: nvidia v: 396.54 bus ID: 01:00.0 
           chip ID: 10de:1401 
           Display: server: 1.20.1 driver: nvidia tty: 240x67 
           Message: Advanced graphics data unavailable in console for root. 
Audio:     Device-1: Advanced Micro Devices [AMD] FCH Azalia vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 00:14.2 chip ID: 1022:780d 
           Device-2: NVIDIA vendor: driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fba 
           Device-3: Corsair type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 8-1:2 
           chip ID: 1b1c:0a0a 
           Sound Server: ALSA v: k4.14.71-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 v: 8.045.08-NAPI 
           port: d000 bus ID: 02:00 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
Drives:    Local Storage: total: 3.89 TiB used: 34.04 GiB (0.9%) 
           ID-1: /dev/sda vendor: Crucial model: CT256MX100SSD1 size: 238.47 GiB speed: 6.0 Gb/s 
           serial: <filter> rev: MU01 scheme: MBR 
           ID-2: /dev/sdb vendor: Western Digital model: WD30EZRZ-00Z5HB0 size: 2.73 TiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: 0A80 scheme: GPT 
           ID-3: /dev/sdc vendor: Western Digital model: WD10JPVT-08A1YT2 size: 931.51 GiB speed: 3.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: 1A01 scheme: MBR 
           ID-4: /dev/sdd type: USB model: USB DISK 2.0 size: 14.46 GiB serial: <filter> rev: PMAP scheme: MBR 
Partition: ID-1: / size: 62.50 GiB used: 34.04 GiB (54.5%) fs: ext4 dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 0.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 93 Uptime: 1h 01m Memory: 7.80 GiB used: 153.7 MiB (1.9%) Init: systemd v: 239 Compilers: 
           gcc: 8.2.1 clang: 6.0.1 Shell: bash v: 4.4.23 inxi: 3.0.21 

Any help would be much appreciated. If worst comes to worst, I'll just reinstall, but hopefully that won't be the case.

Can you post a copy of your /etc/fstab?

You will probably need to either mount your root partition via the emergency shell or boot off a live image and mount it that way.

I think your system is uefi.
See this and boot up. After fixing it following the post, read completely 1st post, do not unplug any drive. Let us know if you want to unplug any drive in the future and we'll handle it after you tell us.

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=fefd8448-de96-4947-a5c8-517985bb109c /              ext4    defaults,noatime,discard 0 1
UUID=6025-DE36                            /boot/efi      vfat    defaults,noatime 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

Your $esp (/boot/efi) could not be found.
Is it there, or changed UUID?

inxi -puo

That guide didn't really do anything to help, if anything it made it worse. Maybe I did something wrong, and didn't read it correctly, but it ended up basically corrupting my grub and I ended up using gparted to just completely format my boot partition because it was starting to say that I hadn't shutdown my old install of windows, which wasn't there anymore. I've gotten grub installed again, and its detected in the MBR, but it didn't do anything to solve my issue so far. I'm pretty much just back to where I was, but with a weird slightly broken grub.

I don't know exactly what I'm looking for, but this is the outcome of that command.

  ID-1: / size: 62.50 GiB used: 34.99 GiB (56.0%) fs: ext4 dev: /dev/sda4 
  uuid: fefd8448-de96-4947-a5c8-517985bb109c 
  ID-1: /dev/sda1 size: 512.0 MiB fs: vfat label: N/A uuid: 9F90-ECB1 
  ID-2: /dev/sdb1 size: 128.0 MiB fs: N/A label: N/A uuid: N/A 
  ID-3: /dev/sdb2 size: 2.73 TiB fs: ntfs label: Storage uuid: 04A851E5A851D630 
  ID-4: /dev/sdc1 size: 931.41 GiB fs: ntfs label: Media uuid: A60A521F0A51ED35 
  ID-5: /dev/sdd1 size: 2.01 GiB fs: iso9660 label: MJR17112 
  uuid: 2018-08-18-15-33-20-00 
  ID-6: /dev/sdd2 size: 4.0 MiB fs: vfat label: MISO_EFI uuid: AA50-706E 

When reinstalling grub due to what I mentioned in my last post, it did give me errors which may be related to it though, so I'm assuming stuff is very messed up right now.

Make both disks either msdos or gpt only.
Install all OS's in uefi or bios-legacy only.

Recreate your ESP. After that, use a manjaro install to get a grub command prompt. Try booting your system. Using “configfile (HDx,x)/boot/grub/grub.cfg you’ll have to search a little to find your drive using the LS command. If you can get back into your system. Go into /etc/fstab and change the partition UUID to the new one, now finally, install grub and then update it.

Edit fstab and replace UUID.
It may work. If not, go with the tutorial posted by @gohlip

If you still have problem, print output as stated in the link.
Without the output, we can't help you.

aha, that seems to have fixed it. Sorry for the trouble and thanks for the help guys.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by