Intel based Laptop does not boot if external Monitor is present (since Manjaro 20.0.x)

Hello,

as I was distro-hopping, I also tried Manjaro. All 3 major spins share the same issue on my intel based laptop:

The boot process is halted very early - before you can switch consoles or whatever. It simply stalls.
I found this to happen even with the Manjaro installation image when booting from an USB-Stick.
It does boot when no external monitor is connected (or is switched off). Problem is: I use a docking station and my ext. monitor is present most of the time.
It also reboots fine most of the time.
It happens on all Manjaro spins - so it is not related to KDE or GNOME.

For the time being, I switched to Pop!_OS, but since this is also Ubuntu-based I'd rather use Manjaro :slight_smile:.

From initial post, but later found it was not related to the problem thanks to the heads-up from the two gents answering below:

Today I experimented with editing the boot parameters of the installation and it seems that my laptop boots when I delete the AMD-part out of the initrd line:

Default, does not boot if ext. monitor present:

linux /boot/vmlinuz-$2
initrd /boot/amd_ucode.img /boot/intel_ucode.img /boot/initramfs-x86_64.img

Changed to, does boot:

linux /boot/vmlinuz-$2
initrd  /boot/intel_ucode.img /boot/initramfs-x86_64.img

Since I do not know if the PC really boots because I cancelled out the amd_ucode.img or because it boots differently because of me using the editor before actually booting...can anybody confirm this bug/behaviour? :slight_smile:.

  • Is this a common issue on intel-based systems or is it just my Dell Latitude E7440? (Intel HD 4400, i5 Gen4U)
  • If it is common, it would be very benefitial to change the default boot configuration of Manjaro.
  • If it is just my laptop - can you point me to a tutorial on how to change the boot entries of the finished install of Manjaro, please

TLDR:

  • Dell E-Dock plus docking station was the issue. Connecting the monitor directly to the laptop showed no issues
  • deleting "quiet" from GRUB boot parameters also resulted in successful booting even when using the docking station

Regards,
SuAlfons

The ucode image is only loaded when a matching cpu are found.

I have never seen an issue where the ucode image is blocking boot - so I think this is a local issue - but as you say - never say never.

I think it is an issue with your dock - but I can't be sure.

1 Like

Try the following:

If you power on your laptop, press "e" when GRUB appears. Afterwards, go the line starting with "linux" and remove the word "quite". When done, press "Ctrl + x" or F10.

Report back if that worked. If yes, you can do this change permanent in a second step.

1 Like

Yes!
You are both right!

  • Laptop does reboot with ext. monitor attached to HDMI or mini-DP directly, without the docking station

  • Laptop does boot when everything is connected to the docking station and "quiet" is deleted from boot parameters.

Thanks for your help so far!

I will change the initial post accordingly, since deleting amd-stuff was not the thing to do (it sometimes just boots when it is not a proper cold start).

The culprit probably is the Dell "E-Port plus" docking station I use with my Latitude. (It's the more modern one with 2 DVI+2 DP + 1VGA connector and USB3-support on two ports if your laptop also has USB3).

But why does Pop!_OS (SystemD boot manager) and any other Ubuntu-based distro I tried (Ubuntu, Mint, Zorin OS, Elementary) boot without issues?

Glad you sorted it out! Do you know how to modify GRUB so you don't have to remove the quit flag each time at boot?

Try both and use whatever suits you best! I use KDE for years now but it is really a matter of taste. I guess both have their advantages/disadvantages.

1 Like

Using KDE on Manjaro is probably one of the best distro to run it on - I used to have problems with KDE when I tried Kubuntu (18.04 LTS and then the then current 19.04) and using the laptop stand-alone, in dock, with a projector, on a TV....after a week or so, screen would stay black with the easiest resolve being a new base-installation ( /home on extra SSD).

So I'll probably try Manjaro KDE

And yes, changing GRUB, I think I'll find the list of commands I always forget to rebuild the boot menu via search.

So I did it.
Reinstalled my main Laptop with Manjaro (editing out the "quiet" option in Grub).
Currently I give KDE a try.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by