Intel Baytrail (Lenovo Miix 300)

Hey everyone!

I took pretty much time to read around, both here, in the Arch documentation and Wiki and elsewhere, before deciding to finally open a topic here. There are some threads that have something to do with my issues, but nothing seemed to help so far. Maybe this machine is particularly unfortunate?

I got a Lenovo Miix 300 I wanted to resurrect. You know, Easter is coming... :stuck_out_tongue:
I tried several distros so far (talking about the 64bit versions that can at least boot):

  • Void Linux attracted me for the approach, it boots and works, but the installation is very bumpy (many things that should be there are not -logind, xorg etc- and I had to go by hand quite a lot). I do not feel ready for that kind of approach yet
  • Fedora 31 & 32 beta work the best so far (even screen/touch rotation in Gnome, after some tweaking of the sensors´matrix)
  • MX Linux works fine as well
  • I managed to give Mint a spin as well, after some trouble with the initial problem of the black screen (Baytrail related) and a manually baked USB key to be able to boot from
  • I could boot into a taylored version of Arch with 32 bit efi support, I went through the installation but got some errors while pulling the packages, I did not investigate that hard (I would like to share the fun of having the machine on its side - it starts 90 degrees counterclockwise - with a USB hub, a keyboard and a USB-RJ45 dongle -no wifi at least at that stage-, who tried can understand. Yes, I tried also with my head sideways at the beginning, but that was too painful).

But...

  • Manjaro 19.02 64 bit is not seen at all by the efi
  • Manjaro 19.02 32 bit (i686 spin) boots, but leads me to a black screen (same as Mint, but I did not push further on that either).

I try to expand further (at least that´s what I understood so far):
the Miix 300 has a 64 bit Intel Baytrail processor (with integrated controllers, gpu & audio) but a 32 bit EFI. Yes, there are some guides, one of them in this very forum (that by the way has been deprecated because Manjaro supposedly should support this kind of architectures now) and I do not think I am creating a duplicate here. Even if yes, I am aware that I could be one of the very few adventurous ones trying to crack my head on this cheap piece of old iron, who knows even why.

With Manjaro the best I could achieve (after editing the iso and inserting the 32 bit efi (bootia32.efi) and the grub file from the git repo of the guide) I get to the grub command line, but I can not see any partitions (with ls I can see the disks, but everything says "unknown filesystem" or "partition non existing" and can not go anywhere, at least with my scarse knowledge I have at the moment.

Is there any good soul that have some hints for this adventure?
Or anyone else that could take advantage of this discussion?

Thanks a lot, have a great day!

Dario

I can point you to this "guide" which is now a little out of date (guides for rolling release distros tend to go stale quickly.) The problem of "unknown filesystem" is that the Manjaro bootia32.efi can only read the ISO9660 format, not fat32 or ext4. My guide should produce a liveUSB that will get to the desktop. But it is concerning that Manjarox32 just goes to a black screen. The 4.19 LTS kernel has good OOTB baytrail support, so Manjaro32 should be able to boot to the grub menu and then the desktop. I am unfamiliar with Miix specific quirks.

Thank you @jbMacAZ,
I don't know why I saw your guide at a certain point, and then it disappeared from my search results.

And the best part is:
it works!!!!

I have never gone so far, I could boot and install as well!
Not without some trouble, the installer got stuck formatting the disk, then didn't want to make the swap, then complained about a missing label in the efi partition, but... after doing some suff by hand and relaunching the installer, it went until the end, and I could boot from the internal MMC:

I am still updating before I can say where I am,
but - as said - never could I go so far, thank you so much!!
Your guide should get more evidence, and they should actually consider implementing this natively, if there are not major problems, like other distros did.

I'll get back with further details, if anyone else should ever benefit!
Cheers!!

1 Like

I'm glad it worked out for you. :grinning:

I've been lobbying for uefi32 support for the 64 bit ISOs, especially since Manjaro32 was able to implement it successfully.

I have really no idea why it has to be like that.
Manjaro did the best job so far also on this little old tablet,
even if I have been customizing, updating and installing, I can already say that it runs cooler and faster (even boot and shut down times) and with a bit of tweaking it looks amazing!
I think I got this Miix 300 back to business,
thank you so much for helping out!! And it was damn easy! :wink:
I will see if I can have the rotation of the screen and touch going, but so far sound, wifi and bluetooth are there and run fine!
Cheers Dario

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by