Intel Ethernet I219-LM - LAN port flapping

Over the past couple of days I noticed my internet downloads were much slower than before. I investigated further and discovered my LAN connection was working at 100Base-T whereas before it had been a 1000Base-T. So reading some threads here I saw that one of the recommendations was to change the /etc/dhcpd.conf configuration from duid to clientid and then reboot. So I've tried that but since then my LAN connection has been continually flapping every 3-4 seconds. Its gotten to the stage I've had to disable it to keep the system stable, and instead use my wifi network connection. I've changed the dhcpd.conf config back to duid, and rebooted again but it has made zero difference

The only other change I've made recently that I can remember was turning off IPv6 via /etc/default/grub, and I've reversed that change (and updated grub) also and rebooted, but again it has made zero change.

dmesg output:
other command output:

The interface is set to autoneg, and get its IP via DHCP. MTU size is set to automatic, there's no 802.1x used, or anything out of the usual for a normal home network.

System is up to date with all the latest patches. Has there been an update to the e1000e driver in the past 2-3 weeks, or how do I go about figuring out whats gone wrong all of a sudden?

Please read:

There have been a lot of issues with the e1000e driver recently. The most likely fix is using a different kernel as 5.4 is currently experiencing many networking issues.

On the links I posted, one user had to go all the way back to kernel 4.9 recently to get this adapter working. Also the 5.2 Real Time (rt) kernel was reported to fix recent speed issues as well.

I hope you have already tested alternate cabling (cat6e or better quality).

Also be sure your bios is up to date.

Hopefully some of those suggestions will fix you up.

1 Like

I saw that post on the laptop docking station when I was troubleshooting why I was only getting a 100Mb connection rather than a 1 Gb one, but this device is a desktop rather than a laptop, so its not prevalent for me.

Trying the whack a mole game of matching different versions of kernels and network drivers sounds like hell, because I'm guessing its going to have to be repeated every time either is upgraded in the future. As its a desktop rather than a laptop, is there a USB or PCI network card I could get which is unlikely to also have this issue?. Or is that the e1000e driver is ultimately at fault here, and the network card in use is relatively immaterial?

Installing a kernel is one of the easiest troubleshooting measures you can perform with Manjaro. It is as simple as a push of a button and a reboot (and select a new kernel).

No, you do not have to reinstall the e1000e network drivers upon kernel update (as they are contained in the kernel).

If you wish to spend money to replace your network hardware that is your prerogative. I do not give hardware recommendations as new bugs with firmware/drivers can make what was previously a good adapter a complete disaster. Problems with drivers come and go in Linux, check the internet for up to date recommendation on hardware purchases.


Ok, I can see it was working fine with 5.4.2-1 kernel, so I'll fall back to that when I'm at home later and see if everything resolves itself.

Before you change the NIC, change the cable first, please! :innocent:

Yeah, I've verified its not the cable, I swapped it, used different switch ports and still the same issue. The same switch is being used by other devices without a problem too.

I didn't realize that in updating the kernel with the last update, that it would remove the previous kernel. So the only ones available via grub are the current one I'm using and a 3.16 release. If I try to boot of it, the system never fully boots. So I'm trying via the Manjaro Settings Manager to install a different kernel via the WiFi connection, but while its reasonable enough to load this webpage and others, its not fast enough to download the kernel. It was a PoS device I had lying around that only uses the 2.4GHz band, so I've now gone and bought a different device that can see both bands. Problem is when I try to install the driver I get this error

make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.4.6-2-MANJARO/build M=/tmp/wifi/RTL88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959/driver/rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959  modules
make[1]: Entering directory '/usr/lib/modules/5.4.6-2-MANJARO/build'
make[1]: *** No rule to make target 'modules'.  Stop.
make[1]: Leaving directory '/usr/lib/modules/5.4.6-2-MANJARO/build'
make: *** [Makefile:1986: modules] Error 2
Compile make driver error: 2
Please check error Mesg

and I've no idea how to get around it

So figured out the problem with the WiFi was with the firewall behind it blocking FTP, moved the kernel back to 5.3 and we're good again

[stevo@zen ~]$ inxi -Fx
System:    Host: zen Kernel: 5.3.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.4 
           Distro: Manjaro Linux 
Machine:   Type: Desktop System: Dell product: OptiPlex 7040 v: N/A serial: <root required> 
           Mobo: Dell model: 0Y7WYT v: A00 serial: <root required> UEFI [Legacy]: Dell v: 1.15.5 date: 07/19/2019 
CPU:       Topology: Quad Core model: Intel Core i7-6700 bits: 64 type: MT MCP arch: Skylake-S rev: 3 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54417 
           Speed: 900 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 900 2: 901 3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
Graphics:  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GM107 [GeForce GTX 745] driver: nvidia v: 440.44 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.6 driver: nvidia resolution: 1920x1080~60Hz, 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 745/PCIe/SSE2 v: 4.6.0 NVIDIA 440.44 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: NVIDIA driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k5.3.18-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: f4:8e:38:aa:18:54 
           Device-2: Realtek 802.11ac NIC type: USB driver: usb-network bus ID: 1-1:2 
           Device-3: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB driver: r8188eu bus ID: 1-3:3 
           IF: wlp0s20f0u3 state: up mac: 34:e8:94:df:33:f6 
Drives:    Local Storage: total: 931.52 GiB used: 203.55 GiB (21.9%) 
           ID-1: /dev/sda vendor: SanDisk model: SSD PLUS 1000GB size: 931.52 GiB 
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:17.0 
Partition: ID-1: / size: 887.06 GiB used: 203.55 GiB (22.9%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 29.30 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 45.5 C mobo: 29.8 C gpu: nvidia temp: 49 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 21% 
Info:      Processes: 271 Uptime: 3m Memory: 31.25 GiB used: 1.29 GiB (4.1%) Init: systemd Compilers: gcc: 9.2.0 clang: 9.0.0 
           Shell: bash v: 5.0.11 inxi: 3.0.37 

Figured out that compliation error above was from not having kernel headers installed either. Although once I did that I got another compliation error. I'll try again in a while to see if the new kernel makes a difference or if there's a newer version of the driver available

If any of the above answers resolved your original issue, please do not forget to mark the correct one as "Solution" as per the screenshot below so that your question gets removed from the "unsolved" queue.


If none of the above answers solved your original issue, don't despair: someone else smarter will come along! :wink:

If you have another issue now, please feel free to create a new topic instead of trying to ask someone who is an expert in your old topic but might not be an expert on your new topic... :scream:

We thank you for your cooperation!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by