Intel Graphics GPU Artefacts Mesh in any opengl enabled program (includes webgl)

Good Day I am experiencing some strange symptoms while trying to use any opengl or webgl program.

I selected non-free when installing so I am unsure if that could be the reason, and I am also unsure how to switch.

My first example is half-life, I figure an Intel i5 with onboard should be able to play that, but it makes a mesh of blocks over the screen initially and usually freezes entirely after a while.
In civilizations 5 random triangular artefacts of different colours cover the screen and the game is unplayable. The same happens on all webgl enabled applications.
In Dota 2 I tried running it on Vulkan, but in Vulkan none of the text renders properly.

Please help, I've tried disabling the compositor, switching kernels and several other random fixes I found on support forums, but no luck so far.

hi, please carry out the instructions here and then post a link to your inxi dump in this thread so we know which generation Intel GPU you are experiencing problems with. They aren't all handled the same way and you may need to apply a workaround.

1 Like


Added inxi dump as requested.

I don't know if bumping is a thing here.
I will be home in 9 hours to continue troubleshooting.

If anyone has an idea as to which workaround to apply, even just a direction would be wonderful.

I sort of figured that someone might be able to assist me here, but I figured wrong.
Guess community support is not going to be what Manjaro is known for. And here I was planning on switching all our laptops at work over to Manjaro, but I guess I will have to go back to Mint.
Thanks for the assistance.

You're just in bad luck. Sometimes this happens, no need to be harsh on everyone giving up their free time to help others.

Regarding your issue, I'd try to use the intel driver instead of using modesetting. For this, you only need to create a valid xorg file (then reboot or restart xorg):

[mbb@mbb-laptop ~]$ cat /etc/X11/xorg.conf.d/91-intel.conf 
# Configuração da gráfica INtel HD 4000

Section "Device"
        Identifier      "Device0"
        Driver          "intel"
        BusID           "PCI:0:2:0"
        Option          "DRI" "3"
        Option          "AccelMethod" "sna"
        Option          "TearFree" "true"

Section "InputClass"
        Identifier      "Keyboard Defaults"
        MatchIsKeyboard "yes"
        Option          "XkbOptions" "terminate:ctrl_alt_bksp"

You can get the BusID from lspci:

[mbb@mbb-laptop ~]$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

Note the difference when referring the PCI Bus in the xorg file.

TearFree will avoid screen tearing (which you probably don't have). If the problem persists you can try to change "DRI" "3" to "DRI" "2" and, as a last resort, change "AccelMethod" "sna" to "AccelMethod" "uxa". You can find more info here.

I've been following this topic, but I haven't replied because the symptoms I had with modesetting driver weren't as severe as yours, so I figure the problem must be different and there might be someone more knowledgeable than me with a better answer.

NOTE: if you're using wayland don't apply this suggestion.

Thanks for the reply, I had given up hope on ever playing games again. I will update with results.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by