Intel graphics seem slower than they should be.

Continuing from How do I know if I have video-hybrid-intel-nvidia-440xx-prime?

After setting up Hybrid graphics after having been solely on my Nvidia card (after turning on Hrybrid graphics in my BIOS to make the Intel GPU visible),

mhwd --remove video-nvidia-440xx
mhwd --install pci video-hybrid-intel-nvidia-440xx-prime

the Gnome desktop appears to be quite clunky, but the graphics don't seem that complicated.

Here's where I'm at:

inxi -G
Graphics:
  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
  Device-2: NVIDIA GP107GLM [Quadro P2000 Mobile] driver: nvidia v: 440.64 
  Display: x11 server: X.org 1.20.8 driver: modesetting,nvidia 
  unloaded: intel,nouveau resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.6 Mesa 19.3.5 

Any ideas on why Intel performance is slow?

But why you still have

[quote="trusktr, post:1, topic:134079"]
driver: modesetting,nvidia unloaded: intel,nouveau
Have you removed the custom configs you had previously, before installing the video-hybrid-intel-nvidia-440xx-prime ?

ls /etc/X11/{mhwd,xorg.conf}.d/
cat /etc/default/grub | grep CMDLINE

I haven't removed any configs. All I did was

  • Install Manjaro onto my laptop, which automatically installed the open-source nvidia driver. (I guess I forgot to choose the nonfree option.)
  • Then once I got to the desktop, I opened the Manjaro Settings Hardware UI, and I enabled the nonfree option, and the UI did whatever it did to switch me to video-nvidia-440xx.
  • And then I finally ran the following, which is where I'm at now:
    mhwd --remove video-nvidia-440xx
    mhwd --install pci video-hybrid-intel-nvidia-440xx-prime
    

So I haven't touched any config files. I'm assuming Manjaro Hardware is supposed to manage all the underlying configs, etc.

$ ls /etc/X11/{mhwd,xorg.conf}.d/
/etc/X11/mhwd.d/:
nvidia.conf  nvidia.conf.nvidia-xconfig-original

/etc/X11/xorg.conf.d/:
00-keyboard.conf  90-mhwd.conf@

$ cat /etc/default/grub | grep CMDLINE
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=2d2476ca-269a-41e3-8666-153465a279e5 udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

What is the content of this file?

$ cat /etc/X11/mhwd.d/nvidia.conf
##
## Generated by mhwd - Manjaro Hardware Detection
##

Seems to be empty

And does the prime-run application is actually using the dGPU ?

Testing it out...

@bogdancovaciu Yeah, it totally makes a difference. I was testing prime-run chromium and the WebGL graphics, f.e. at https://threejs.org/examples/#webgl_animation_cloth, are smooth. The graphics are clunky if I run just chromium without prime-run.

If that works, then just let the interface of the desktop run trough the iGPU, and when you want an app to run with better performance to use that prime-run option. You can create custom desktop files in ~/.local/share/applications/ so you don't have to run those applications always trough terminal ...

Cool! I'll do just that for certain apps. Thanks for that tip! :+1:

Is it possible to specify for the desktop UI to run on the Nvidia card? I really like when the Desktop experience is buttery smooth. :smiley: If it is possible to have the desktop run on the dGPU, can apps that I open on the desktop still run with the iGPU if I don't need them to be ultra fast?

I'm still curious why Intel graphics are so slow. I've tested the same WebGL example (and more intense examples) on Chromebooks that have less powerful Intel GPUs, and things run smoothly on the Chromebooks. The Intel GPU speed is definitely not up to par in my Linux setup at the moment.

You might have to test this


Mind you, but the OP is using KDE Plasma, but is possible, it seems, to have the possibility to use
iGPU + prime-run trough dGPU
dGPU
iGPU

Maybe you need to run the modeset driver for iGPU, aka trough the Kernel, not the video-linux driver. Not sure ...

Thanks! I'll post back if I find anything out.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by