[Intel I219-LM] - Ethernet has no connection


I have an issue with my wired ethernet connection. Here what card I am using:

Network:   Device-1: Intel Ethernet I219-LM driver: e1000e 
           IF: enp0s31f6 state: down mac: 54:ee:75:96:74:10 
           Device-2: Intel Wireless 8260 driver: iwlwifi 
           IF: wlp4s0 state: up mac: 44:85:00:16:43:29 
           IF-ID-1: wwp0s20f0u2c3 state: down mac: 36:a2:71:8a:a0:cf

As you can see, my network card is down. I tried to enable it using

ip link set enp0s31f6 up

but with no luck. I also tried to use nmtuito enable it. Here I get the following error message: Connection 'Wired' is not available on device enp0s31f6 because device has no carrier".

My laptop is connected to a Lenovo Thinkpad Doc, as the laptop itself has not ethernet plug. I tried the cable with another laptop, which works fine. So I am sure that my network connection is working properly. Now I don't know if I am doing something wrong when trying to configure the network or maybe there is a hardware defect (dock or laptop). Any ideas what I can do in addition to find the root of my issue?

This may seem like a silly question. Have you rebooted or tried resetting your router back to the factory settings. It does not matter if other devices connect properly, sometimes only one device has issues with the router or its settings.

Have you tried alternate kernels or firmware yet. Do you have a working connection to post outputs?

Is this a new install?

Has this laptop ever worked with Manjaro or another distro with this adapter using the dock.

Have you tested other live boot disks to see if it works on other DE's or Distros?

Please post the output of the following commands:

inxi -Fxxxz
hwinfo --netcard --bluetooth | grep -Ei "(speed|hotplug|model|status|cmd|file|detected|driver:)" | grep -v "Config S"  
1 Like

There is also an alternate driver you could test if switching firmware and kernels does not improve matters.

To use the dkms driver from the AUR you must first install the linux headers.

The following command will install the linux-headers automatically for all installed kernels:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

*credit @dalto for the command

If you already have an AUR hepler to install the e1000e-dkms driver fom the AUR then you can use it.

Otherwise, install "pamac-cli "to perform the AUR driver installation:

sudo pacman -Syu pamac-cli

Then install the e1000e dkms network driver:

pamac build e1000e-dkms

Then reboot.

1 Like


Thank you for you reply. Will answer your questions one after another.

Yes, I have rebootet several times. I also have reset the router, even tried another one, but with no success.

I am using kernel 5.3. As backup I have 4.9, which did not work either. I also installed 5.2 just to test if it works with that one. I have not tried alternate firmware yet. My WiFi connection works fine, so I am able to post outputs.

No, this is not a new install. Running Manjaro since a couple of years with this setup. Currentl installation is maybe 1.5 years old. Therefore I have not tried if it works with another distro, but could try to narrow down the options.

Here is the output of inxi -Fxxxz:

System:    Host: alpha Kernel: 5.2.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.16.5 
           tk: Qt 5.13.1 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Convertible System: LENOVO product: 20FRS05B00 v: ThinkPad X1 Carbon 4th serial: <filter> Chassis: 
           type: 31 serial: <filter> 
           Mobo: LENOVO model: 20FRS05B00 v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO v: N1FET67W (1.41 ) 
           date: 01/16/2019 
Battery:   ID-1: BAT0 charge: 42.5 Wh condition: 42.5/52.1 Wh (82%) volts: 17.0/15.2 model: SMP 00HW029 type: Li-poly 
           serial: <filter> status: Full 
           Device-1: hidpp_battery_0 model: Logitech M720 Triathlon Multi-Device Mouse serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
           Device-2: hidpp_battery_1 model: Logitech K850 Performance Wireless Keyboard serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i7-6600U bits: 64 type: MT MCP arch: Skylake rev: 3 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 22472 
           Speed: 702 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 4: 700 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:1916 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) v: 4.5 Mesa 19.2.1 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d70 
           Device-2: Lenovo USB2.0 Hub type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-4.1.4:8 
           chip ID: 17ef:3055 
           Sound Server: ALSA v: k5.2.21-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           chip ID: 8086:156f 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: efa0 bus ID: 04:00.0 chip ID: 8086:24f3 
           IF: wlp4s0 state: up mac: <filter> 
           IF-ID-1: wwp0s20f0u2c3 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 188.79 GiB (39.6%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVKV512HAJH-000L1 size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 6L0QBXX7 scheme: GPT 
Partition: ID-1: / size: 143.99 GiB used: 37.94 GiB (26.4%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /home size: 307.21 GiB used: 150.84 GiB (49.1%) fs: ext4 dev: /dev/nvme0n1p4 
           ID-3: swap-1 size: 17.10 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 163 Uptime: 1h 04m Memory: 15.52 GiB used: 1.39 GiB (9.0%) Init: systemd v: 242 Compilers: 
           gcc: 9.2.0 Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.36

And the output of hwinfo:

Model: "Intel Ethernet Connection I219-LM"
  Driver: "e1000e"
  Device File: enp0s31f6
  Link detected: no
    Driver Status: e1000e is active
    Driver Activation Cmd: "modprobe e1000e"
  Model: "Intel Wireless 8260"
  Driver: "iwlwifi"
  Device File: wlp4s0
  Link detected: yes
    Driver Status: iwlwifi is active
    Driver Activation Cmd: "modprobe iwlwifi"
  Model: "Intel Bluetooth Device"
  Hotplug: USB
  Driver: "btusb"
  Speed: 12 Mbps
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"

So did things break after an update then?

If not, perhaps this is a hardware issue. That is why you should test some older boot disks or Ubuntu boot disks to narrow down the cause.

I just tried to install the e1000e-dkms driver. Of course I first installed the headers as per your post and rebooted. But during installation I get the following error messages:

Building module:
cleaning build area...(bad exit status: 2)
make -j4 KERNELRELEASE=5.3.6-1-MANJARO KVERSION=5.3.6-1-MANJARO BUILD_KERNEL=5.3.6-1-MANJARO...(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.3.6-1-MANJARO (x86_64)
Consult /var/lib/dkms/e1000e/3.6.0/build/make.log for more information.
error: command failed to execute correctly
:: Running post-transaction hooks...
(1/2) Install DKMS modules
==> dkms install e1000e/3.6.0 -k 5.3.6-1-MANJARO
Error! Bad return status for module build on kernel: 5.3.6-1-MANJARO (x86_64)
Consult /var/lib/dkms/e1000e/3.6.0/build/make.log for more information.
==> dkms install e1000e/3.6.0 -k 4.9.196-1-MANJARO
Error! Bad return status for module build on kernel: 4.9.196-1-MANJARO (x86_64)
Consult /var/lib/dkms/e1000e/3.6.0/build/make.log for more information.
==> dkms install e1000e/3.6.0 -k 5.2.21-1-MANJARO
Error! Bad return status for module build on kernel: 5.2.21-1-MANJARO (x86_64)
Consult /var/lib/dkms/e1000e/3.6.0/build/make.log for more information.

The mentioned log shows the following:

DKMS make.log for e1000e-3.6.0 for kernel 5.2.21-1-MANJARO (x86_64)
Do Okt 17 17:39:37 CEST 2019
make: *** No targets.  Stop.

Try installing kernel 4.14 and then try installing the dkms driver on kernel 4.14.

Install and test the older linux-firmware packages going all the way back to the beginning of the year. There has been a lot of firmware issues with Intel adapters for a while now. The firmware is the most likely suspect if it is not an actual hardware failure

Is your clock out of sync?

Maybe that's your problem.

Be sure to test kernel 4.19 as well.

I tried now an older Manjaro boot disk with Kernel 4.19, but there the network does not work as well. Will try it with another distro just to be sure, but then I think it is a HW issue.

Clock is showing correct, local time.

Downgrading Firmware is one more thing I will try. As I have now a lot to do, I will report back once I tried everything. :grinning:

Thank you for your help and suggestions so far, very appreciated!

1 Like

Are you dual booting?

There are a couple of other possibilities that may help.

A network adapter not being detected properly can sometimes be hard to correct. Changing the BIOS settings may help in this situation (as well as power cycling). Below are several methods that may help with raising your adapter.

Power down the laptop and remove the battery and power plug. Let the laptop sit without power for a few minutes. Then, hold down the power button for approximately 30 seconds. Pressing the power button will help drain all left over power from the unit’s motherboard.

Then reattach the AC power (no battery), and restart. Boot into your bios, then reset the bios to the factory defaults, save the default settings. See if it will boot correctly with the factory default settings. If not, you may have to change a few settings in the BIOS (such as secure boot) to get Manjaro to boot correctly. After rebooting your adapter may be properly detected and initialized.

This is a longshot, but you never know.

Try changing your network interface name in /etc/default/grub:

Add the GRUB kernel boot parameter "net.ifnames=0":

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ net.ifnames=0"/g' -i /etc/default/grub

After adding the boot parameter, run:

sudo update-grub 

Then reboot.

Thank you once again for your patience and time invested to help me @tbg! I was finally able to solve the problem. It was something very surprising: It seems that the AC adapter connected to the docking station is not working at full power. But everything except the network is working normal, also laptop was getting charged any everything. Only this da** network was not working. Changing the power adapter solved the issue.

1 Like

Nice find, I'm glad you solved your issue.

I marked your last post as the solution.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by